Jump to the post that solved this thread.
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: 1 Year, 3 Months ago [General] Category visibility & forum permissions
#11
Solved: 1 Year, 3 Months ago
Sure, no problem. This is from my local copy, at least there is visible some error (link to download because it is too long for pastebin and too big for attachment [12MB]):
https://nofile.io/f/PTbNWwEtBsO/MyBB.txt

Thanks for showing interest.

@Edit:
There is no record like forumpermissions in mybb_datacache table in my local copy, but exist in VPS. Maybe it is something different than this.


Attached Files Thumbnail(s)
   
Reply
#12
Solved: 1 Year, 3 Months ago
(05-13-2018, 06:30 PM)QuatZo Wrote: Sure, no problem. This is from my local copy, at least there is visible some error (link to download because it is too long for pastebin and too big for attachment [12MB]):
https://nofile.io/f/PTbNWwEtBsO/MyBB.txt

Thanks for showing interest.

@Edit:
There is no record like forumpermissions in mybb_datacache table in my local copy, but exist in VPS. Maybe it is something different than this.

Do you have a recent backup of your database?

Looks like something got totally messed up somewhere... I can't pinpoint it, but it seems to be that the database is out of whack.

I'd would restore the latest DB backup and see if that fixes the problem.
I'm Serpius and You're Not    ¯\_(ツ)_/¯
[Image: 5M7sb0n.png?1]
Reply
#13
Solved: 1 Year, 3 Months ago
How many forums and groups do you have? It seems to me the db server is just going out of time.
Reply
#14
Solved: 1 Year, 3 Months ago
@Serpius
It should be somewhere on VPS because there is enabled auto-backup.

@Omar G.
45k posts, 15k threads, 13k users, 60 forums (every forum has ~5 subforums), 30 user groups.
I will try to increase downtime for DB server in few hours, will edit post with results.

@Edit:
Server settings were like below:
wait_timeout = 1800
max_allowed_packet = 128M

Did the same settings for my local copy and it works, but on local. Still have problem with VPS version. Problem with VPS is... I can't see error like with local copy. I see only HTTP 500 Error, which is useless. There is no DB error log or PHP error log.
Reply
#15
Solved: 1 Year, 3 Months ago
@Refresh:
I'm using PHP 7.x under Apache on my local copy, but on VPS there is PHP5-FPM (PHP 5.5.30). Can it have something to do with my problem?

As I previously stated, now settings for both MySQL's are the same on both machines. Local copy doesn't have any problem, but it still doesn't work on VPS.

@Edit:
It works fine for clear installation (VPS). Looks like it's something wrong with actual database or DB timeouts, maybe merge system didn't merge everything.
Reply
#16
Solved: 1 Year, 3 Months ago
I'm not sure if this will fix your issue but perhaps using another cache system will work?
https://mybb.com/features/performance/
https://community.mybb.com/thread-120313.html
Reply
#17
Solved: 1 Year, 3 Months ago
Oh my God, I'm so stupid... I'm really sorry that I was bothering you. I should've checked it at the first place, don't know why I didn't do it.

Solution:
In php.ini (/etc/php5/fpm/php.ini - my version) there are 2 commands:
max_execution_time x
max_input_time x
which were set to 30 and 15, which I changed to 600 and 180 respectively. Now everything works fine.
How did I get to this? Because even with eAccelerator, XCache or files cache (Omar's idea), the problem still exists, so I decided that problem is on the PHP side.

The forumpermissions command is so long (more than 410 000 lines) that PHP was aborting execution because of low execution time.

One more time, I would like to thank you with helping me solve this problem. I feel really sorry for you trying to understand my broken english.
Reply
#18
Solved: 1 Year, 3 Months ago
Understanding you wasn't difficult, the thing was finding the problem. Thank you for sharing the answer.
Reply
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)