[Duplicate] modlog.php missing a semicolon
#1
Hi,

I wanted to visit the moderator log page on admin the front end page, and:


Quote:Parse error: syntax error, unexpected '$table' (T_VARIABLE) in /home/xxxxxxxxxxx/forum/adminpath/modules/tools/modlog.php on line 286


line 284:
$plugins->run_hooks("admin_tools_modlog_modlogs_result")
no semicolor
$plugins->run_hooks("admin_tools_modlog_modlogs_result");
fixed.
Reply
#2
The issue is known and has already been fixed.
https://github.com/mybb/mybb/pull/3060/files

I guess some hotfix was also released about 2 months back...
Reply
#3
(2018-05-14, 12:44 PM)effone Wrote: The issue is known and has already been fixed.
https://github.com/mybb/mybb/pull/3060/files

I guess some hotfix was also released about 2 months back...

why the file has not been changed if it is a known and fixed issue? 
I mean, I installed MyBB 1 week ago "a fresh installation 1.8.15", and that line didn't have a semicolon...
Reply
#4
Because we have not yet released 1.8.16.
If you check the repository at Github the file is corrected.
https://github.com/mybb/mybb/blob/featur...g.php#L284

This was a typo. Sorry for your inconvenience ...
Reply
#5
@effone

https://github.com/mybb/mybb/blob/featur...modlog.php
the file is patched,

but the same file in mybb dl page https://mybb.com/download/
is not patched

(2018-05-14, 12:55 PM)effone Wrote: Because we have not yet released 1.8.16.
If you check the repository at Github the file is corrected.
https://github.com/mybb/mybb/blob/featur...g.php#L284

This was a typo. Sorry for your inconvenience ...

alright,
thank you
Reply
#6
(2018-05-14, 12:56 PM)ZerefGG Wrote: @effone

https://github.com/mybb/mybb/blob/featur...modlog.php
the file is patched,

but the same file in mybb dl page https://mybb.com/download/
is not patched

(2018-05-14, 12:55 PM)effone Wrote: Because we have not yet released 1.8.16.
If you check the repository at Github the file is corrected.
https://github.com/mybb/mybb/blob/featur...g.php#L284

This was a typo. Sorry for your inconvenience ...

alright,
thank you

correct because the file located at mybb.com/download is 1.8.15, not 1.8.16, where this issue is fixed.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)