Jump to the post that solved this thread.
Solved: 3 Years, 1 Month, 4 Weeks ago [Error Message] Uncaught js errors in console
#1
Solved: 3 Years, 1 Month, 4 Weeks ago
Hello MyBB Community,
I'm having a problem with posts quoting on my board.
These are the error i get : 
[Image: image.png]

If you're able to understand what those errors means i'd like to know,
And ofc would love to get a solution.

Thanks in advnaced, Afik.
Reply
#2
Solved: 3 Years, 1 Month, 4 Weeks ago
(2018-08-22, 06:27 PM)tphe1234 Wrote: Hello MyBB Community,
I'm having a problem with posts quoting on my board.
These are the error i get : 
[Image: image.png]

If you're able to understand what those errors means i'd like to know,
And ofc would love to get a solution.

Thanks in advnaced, Afik.


Do you have your AdminCP → Board Settings → Site Details set up like you see in the screenshot below? 

Look at the cookies part. SameSite Cookie Flag and Secure Cookie Flag

[Image: d7018c2041b98e176c94629f8dde547a.png]
I'm Serpius and You're Not    ¯\_(ツ)_/¯
LUXOR FORUMS
Reply
#3
Solved: 3 Years, 1 Month, 4 Weeks ago
Hay @Serpius, Thanks for replying.
Cookie settings on my board looks fine,Cant find anything wrong over there.
But yet haven't found any solution for this errors hope to find one soon.
Reply
#4
Solved: 3 Years, 1 Month, 4 Weeks ago
(2018-08-22, 09:55 PM)tphe1234 Wrote: Hay @Serpius, Thanks for replying.
Cookie settings on my board looks fine,Cant find anything wrong over there.
But yet haven't found any solution for this errors hope to find one soon.

I feel the reason is because you don't have the cookieSecureFlag variable in headerinclude, add this code in the headerinclude template
	var cookieSecureFlag = "{$mybb->settings['cookiesecureflag']}";

It should be in this place ->
	var cookieDomain = "{$mybb->settings['cookiedomain']}";
	var cookiePath = "{$mybb->settings['cookiepath']}";
	var cookiePrefix = "{$mybb->settings['cookieprefix']}";
	var cookieSecureFlag = "{$mybb->settings['cookiesecureflag']}";

Regards
WallBB
Reply
#5
Solved: 3 Years, 1 Month, 4 Weeks ago
(2018-08-23, 06:40 AM)WallBB Wrote:
(2018-08-22, 09:55 PM)tphe1234 Wrote: Hay @Serpius, Thanks for replying.
Cookie settings on my board looks fine,Cant find anything wrong over there.
But yet haven't found any solution for this errors hope to find one soon.

I feel the reason is because you don't have the cookieSecureFlag variable in headerinclude, add this code in the headerinclude template
	var cookieSecureFlag = "{$mybb->settings['cookiesecureflag']}";

It should be in this place ->
	var cookieDomain = "{$mybb->settings['cookiedomain']}";
	var cookiePath = "{$mybb->settings['cookiepath']}";
	var cookiePrefix = "{$mybb->settings['cookieprefix']}";
	var cookieSecureFlag = "{$mybb->settings['cookiesecureflag']}";

Regards
WallBB

Yes!
It worked wonderly thank you very much @WallBB, Much appreiciated.

All the best, Afik.
Reply
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)