Jump to the post that solved this thread.
Solved: 2 Years, 1 Month, 3 Weeks ago Private message title and sender
#1
Solved: 2 Years, 1 Month, 3 Weeks ago
Hello to all MYBB experts
i have a problem with the ptivate messages
recently i updated mybb to the lastest version, all is ok but:
1:  the private message title for new message is not BOLD 
its used to be bold so i can recognize it easy,
2: also the sender of the private message was clickable , when i click on it , it take me to his profile .
this 2 option stoped worked
can anyone help me

[Image: 01.png]

Best regrads
Reply
#2
Solved: 2 Years, 1 Month, 3 Weeks ago
(2019-06-06, 04:20 PM)feeling_bored Wrote: Hello to all MYBB experts
i have a problem with the ptivate messages
recently i updated mybb to the lastest version, all is ok but:

Hi,

sorry but you updated MyBB, but your theme it's not updated, and there is where the problem is.

Proof:
<script type="text/javascript" src="http://auto-file.org/jscripts/jquery.js?ver=1806"></script>
<script type="text/javascript" src="http://auto-file.org/jscripts/jquery.plugins.min.js?ver=1806"></script>
<script type="text/javascript" src="http://auto-file.org/jscripts/general.js?ver=1810"></script>

<script type="text/javascript">
 // <!--
 if(use_xmlhttprequest == "1")
 {
 $("#thread_modes").popupMenu();
 }
 // -->
 </script>
 <script type="text/javascript">
 $(".author_avatar img").error(function () {
 $(this).unbind("error").closest('.author_avatar').remove();
 });
 </script>
</body>
</html>
<!-- end: showthread -->

So sure the Private Messages template have to be updated as others parts of the theme.
I don't answer questions about localhost forums or forums without URL, I'm not a seer.  Cool
Reply
#3
Solved: 2 Years, 1 Month, 3 Weeks ago
(2019-06-06, 04:31 PM)NoRules Wrote:
(2019-06-06, 04:20 PM)feeling_bored Wrote: Hello to all MYBB experts
i have a problem with the ptivate messages
recently i updated mybb to the lastest version, all is ok but:

Hi,

sorry but you updated MyBB, but your theme it's not updated, and there is where the problem is.

Proof:
<script type="text/javascript" src="http://auto-file.org/jscripts/jquery.js?ver=1806"></script>
<script type="text/javascript" src="http://auto-file.org/jscripts/jquery.plugins.min.js?ver=1806"></script>
<script type="text/javascript" src="http://auto-file.org/jscripts/general.js?ver=1810"></script>

<script type="text/javascript">
 // <!--
 if(use_xmlhttprequest == "1")
 {
 $("#thread_modes").popupMenu();
 }
 // -->
 </script>
 <script type="text/javascript">
 $(".author_avatar img").error(function () {
 $(this).unbind("error").closest('.author_avatar').remove();
 });
 </script>
</body>
</html>
<!-- end: showthread -->

So sure the Private Messages template have to be updated as others parts of the theme.

mu website is auto-epc.org , not autofile , 
can you check that
Reply
#4
Solved: 2 Years, 1 Month, 3 Weeks ago
(2019-06-06, 06:01 PM)feeling_bored Wrote: mu website is auto-epc.org , not autofile , 
can you check that

Oops, my fault, but same problem, or even worse, because the theme it's not updated since the 18.04 version of MyBB...

Knowing that, if you want to bold the new private messages:

Admin Control Panel > Templates & Style (Tab) > Themes > YOUR THEME > global.css > Edit Stylesheet: Advanced Mode (Tab)

And add this at the end:
.new_pm {
font-weight: bold;
}

And save.
I don't answer questions about localhost forums or forums without URL, I'm not a seer.  Cool
Reply
#5
Solved: 2 Years, 1 Month, 3 Weeks ago
thats awesone ,, its work now
and how can i make the sender id clickable , click on it to take me to his profile 
thanks sir
Reply
#6
Solved: 2 Years, 1 Month, 3 Weeks ago
Hi,

could you please copy/paste here the private_messagebit template of your theme?
(Admin Control Panel > Templates & Style (Tab) > Templates (Left Column) > YOUR THEME > Private Messaging Templates > private_messagebit)
I don't answer questions about localhost forums or forums without URL, I'm not a seer.  Cool
Reply
#7
Solved: 2 Years, 1 Month, 3 Weeks ago
<tr>
	<td align="center" class="trow1" width="1%"><img src="{$theme['imgdir']}/{$msgstatus}.png" alt="{$msgalt}" title="{$msgalt}" /></td>
	<td align="center" class="trow2" width="1%">{$icon}</td>
	<td class="trow1" width="35%"><a class="{$msgstatus}" href="private.php?action=read&amp;pmid={$message['pmid']}">{$message['subject']}</a>{$denyreceipt}</td>
	<td align="center" class="trow2">{$tofromusername}</td>
	<td class="trow1" align="right" style="white-space: nowrap"><span class="smalltext">{$senddate}</span></td>
	<td class="trow2" align="center"><input type="checkbox" class="checkbox" name="check[{$message['pmid']}]" value="1" /></td>
</tr>
Reply
#8
Solved: 2 Years, 1 Month, 3 Weeks ago
Hi,

the template it's OK. Maybe it's a plugin that changes the author's profile link.

I don't know what could cause it.
I don't answer questions about localhost forums or forums without URL, I'm not a seer.  Cool
Reply
#9
Solved: 2 Years, 1 Month, 3 Weeks ago
The non clickable names is not theme related. The same issue is happening on all of the themes installed on your site. Your templates are showing as Forum Bit {1} Templates on all themes.

Also file verification shows this message in your admin panel.
Quote:The following errors were encountered:
There was a problem communicating with the MyBB server. Please try again in a few minutes.
[Image: sig2.jpg]
Reply
#10
Solved: 2 Years, 1 Month, 3 Weeks ago
solved
i replaced
<td align="center" class="trow2">{$tofromusername}</td>
with
<td align="center" class="trow2"><a href="member.php?action=profile&uid={$tofromuid}">{$tofromusername}</a></td>
Reply
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)