Jump to the post that solved this thread.
Solved: 1 Year, 3 Months ago Custom thread fields disappears from thread after upgrade to 1.8.29
Solved: 1 Year, 3 Months ago
My Custom thread fields disappear from the threads after upgrading to 1.8.29.
On edit thread, there are all custom thread fields but on thread not displaying them
How to fix it?

help pleas to fix it.

All templates related to xthreads are in place.
Help to fix it.
Solved: 1 Year, 3 Months ago
Please help, all templates checked. All are same as comparing with another 1.8.24 localhost board.
Some php files changed so it not displaying custom thread fields on postbit.
Guide please.

It occurs from upgrade 1.8.26 to 1.8.27.
Solved: 1 Year, 3 Months ago
Have a look at the error log.

It may be related to parser validation: https://docs.mybb.com/1.8/faq/errors/#pa...ion-failed
devilshakerz.com/pgp (DF3A 34D9 A627 42E5 BC6A 6750 1F2F B8AA 28FF E1BC) ▪ keybase.io/devilshakerz
Solved: 1 Year, 3 Months ago
Thank devilshackers.

There are no errors or empty posts.

But all the custom thread field related to xthreads disappears from the first post of all threads. On full edit of first pot of the thread, there are custom thread fields are present.

I try _parser-debug.php and it shows validates correctly.

I change $output_validation_policy value from VALIDATION_REQUIRE to VALIDATION_REPORT_ONLY in class_parse.php file but the issue is still present.

No, an error log was created after the upgrade to 1.8.27.
How to find the solution.
Thank you.

It looks like postbit_first and postbit_first_classic templates not loading.
Up to 1.8.26, both templates work fine but after that not work.
It's my thinking that it's not related to xthread. but it's due to changes in some core files in 1.8.27 and onward versions.
Hope I will get a fix for this.
Thank you.

I install a fresh copy of 1.8.27 and install xthread and create one custom thread field.
Created postbit_first and postbit_first_classic templates.
I also added {first_post} in shwothrad template..
But that created custom thread field not seen in first post of the thread even there is custom thread field in full edit of 1st post.

Below is the postbit_first_classic template:
<a name="pid{$post['pid']}" id="pid{$post['pid']}"></a>
<div class="post classic {$unapproved_shade}" style="{$post_visibility}" id="post_{$post['pid']}">
<div class="post_author scaleimages">
	<div class="author_information">
			<strong><span class="largetext">{$post['profilelink']}</span></strong> {$post['onlinestatus']}<br />
			<span class="smalltext">
				{$post['usertitle']}<br />
	<div class="author_statistics">
<div class="post_content">
	<div class="post_head">
		<span class="post_date">{$post['postdate']} <span class="post_edit" id="edited_by_{$post['pid']}">{$post['editedmsg']}</span></span>
	<div class="post_body scaleimages" id="pid_{$post['pid']}">
		<br/><br/><br class="clear" />
		<span class="largetext" style="color:#8761c3;font-size: 20px" ><center><strong> !!! Free Download Links !!!</strong></center></span>	
<div class="thread-content1 text-center largetext bg-info-o-10 ">{$GLOBALS['threadfields']['Free_Link']}</div>	
<br />	
	<div class="post_meta" id="post_meta_{$post['pid']}">
		<div class="float_right">
<div class="post_controls">
	<div class="postbit_buttons author_buttons float_left">
	<div class="postbit_buttons post_management_buttons float_right">
Solved: 1 Year, 3 Months ago
Its fix is here...

Thanks to Omar G for this.
Jump to the post that solved this thread.

Forum Jump:

Users browsing this thread: 1 Guest(s)