Jump to the post that solved this thread.
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: 8 Years, 8 Months, 3 Weeks ago View Forum Button in CP
#1
Solved: 8 Years, 8 Months, 3 Weeks ago
I am having only one issue with the fresh install of MYBB, so far.

In the Dashboard, when I click View Forum. It takes me to the folder and not the Index.php of that folder. So, the page is Blank.

Is there a Location to change...

http://twistedtoys.sexyi.am/Upload/

to

http://twistedtoys.sexyi.am/Upload/index.php

for that button?

When you click the View Forum, preview button you get http://twistedtoys.sexyi.am/Upload/

This is my version and info below.
MyBB Version 1.6.9
PHP Version 5.2.17
SQL Engine MySQLi 5.1.61
Server Load 11.83

Thanks for your help. I searched for an hour before I posted.
#2
Solved: 8 Years, 8 Months, 3 Weeks ago
I don't really see what the purpose is, and this edit will be reverted if you need to upgrade the file.

Go to /admin/inc/class_page.php

Find:
<a href=\"{$mybb->settings['bburl']}\" target=\"_blank\" class=\"forum\">

Replace with:
<a href=\"{$mybb->settings['bburl']}/index.php\" target=\"_blank\" class=\"forum\">

<a href=\"{$mybb->settings['bburl']}\index.php" target=\"_blank\" class=\"forum\">
Need web hosting? Try MyBBWebHost!
#1 for Running MyBB Communities
The world's only premium web host dedicated to MyBB forums.

#3
Solved: 8 Years, 8 Months, 3 Weeks ago
(2013-01-24, 12:03 AM)Zash Wrote: I don't really see what the purpose is, and this edit will be reverted if you need to upgrade the file.

I just figured from my previous MYBB installation over a year ago. When I click ( View Forum) it would!

I did as you said and got this message...

Parse error: syntax error, unexpected T_STRING, expecting ',' or ';' in /home/u705822466/public_html/Upload/admin/inc/class_page.php on line 122

when I add index.php to line 122. I get the error. When I remove it, Dashboard opens fine.
#4
Solved: 8 Years, 8 Months, 3 Weeks ago
My bad, replace with this:

<a href=\"{$mybb->settings['bburl']}/index.php\" target=\"_blank\" class=\"forum\">
Need web hosting? Try MyBBWebHost!
#1 for Running MyBB Communities
The world's only premium web host dedicated to MyBB forums.

#5
Solved: 8 Years, 8 Months, 3 Weeks ago
(2013-01-24, 12:30 AM)Zash Wrote: My bad, replace with this:

<a href=\"{$mybb->settings['bburl']}/index.php\" target=\"_blank\" class=\"forum\">

That was the problem. Thank you, for your quick response. I just downloaded the modified file for future use. Big Grin

I hope I did the solved thing properly for future users.
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)