MyBB Community Forums
[For 1.6] Google SEO 1.6.8 [EOL] - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Resources (https://community.mybb.com/forum-8.html)
+--- Forum: Plugins (https://community.mybb.com/forum-73.html)
+---- Forum: Plugin Releases (https://community.mybb.com/forum-102.html)
+---- Thread: [For 1.6] Google SEO 1.6.8 [EOL] (/thread-101262.html)



RE: Google SEO 1.6.8 - Eldenroot - 09-27-2014

Why? It is working fine... just few changes


RE: Google SEO 1.6.8 - [email protected] - 09-27-2014

(09-27-2014, 01:59 PM)Destroy666 Wrote: You need to enable plugins in ACP -> Configuration -> General Configuration -> Disable All Plugins?

Great mate Smile forget after upgrade to disable this. issue is fixed.
tc
http://www.oraerp.com


RE: Google SEO 1.6.8 - dimxo - 11-06-2014

""First of all, this is my third account. And i request you not to delete this. Becuase i am not a spammer. My first account was deal94350, which i tried hard to recover password but could not, i dont know what is the problem. Next i created another account named deal94351, which was banned because i made second account. So both my accounts are inaccessible so i created third account.""~ This message is for mybb support

Now Please help me, I installed google seo 1.6.8 on my forum. I changed the compatibility to 18.
And copied the required file
Code:
RewriteEngine on

# Some hosts require RewriteBase to make RewriteRules work.
RewriteBase /forums/

# Google SEO workaround for search.php highlights:
# Make this rule the first rewrite rule in your .htaccess!
RewriteRule ^([^&]*)&(.*)$ http://offerdarbar.com/forums/$1?$2 [L,QSA,R=301]

# Google SEO 404:
ErrorDocument 404 /forums/misc.php?google_seo_error=404

# Google SEO Sitemap:
RewriteRule ^sitemap\-([^./]+)\.xml$ misc.php?google_seo_sitemap=$1 [L,QSA,NC]

# Google SEO URL Forums:
RewriteRule ^Forum\-([^./]+)$ forumdisplay.php?google_seo_forum=$1 [L,QSA,NC]

# Google SEO URL Threads:
RewriteRule ^Thread\-([^./]+)$ showthread.php?google_seo_thread=$1 [L,QSA,NC]

# Google SEO URL Announcements:
RewriteRule ^Announcement\-([^./]+)$ announcements.php?google_seo_announcement=$1 [L,QSA,NC]

# Google SEO URL Users:
RewriteRule ^User\-([^./]+)$ member.php?action=profile&google_seo_user=$1 [L,QSA,NC]

# Google SEO URL Calendars:
RewriteRule ^Calendar\-([^./]+)$ calendar.php?google_seo_calendar=$1 [L,QSA,NC]

# Google SEO URL Events:
RewriteRule ^Event\-([^./]+)$ calendar.php?action=event&google_seo_event=$1 [L,QSA,NC]

to .htaccess

All the google seo settings are default and activated.

Now when i applied changes to core files after that the thread urls and all urls changed as said but i am getting 404 error.

Please help.


RE: Google SEO 1.6.8 - fonta - 11-06-2014

Don't know what server you're on? Might be that the .htaccess is not being applied.
This is the case when you're on nginx or iis.


RE: Google SEO 1.6.8 - dimxo - 11-06-2014

Thnks for replying so fast.

Is there any solution for this. Or is there any other thing for which this might happen. I have wordpress installed in the root directory and mybb installed in /forums directory.


RE: Google SEO 1.6.8 - frostschutz - 11-06-2014

Wordpress may be blocking it. Google for wordpress ignore directory or somesuch.
Make the Wordpress .htaccess ignore /forums


RE: Google SEO 1.6.8 - fonta - 11-06-2014

I'm also having wordpress in the root, and mybb in a subfolder. It's not getting affected by wordpress on my server.

This is what I have in my .htaccess file in the root folder:
Code:
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress #



RE: Google SEO 1.6.8 - dimxo - 11-06-2014

Thnks for replying.

I will try and tell you the results.

I got one solution



""" For any normal directory, just create it and it'll work. No changes needed.

When you're using password protection, you'll need to modify WordPress' .htaccess file slightly.

The workaround is to create an empty file somewhere called "onerror.html" and then to add these lines to the main .htaccess, before the WordPress rules:

ErrorDocument 401 /onerror.html
ErrorDocument 403 /onerror.html

Change the path as appropriate for your setup, of course."""


I made empty onerror.html and uploaded into the root folder.

And then added

ErrorDocument 401 /onerror.html
ErrorDocument 403 /onerror.html

in .htacces before wordpress, but its not working

fonta
i also have the same .htaccess rule for wordpress like you..


RE: Google SEO 1.6.8 - frostschutz - 11-06-2014

ErrorDocument is bullshit. You need a RewriteCond most likely...


RE: Google SEO 1.6.8 - dimxo - 11-06-2014

I used this as well RewriteRule ^forums - [L,NC]
where forums is the directory on which my forum is installed.
Please help...i am unable to do it..