MyBB Community Forums
[For 1.6] Google SEO 1.6.8 [EOL] - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Resources (https://community.mybb.com/forum-8.html)
+--- Forum: Plugins (https://community.mybb.com/forum-73.html)
+---- Forum: Plugin Releases (https://community.mybb.com/forum-102.html)
+---- Thread: [For 1.6] Google SEO 1.6.8 [EOL] (/thread-101262.html)



RE: Google SEO 1.6.8 - frostschutz - 02-01-2016

(02-01-2016, 05:24 PM)boson Wrote: very disappointed Sad

[Image: cry-moar.jpg]


RE: Google SEO 1.6.8 - ChillBro - 02-03-2016

Now when I log out I am redirected back to the index.php page. How can I fix that issue?

Edit: Solved


RE: Google SEO 1.6.8 - boson - 02-04-2016

<-- snip -->
anyways .

This "MySeo" plugin works well very if you want to use http://community.mybb.com/mods.php?action=view&pid=359

I see good ranking and google analytic etc.


RE: Google SEO 1.6.8 - ChillBro - 02-04-2016

One more question. I had added this line of code
PHP Code:
DirectoryIndex forumdisplay.php?fid=2 index.php 
added to .htaccess before my Google SEO installation. This redirected my websires url to my forum page and made it appear like this 'mysite.com' without the 'forumdisplay.php?fid=2 index.php' trailing. 

I have left this line of code and it still redirects from the index.php page but now we see 'mysite.com/Forum-general-discussion' instead of 'mysite.com'. I have attempted to remove the code and use Google Tweaks but that just redirects everything to the index.php page.

Can someone please help me address this issue?

Thanks in advance!


RE: Google SEO 1.6.8 - frostschutz - 02-06-2016

@ChillBro,

first of all you should add index.html index.htm at the end of your DirectoryIndex directive so that regular index still work in subdirs.

About your redirect issue, you're kind of fighting Google SEO Redirect there, which redirects every item to its canonical URL to avoid duplicate content. The canonical URL for a forum is of course its forum URL of which you may have several ones:

* forumdipslay.php?fid=2
* forum-2.html
* forum-2-page-1.html
* ...
* Forum-General-Discussion

And Google SEO Redirect takes all of these and redirects them all to whatever your current URL style is. So if you make the index point to a forum it redirects to its forum URL.

If you absolutely must have a forum as index you have several options...

* You could simply deactivate Google SEO Redirect (at the cost of losing all other redirects as well)
* You could edit forumdisplay.php to disable redirect selectively for the fid=2 case
* You could edit inc/functions.php::get_forum_link() to return '' (empty string) for the fid=2 case.

That would make the index be the canonical URL for this forum and Google SEO Redirect would redirect to the index for that forum; however there may be some functions that misunderstand the empty string return value as false/no URL. Not sure if there is a if(get_forum_link()) anywhere in MyBB or any of MyBB's plugins. Hopefully not but you never know.

Basically what you're asking for is not really part of the concept; I won't provide further help on this, you'll have to figure it out on your own.


RE: Google SEO 1.6.8 - jaydee9296 - 02-06-2016

is there any way that the url will only use id's?

For example

forum-"id"
thread-"id"

is that possible and how to do it if it so?


RE: Google SEO 1.6.8 - frostschutz - 02-06-2016

It's possible using the "force uniquifier" setting and you can actually remove {url} from the uniquifier so only the ID remains. But it might be easier to achieve with a core edit since that already has that style (just with .html added at the end) or just by sticking to the official URLs.


RE: Google SEO 1.6.8 - jaydee9296 - 02-06-2016

(02-06-2016, 11:20 PM)frostschutz Wrote: It's possible using the "force uniquifier" setting and you can actually remove {url} from the uniquifier so only the ID remains. But it might be easier to achieve with a core edit since that already has that style (just with .html added at the end) or just by sticking to the official URLs.

Ahh I see. But it didn't work Sad Can you do it for me? Sad It's very hard though and it gives me error right I did your instructions. Sad


RE: Google SEO 1.6.8 - ChillBro - 02-07-2016

(02-06-2016, 01:04 PM)frostschutz Wrote: @ChillBro,

first of all you should add index.html index.htm at the end of your DirectoryIndex directive so that regular index still work in subdirs.

About your redirect issue, you're kind of fighting Google SEO Redirect there, which redirects every item to its canonical URL to avoid duplicate content. The canonical URL for a forum is of course its forum URL of which you may have several ones:

* forumdipslay.php?fid=2
* forum-2.html
* forum-2-page-1.html
* ...
* Forum-General-Discussion

And Google SEO Redirect takes all of these and redirects them all to whatever your current URL style is. So if you make the index point to a forum it redirects to its forum URL.

If you absolutely must have a forum as index you have several options...

* You could simply deactivate Google SEO Redirect (at the cost of losing all other redirects as well)
* You could edit forumdisplay.php to disable redirect selectively for the fid=2 case
* You could edit inc/functions.php::get_forum_link() to return '' (empty string) for the fid=2 case.

That would make the index be the canonical URL for this forum and Google SEO Redirect would redirect to the index for that forum; however there may be some functions that misunderstand the empty string return value as false/no URL. Not sure if there is a if(get_forum_link()) anywhere in MyBB or any of MyBB's plugins. Hopefully not but you never know.

Basically what you're asking for is not really part of the concept; I won't provide further help on this, you'll have to figure it out on your own.

Why would I be denied support for this? I'm not trying to be insulting here but Isn't that what the 'Google Tweaks' option is supposed to be for? Maybe I'm mistaken, sorry if so...


RE: Google SEO 1.6.8 - frostschutz - 02-08-2016

(02-07-2016, 08:42 PM)ChillBro Wrote: Isn't that what the 'Google Tweaks' option is supposed to be for?

Rolleyes Shy Confused

This plugin has too many settings for me to remember.

What have you set it to? It should work if set to (in your case) 2...

Instead of the DirectoryIndex directive you might need a rewrite rule like so:

Code:
RewriteRule ^/?$ /forumdisplay.php?fid=2 [L,QSA]

since it might be that apache otherwise discards parameters like ?page=2 so they would all redirect to the first page of the forum. not sure if that was your problem actually...