MyBB Community Forums
[For 1.6] Google SEO 1.6.8 [EOL] - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Resources (https://community.mybb.com/forum-8.html)
+--- Forum: Plugins (https://community.mybb.com/forum-73.html)
+---- Forum: Plugin Releases (https://community.mybb.com/forum-102.html)
+---- Thread: [For 1.6] Google SEO 1.6.8 [EOL] (/thread-101262.html)



RE: Google SEO 1.6.8 - Starnova - 05-29-2016

Hi, I just wanted to tell you that I installed it without any issues. Perfect and this is easier than installing it on previous versions as I remember. Thank you for keeping up to date on this great  plugin !


RE: Google SEO 1.6.8 - xecollons - 07-09-2016

Hello,

I have moved my forum to another server and using another domain. Now the GOOGLE URLs don't work anymore. The url "http://www.mysite.com/forum/forum-firstforum" doesn't work. The subfolder(forum) and the forum prefix is the same. I have changed .htaccess.

Is there anything more that I can do?

Thanks.


RE: Google SEO 1.6.8 - Donald_Duck - 07-12-2016

(07-09-2016, 09:16 PM)xecollons Wrote: Hello,

I have moved my forum to another server and using another domain. Now the GOOGLE URLs don't work anymore. The url "http://www.mysite.com/forum/forum-firstforum" doesn't work. The subfolder(forum) and the forum prefix is the same. I have changed .htaccess.

Is there anything more that I can do?

Thanks.

Did you enter new domain name in "Site Detail" - ACP !
Also, you need to edit "settings.php" with proper domain detail [Cookie optional]


RE: Google SEO 1.6.8 - groovybluedog - 07-30-2016

What would be the correct way to still include the thread/forum ID number in the URL?

Would (haven't tried it yet) changing Thread-{url} to Thread-{url}-{id} be sufficient? If {id} would even work!

EDIT: Adding "{id}" shows exactly that as plain text Sad

Still an excellent plugin that does all it says Big Grin


RE: Google SEO 1.6.8 - frostschutz - 07-30-2016

If you absolutely must have nonsensical numbers in your URLs, try the "force uniquifier" option.


RE: Google SEO 1.6.8 - groovybluedog - 08-02-2016

Hmmm oddly, now I have directed domain.com to domain.com/web - as /web is where my forum is - this plugin has generated a "Page cannot redirect properly" when you go to domain.com/web - but domain.com/web/index.php works fine.

Tried all sorts of mixtures of htaccess, even making a blank one which worked, adding in the URL SEO rules from this plugin, then it stops working. Confused


RE: Google SEO 1.6.8 - frostschutz - 08-02-2016

Is your bburl set correctly? Any warnings on the plugins page? URL to your site?

Redirecting an entire domain to /web sounds strange. Would it redirect /web to /web/web, that would never end?


RE: Google SEO 1.6.8 - groovybluedog - 08-02-2016

(08-02-2016, 04:48 PM)frostschutz Wrote: Is your bburl set correctly? Any warnings on the plugins page? URL to your site?

Redirecting an entire domain to /web sounds strange. Would it redirect /web to /web/web, that would never end?

Thank you for your reply however the issue seems to occur even with ONLY "RewriteEngine on" in the forum's .htaccess so this looks more severe than an issue with MyBB or the plugin...

I don't think so, my main .htaccess under domain.com just pushes to domain.com/web - I've used this same system for years, always putting forums under /web, Joomla under /home and then redirecting the main URL to whichever the homepage is. This is the first time I have encountered this Confused

Guess I'll contact my cPanel license provider or host as this is odd Confused

Code:
RewriteOptions inherit
RewriteEngine on

RewriteCond %{HTTP_HOST} ^.*$
RewriteRule ^/?$ "http\:\/\/domain\.com\/web" [R=301,L]



RE: Google SEO 1.6.8 - frostschutz - 08-02-2016

If you also have inherit in the .htaccess of MyBB, that may be your problem. You shouldn't need inherit here or anywhere else, so try removing it from all your (root,mybb) .htaccess files. I'm not sure if I can help you any further here, if your problem is not related to this plugin please make a separate thread for it, thank you.


RE: Google SEO 1.6.8 - groovybluedog - 08-02-2016

You were absolutely right, it was the inherit option - in quite a few places - that caused the issue. Thankfully BuycPanel found that out in less than 45 minutes of creating the ticket ;D - credit due there.

I did a bunch of testing and the plugin is working perfectly so far in all aspects. My apologies to of blamed your plugin; it was just a coincidence that some parts worked in my original diagnostics when taking parts of your plugins htaccess text out; I might of been taking out Inherit with it causing the issue to disappear...

Heavens knows but thanks for this amazing plugin that works excellently! ;D