MyBB Community Forums
[For 1.6] Google SEO 1.6.8 [EOL] - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Resources (https://community.mybb.com/forum-8.html)
+--- Forum: Plugins (https://community.mybb.com/forum-73.html)
+---- Forum: Plugin Releases (https://community.mybb.com/forum-102.html)
+---- Thread: [For 1.6] Google SEO 1.6.8 [EOL] (/thread-101262.html)



RE: Google SEO 1.6.1 - faviouz - 09-08-2011

You're using the legacy version, which requires you to manually patch the files.

Download 1.6.1 from the main post, replace all the files and you should see a bit of text that goes like "Click to Apply changes to core files." whereas "Apply" is the link you should click to perform the changes.


RE: Google SEO 1.6.1 - frostschutz - 09-08-2011

1.1.13 shouldn't be available for download anymore, at least not from the mods page here.

You can get either 1.4 (Legacy) or 1.6 (main branch for MyBB 1.6.4 and newer)


RE: Google SEO 1.6.1 - hazy - 09-08-2011

I'm not using the Legacy version, I've clicked the link as per the first post and it tallies with the mod page url also - downloaded the archive and it's "1407-1313491216-Google-SEO-1.6.1" whereas the Legacy is "2970-1313491231-google_seo_legacy_1.4.1" when extracted and I'm not using that.




RE: Google SEO 1.6.1 - frostschutz - 09-08-2011

Then you probably didn't upload all of the files or not to the correct location?


RE: Google SEO 1.6.1 - hazy - 09-08-2011

Ok, it's working now. I had the files in the right place but I also had a stray php file loose in my inc folder! I think there was some conflict there, bizarre. Well, at least if someone else has this problem they know what to do now!

Working overall, thanks a million! Glad it was only something simple! Blush

Quote:Google SEO (1.6.1)
Google Search Engine Optimization as described in the official Google's SEO starter guide. Please see the documentation for details.

404, Meta, Redirect, Sitemap and URL are enabled. (Configure)
Click to Revert changes to core files.


Created by Andreas Klauer



RE: Google SEO 1.6.1 - blake - 09-08-2011

Can I have a little help? My host said it's because the file's plugin.php and pluginlibary.php where not there but I downloading this mods form the mods site and those files where never in the package and it's causing some issues.

Quote:I installed the newest version of this plugin to update it and got this error.

Warning [2] require_once(/home/gfxcafen/public_html/inc/plugins/pluginlibrary.php) [function.require-once]: failed to open stream: No such file or directory - Line: 84 - File: inc/plugins/google_seo/plugin.php PHP 5.2.16 (Linux)
File Line Function
/inc/plugins/google_seo/plugin.php 84 errorHandler->error
/inc/plugins/google_seo/plugin.php 84 google_seo_plugin_status
/inc/plugins/google_seo/plugin.php 69 google_seo_plugin_status
/inc/plugins/google_seo.php 50 google_seo_plugin_info
/Tbzad32/modules/config/plugins.php 491 google_seo_info
/Tbzad32/index.php 483 require

Fatal error: require_once() [function.require]: Failed opening required '/home/gfxcafen/public_html/inc/plugins/pluginlibrary.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/gfxcafen/public_html/inc/plugins/google_seo/plugin.php on line 84



RE: Google SEO 1.6.1 - BBFPaco - 09-09-2011

(09-08-2011, 01:38 PM)frostschutz Wrote: ...BBFPaco: Google SEO handles the URLs by redirecting and/or specifying canonicals.

Ok, I finally implemented the meta, redirect, and URLs. So far so good. Smile

We'll see how Google likes the changes in the next month, but I think users will like the URL change.

Subconsciously, we're probably more likely to click on a friendly URL than a random forum generated one. Smile


Thanks for all your hard work on this plugin frostschutz! I'll let you know if I come across any issues.


RE: Google SEO 1.6.1 - Euan T - 09-09-2011

(09-08-2011, 11:27 PM)blake Wrote: Can I have a little help? My host said it's because the file's plugin.php and pluginlibary.php where not there but I downloading this mods form the mods site and those files where never in the package and it's causing some issues.

Quote:I installed the newest version of this plugin to update it and got this error.

Warning [2] require_once(/home/gfxcafen/public_html/inc/plugins/pluginlibrary.php) [function.require-once]: failed to open stream: No such file or directory - Line: 84 - File: inc/plugins/google_seo/plugin.php PHP 5.2.16 (Linux)
File Line Function
/inc/plugins/google_seo/plugin.php 84 errorHandler->error
/inc/plugins/google_seo/plugin.php 84 google_seo_plugin_status
/inc/plugins/google_seo/plugin.php 69 google_seo_plugin_status
/inc/plugins/google_seo.php 50 google_seo_plugin_info
/Tbzad32/modules/config/plugins.php 491 google_seo_info
/Tbzad32/index.php 483 require

Fatal error: require_once() [function.require]: Failed opening required '/home/gfxcafen/public_html/inc/plugins/pluginlibrary.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/gfxcafen/public_html/inc/plugins/google_seo/plugin.php on line 84

Have you read the documentation provided for the plugin? It requires Plugin Library v4, which you can gain from the mods site. It is not in the Google SEO package as it is a separate product.


RE: Google SEO 1.6.1 - play-connect - 09-10-2011

Great Plugin. Thanks a lot Smile


RE: Google SEO 1.6.1 - MadComp - 09-10-2011

With this plugin installed, no sub-directories work properly for me (ie. you can't just go to a URL like christnet.leetlink.com, PHP powered sites don't work, etc.).

Example: christnet.leetlink.com <- Doesn't show me as logged in, yet I got a success message (and I can login to the ACP). Another sub-domain site you can't even access it unless you add index.html to it's URL! (The only thing that makes it works is registering domains for each site, but sometimes the domain I prefer is gone.)

If you could help me solve this problem, I'd be grateful!