MyBB Community Forums
[For 1.6] Google SEO 1.6.8 [EOL] - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Resources (https://community.mybb.com/forum-8.html)
+--- Forum: Plugins (https://community.mybb.com/forum-73.html)
+---- Forum: Plugin Releases (https://community.mybb.com/forum-102.html)
+---- Thread: [For 1.6] Google SEO 1.6.8 [EOL] (/thread-101262.html)



RE: Google SEO 1.6.2 - mikekehrli - 11-27-2011

Ooops. I solved my own problem. Please ignore this post.



RE: Google SEO 1.6.2 - frostschutz - 11-27-2011

Not really, since the edits required change with the settings you choose. The edits being applied semi-automatically allowed the plugin to be more selective in the way it makes changes. You can find the possible edits in plugins/google_seo/plugin.php::google_seo_plugin_apply() though.

We really should find out why the apply is not working for you when it works for everybody else (at least I can't remember anyone complaining about the feature so far). The homepage-redirect baffles me most as there is no code anywhere in the plugin that would redirect you from the Admin CP to the forum homepage. You should be seeing either a success or failure message but stay on the plugins page in any case.

Maybe another plugin is interfering somehow?


RE: Google SEO 1.6.2 - mikekehrli - 11-27-2011

Thanks very much. I actually solved the issue. When I did my upgrade, I forgot I had changed my admin directory name for security reasons. Once I discovered that, and fixed it, everything worked great. Thanks for the great mod!


RE: Google SEO 1.6.2 - Wiz01 - 11-28-2011

I'm currently using G. SEO 1.6.1
Do i need to revert functions.php (with the revert option on the plugins page) before MyBB and G. SEO upgrade?


RE: Google SEO 1.6.2 - GhostMaster - 11-28-2011

(11-28-2011, 03:23 AM)Wiz01 Wrote: I'm currently using G. SEO 1.6.1
Do i need to revert functions.php (with the revert option on the plugins page) before MyBB and G. SEO upgrade?

No, i uploaded the files, overwrite the old ones, disabled the plugin, enabled and patched the core again and its working fine.
For best SEO do you guys use any other plugin?


RE: Google SEO 1.6.2 - Wiz01 - 11-30-2011

After the update, it seems the sitemap is doesn't work anymore.
Has anybody experienced this issue?


RE: Google SEO 1.6.2 - bositman - 11-30-2011

Having a problem with Google SEO Redirect.
The issue:
Links using the ?highlight with multiple words cause a "The page isn't redirecting properly" error. Turned on the redirect debug and got this error:
Content Encoding Error
The page you are trying to view cannot be shown because it uses an invalid or unsupported form of compression.

It seems that the + symbol is not being encoded properly so a search like "?highlight=god+of+war" ends up as "?highlight=god%2Bof%2Bwar" which is invalid.

The configuration:
MyBB 1.6.5, Google SEO 1.6.2, using the rewrite rules in the package for nginx
Using Nginx (so I guess that is the issue), already tried the LiteSpeed workaround but to no avail.


RE: Google SEO 1.6.2 - frostschutz - 11-30-2011

The content encoding error may be due to gzip (if you have enabled gzip in the MyBB settings).

Can you try disabling gzip and then PM me the redirect debug info?


RE: Google SEO 1.6.2 - bositman - 11-30-2011

Indeed disabling gzip does the trick and everything works properly...but I'd like gzip on Confused


RE: Google SEO 1.6.2 - frostschutz - 11-30-2011

Enabling / disabling gzip should have no influence whatsoever on redirect functionality, with the exception of the redirect debug info... gzip only does anything when content is displayed, the decision whether or not to redirect a page happens long before that...