MyBB Community Forums
[For 1.6] Google SEO 1.6.8 [EOL] - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Resources (https://community.mybb.com/forum-8.html)
+--- Forum: Plugins (https://community.mybb.com/forum-73.html)
+---- Forum: Plugin Releases (https://community.mybb.com/forum-102.html)
+---- Thread: [For 1.6] Google SEO 1.6.8 [EOL] (/thread-101262.html)



RE: Google SEO 1.6.3 - KingCupid - 11-04-2012

Thanx Koyote


RE: Google SEO 1.6.3 - ahlawat.vikas24 - 11-04-2012

Same problem here... SadSadSadSadSadSadSadSadSadSadSad
Hi I just install MyBB 1.6.8 and Google SEO 1.6.3.
I followed the tutorial How to install MyBB Google SEO for MyBB for better SEO.

the .htaccess has been done without plugin warnings

but when i try to test error 404, it gives me the default 404page of

Not Found

The requested URL /forum/cat was not found on this server.

when i try the forum links, the url is seo.
eg http://www.tutoriz.com/Forum-Rules

but I get the below page

Not Found

The requested URL /forum/Forum-General was not found on this server.

disable google redirect and google SEO and the forum is back alive with address http://www.mydomain.com/forum/forumdisplay.php?fid=3

one thing still not working even when deactivated the google seo is that the calendar is stuck pointing at /forum/Calendar-Default-Calendar

Not Found

The requested URL /forum/Calendar-Default-Calendar was not found on this server.


I tried without google SEO and used the built in Enable search engine friendly URLs? option enabled and it also gives page not found error.
I used the MyBB .htaccess for that testing.

is there something I am doing wrongly since the built in SEO is not working also?



my .htaccess code is

RewriteEngine on

# Some hosts require RewriteBase to make RewriteRules work.
RewriteBase /tutoriz/

# Google SEO workaround for search.php highlights:
# Make this rule the first rewrite rule in your .htaccess!
RewriteRule ^([^&]*)&(.*)$ http://www.tutoriz.com/tutoriz/$1?$2 [L,QSA,R=301]

# Google SEO 404:
ErrorDocument 404 /tutoriz/misc.php?google_seo_error=404

# Google SEO Sitemap:
RewriteRule ^sitemap-([^./]+)\.xml$ misc.php?google_seo_sitemap=$1 [L,QSA,NC]

# Google SEO URL Forums:
RewriteRule ^Forum-([^./]+)$ forumdisplay.php?google_seo_forum=$1 [L,QSA,NC]

# Google SEO URL Threads:
RewriteRule ^Thread-([^./]+)$ showthread.php?google_seo_thread=$1 [L,QSA,NC]

# Google SEO URL Announcements:
RewriteRule ^Announcement-([^./]+)$ announcements.php?google_seo_announcement=$1 [L,QSA,NC]

# Google SEO URL Users:
RewriteRule ^User-([^./]+)$ member.php?action=profile&google_seo_user=$1 [L,QSA,NC]

# Google SEO URL Calendars:
RewriteRule ^Calendar-([^./]+)$ calendar.php?google_seo_calendar=$1 [L,QSA,NC]

# Google SEO URL Events:
RewriteRule ^Event-([^./]+)$ calendar.php?action=event&google_seo_event=$1 [L,QSA,NC]



please help me what is going wrong....


RE: Google SEO 1.6.3 - frostschutz - 11-04-2012

Your posting is confusing as to which URL your site should be using.

You have mentioned http://www.tutoriz.com , http://www.tutoriz.com/tutoriz , http://www.tutoriz.com/forum ... which one is it?

Please choose one and stick to that. Also make sure it's identical to MyBB's bburl setting.

For example for the first, RewriteBase should be / not /tutoriz/ etc...


RE: Google SEO 1.6.3 - ahlawat.vikas24 - 11-05-2012

(11-04-2012, 06:21 PM)frostschutz Wrote: Your posting is confusing as to which URL your site should be using.

You have mentioned http://www.tutoriz.com , http://www.tutoriz.com/tutoriz , http://www.tutoriz.com/forum ... which one is it?

Please choose one and stick to that. Also make sure it's identical to MyBB's bburl setting.

For example for the first, RewriteBase should be / not /tutoriz/ etc...

it is http://www.tutoriz.com/tutoriz
but I think the main problem is IIS server
I have windows hosting... is it support Google SEO...
if how can i do?

I think it was IIS problem. now I have hosted in linux server... now working fine but I have another questions
current my thread url is looking like...

http://tutoriz.com/Thread-How-to-Install-SQL-Server-2008-R2-on-windows-8?pid=1#pid1

but I want it as
http://tutoriz.com/Thread-How-to-Install-SQL-Server-2008-R2-on-windows-8

means not want to show ID in the last...
How can it do this..


RE: Google SEO 1.6.3 - godgifted - 11-07-2012

Hi my server uses nginx can anybody please chage those rewrite rules for nginx server?


RE: Google SEO 1.6.3 - frostschutz - 11-07-2012

(11-05-2012, 06:49 AM)ahlawat.vikas24 Wrote: current my thread url is looking like...

http://tutoriz.com/Thread-How-to-Install-SQL-Server-2008-R2-on-windows-8?pid=1#pid1

but I want it as
http://tutoriz.com/Thread-How-to-Install-SQL-Server-2008-R2-on-windows-8

means not want to show ID in the last...
How can it do this..

The ?pid=123#pid123 is necessary for post links, you cannot remove it without losing the ability to link to specific posts... ?pid=123 opens the correct thread at the correct page, #pid123 makes the browser scroll down to that post. It's how MyBB post links work...

(11-07-2012, 10:12 AM)godgifted Wrote: Hi my server uses nginx can anybody please chage those rewrite rules for nginx server?

There's an example file for nginx included in the Google SEO package. You'll have to adapt it on your own…


RE: Google SEO 1.6.3 - Ans - 11-14-2012

Hi

I'm trying to set google SE on my forum and I have that lovely 404 Fatal error ...

[undefined=undefined]http://www.famille-solo.fr/mybb/Forum-ouest?google_seo_redirect=debug
Apache/2.2.14 (Ubuntu) Server at http://www.famille-solo.fr Port 80[/undefined]

I tried all the seeting there as possible
The .htacess looks ok

I wonder what to do to set that

Ok the bad side in french we have accents ... I puted the translaition in the SEO ACP board ..but doesn't work
I made a forum with no accents at all, the same thing...

What should I do?

Thx

http://www.famille-solo.fr

http://www.famille-solo.fr/mybb/index.php


RE: Google SEO 1.6.3 - frostschutz - 11-14-2012

Accents shouldn't be a problem. It also works fine with German äöüß and Japanese ひらカタ漢字.

The board should be using UTF-8 though. I'm guessing that something went wrong there on your board since e.g. on http://www.famille-solo.fr/mybb/forumdisplay.php?fid=10 I see thread subjects like "Message privé", and isn't é supposed to be an accented character? My French is a bit rusty...

Other than that the main reason for 404 is problems with the rewrite rules.


RE: Google SEO 1.6.3 - sriram - 11-14-2012

I too have the same problem. I downloaded the Google SEO 1.6.3 plugin.
My Main Blog URL is http://www.revealingthestuffs.com/

And I installed MyBB 1.6.8 on my Subdomain : http://forums.revealingthestuffs.com

When I click on The categories , ex: http://forums.revealingthestuffs.com/Forum-Introduce-yourself. I get an Error like:

Not Found

The requested URL /Forum-Introduce-yourself was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

I have updated htaccess file like this:
RewriteEngine on

# Some hosts need a RewriteBase specification.
RewriteBase /

# Google SEO workaround for search.php highlights:
# Make this rule the first rewrite rule in your .htaccess!
RewriteRule ^([^&]*)&(.*)$ http://forums.revealingthestuffs.com/$1?$2 [L,QSA,R=301]

# Google SEO Sitemap:
RewriteRule ^sitemap-([^./]+)\.xml$ misc.php?google_seo_sitemap=$1 [L,QSA,NC]

# Google SEO URL Forums:
RewriteRule ^Forum-([^./]+)$ forumdisplay.php?google_seo_forum=$1 [L,QSA,NC]

# Google SEO URL Threads:
RewriteRule ^Thread-([^./]+)$ showthread.php?google_seo_thread=$1 [L,QSA,NC]

# Google SEO URL Announcements:
RewriteRule ^Announcement-([^./]+)$ announcements.php?google_seo_announcement=$1 [L,QSA,NC]

# Google SEO URL Users:
RewriteRule ^User-([^./]+)$ member.php?action=profile&google_seo_user=$1 [L,QSA,NC]

# Google SEO URL Calendars:
RewriteRule ^Calendar-([^./]+)$ calendar.php?google_seo_calendar=$1 [L,QSA,NC]

# Google SEO URL Events:
RewriteRule ^Event-([^./]+)$ calendar.php?action=event&google_seo_event=$1 [L,QSA,NC]

# Google SEO 404:
ErrorDocument 404 /misc.php?google_seo_error=404

I want the URL of my Forum like- http://forums.revealingthestuffs.com/Forum-Introduce-yourself without 404 error. Please suggest me how to fix this 404 error.


RE: Google SEO 1.6.3 - Ans - 11-14-2012

Thanks for your reply

Yes I had a problem importing the forum from Phpbb and the accents did a bit messy thing ...all the titels with accentts I'm writing them back ..
Thats why I dit a forum with no accents at all to check that point:

The requested URL /mybb/Forum-forum-sans-accents was not found on this server.
Apache/2.2.14 (Ubuntu) Server at http://www.famille-solo.fr Port 80

I have a file named: translate.php.french.php
where would you put it ?

I tried:
Google Seo Plugin On +Server setting "active search engin nice URL " Enable + "active search engin nice URl in archives" Enable = Not working
Just plugin on =Not working
Just server setting on and plugin Off = not working ...

the .htaccess


# Google SEO URL Announcements:
RewriteRule ^Announcement\-([^./]+)$ announcements.php?google_seo_announcement=$1 [L,QSA,NC]

# Google SEO URL Users:
RewriteRule ^User\-([^./]+)$ member.php?action=profile&google_seo_user=$1 [L,QSA,NC]

# Google SEO URL Calendars:
RewriteRule ^Calendar\-([^./]+)$ calendar.php?google_seo_calendar=$1 [L,QSA,NC]

# Google SEO URL Events:
RewriteRule ^Event\-([^./]+)$ calendar.php?action=event&google_seo_event=$1 [L,QSA,NC]

# Default MyBB Rewrite Rules:
RewriteRule ^forum-([0-9]+)\.html$ forumdisplay.php?fid=$1 [L,QSA]
RewriteRule ^forum-([0-9]+)-page-([0-9]+)\.html$ forumdisplay.php?fid=$1&page=$2 [L,QSA]

RewriteRule ^thread-([0-9]+)\.html$ showthread.php?tid=$1 [L,QSA]
RewriteRule ^thread-([0-9]+)-page-([0-9]+)\.html$ showthread.php?tid=$1&page=$2 [L,QSA]
RewriteRule ^thread-([0-9]+)-lastpost\.html$ showthread.php?tid=$1&action=lastpost [L,QSA]
RewriteRule ^thread-([0-9]+)-nextnewest\.html$ showthread.php?tid=$1&action=nextnewest [L,QSA]
RewriteRule ^thread-([0-9]+)-nextoldest\.html$ showthread.php?tid=$1&action=nextoldest [L,QSA]
RewriteRule ^thread-([0-9]+)-newpost\.html$ showthread.php?tid=$1&action=newpost [L,QSA]
RewriteRule ^thread-([0-9]+)-post-([0-9]+)\.html$ showthread.php?tid=$1&pid=$2 [L,QSA]

RewriteRule ^post-([0-9]+)\.html$ showthread.php?pid=$1 [L,QSA]

RewriteRule ^announcement-([0-9]+)\.html$ announcements.php?aid=$1 [L,QSA]

RewriteRule ^user-([0-9]+)\.html$ member.php?action=profile&uid=$1 [L,QSA]

RewriteRule ^calendar-([0-9]+)\.html$ calendar.php?calendar=$1 [L,QSA]
RewriteRule ^calendar-([0-9]+)-year-([0-9]+)\.html$ calendar.php?action=yearview&calendar=$1&year=$2 [L,QSA]
RewriteRule ^calendar-([0-9]+)-year-([0-9]+)-month-([0-9]+)\.html$ calendar.php?calendar=$1&year=$2&month=$3 [L,QSA]
RewriteRule ^calendar-([0-9]+)-year-([0-9]+)-month-([0-9]+)-day-([0-9]+)\.html$ calendar.php?action=dayview&calendar=$1&year=$2&month=$3&day=$4 [L,QSA]
RewriteRule ^calendar-([0-9]+)-week-(n?[0-9]+)\.html$ calendar.php?action=weekview&calendar=$1&week=$2 [L,QSA]

RewriteRule ^event-([0-9]+)\.html$ calendar.php?action=event&eid=$1 [L,QSA]

<IfModule mod_env.c>
SetEnv SEO_SUPPORT 1
</IfModule>
</IfModule>

#
# If Apache is compiled with built in mod_deflade/GZIP support
# then GZIP Javascript, CSS, HTML and XML so they're sent to
# the client faster.
#
<IfModule mod_deflate.c>
AddOutputFilterByType DEFLATE application/x-javascript text/css text/html text/xml
</IfModule>





Thanks