MyBB Community Forums
[For 1.6] Google SEO 1.6.8 [EOL] - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Resources (https://community.mybb.com/forum-8.html)
+--- Forum: Plugins (https://community.mybb.com/forum-73.html)
+---- Forum: Plugin Releases (https://community.mybb.com/forum-102.html)
+---- Thread: [For 1.6] Google SEO 1.6.8 [EOL] (/thread-101262.html)



RE: Google SEO 1.6.5 - pilinko - 12-23-2012

(12-23-2012, 09:06 PM)Kodaks Wrote:
(12-23-2012, 09:02 PM)pilinko Wrote: yes but in forum it's htaccess.txt

so what to do now?please help

You need to rename htaccess.txt to .htaccess

Ok, now i have to file .htaccess , one in public html , and one in /forums folder.

But still not dissapear froum plugin that says me to add the code...Sad


RE: Google SEO 1.6.5 - rfc - 12-28-2012

Hello, I have a problem,I installed the Google SEO plugin but I have a problem with it.It redirects any link,category etc. to the forum index.
In the Plugins page from Admin CP it appears like this:

Code:
Add to .htaccess:
RewriteEngine on

# Some hosts require RewriteBase to make RewriteRules work.
RewriteBase /forum/

# Google SEO workaround for search.php highlights:
# Make this rule the first rewrite rule in your .htaccess!
RewriteRule ^([^&]*)&(.*)$ http://eromaniaonline.com/forum/$1?$2 [L,QSA,R=301]

# Google SEO 404:
ErrorDocument 404 /forum/misc.php?google_seo_error=404

# Google SEO Sitemap:
RewriteRule ^sitemap\-([^./]+)\.xml$ misc.php?google_seo_sitemap=$1 [L,QSA,NC]

# Google SEO URL Forums:
RewriteRule ^Forum\-([^./]+)$ forumdisplay.php?google_seo_forum=$1 [L,QSA,NC]

# Google SEO URL Threads:
RewriteRule ^Thread\-([^./]+)$ showthread.php?google_seo_thread=$1 [L,QSA,NC]

# Google SEO URL Announcements:
RewriteRule ^Announcement\-([^./]+)$ announcements.php?google_seo_announcement=$1 [L,QSA,NC]

# Google SEO URL Users:
RewriteRule ^User\-([^./]+)$ member.php?action=profile&google_seo_user=$1 [L,QSA,NC]

# Google SEO URL Calendars:
RewriteRule ^Calendar\-([^./]+)$ calendar.php?google_seo_calendar=$1 [L,QSA,NC]

# Google SEO URL Events:
RewriteRule ^Event\-([^./]+)$ calendar.php?action=event&google_seo_event=$1 [L,QSA,NC]

And the htaccess code from the server:

# EXAMPLE .htaccess FOR MYBB WITH GOOGLE SEO URL
# -------------------------------------------------------------------
# This file is identical to MyBB's htaccess.txt example file,
# with rewrite rules for a standard Google SEO install added.
#
# Before using this file please make sure to:
#
# - replace /MyBB/ with your forum folder, e.g. / or /forum/
# - replace yoursite/MyBB with your forum URL
# - name the file '.htaccess' (starting with the dot, no .txt)
#
# Alternatively you can add the required rewrite rules to your
# existing .htaccess, the specific rules required will be displayed
# on the plugin status page once Google SEO URL is enabled.
# -------------------------------------------------------------------

Options -MultiViews +FollowSymlinks -Indexes

#
# If mod_security is enabled, attempt to disable it.
# - Note, this will work on the majority of hosts but on
# MediaTemple, it is known to cause random Internal Server
# errors. For MediaTemple, please remove the block below
#
<IfModule mod_security.c>
# Turn off mod_security filtering.
SecFilterEngine Off

# The below probably isn't needed, but better safe than sorry.
SecFilterScanPOST Off
</IfModule>

#
# MyBB "search engine friendly" URL rewrites
# - Note, for these to work with MyBB please make sure you have
# the setting enabled in the Admin CP and you have this file
# named .htaccess
#
<IfModule mod_rewrite.c>
RewriteEngine on
# Some hosts require RewriteBase to make RewriteRules work.
RewriteBase /forum/

# Google SEO workaround for search.php highlights:
# Make this rule the first rewrite rule in your .htaccess!
RewriteRule ^([^&]*)&(.*)$ http://eromaniaonline.com/forum/$1?$2 [L,QSA,R=301]

# Google SEO 404:
ErrorDocument 404 /forum/misc.php?google_seo_error=404

# Google SEO Sitemap:
RewriteRule ^sitemap\-([^./]+)\.xml$ misc.php?google_seo_sitemap=$1 [L,QSA,NC]

# Google SEO URL Forums:
RewriteRule ^Forum\-([^./]+)$ forumdisplay.php?google_seo_forum=$1 [L,QSA,NC]

# Google SEO URL Threads:
RewriteRule ^Thread\-([^./]+)$ showthread.php?google_seo_thread=$1 [L,QSA,NC]

# Google SEO URL Announcements:
RewriteRule ^Announcement\-([^./]+)$ announcements.php?google_seo_announcement=$1 [L,QSA,NC]

# Google SEO URL Users:
RewriteRule ^User\-([^./]+)$ member.php?action=profile&google_seo_user=$1 [L,QSA,NC]

# Google SEO URL Calendars:
RewriteRule ^Calendar\-([^./]+)$ calendar.php?google_seo_calendar=$1 [L,QSA,NC]

# Google SEO URL Events:
RewriteRule ^Event\-([^./]+)$ calendar.php?action=event&google_seo_event=$1 [L,QSA,NC]

<IfModule mod_env.c>
SetEnv SEO_SUPPORT 1
</IfModule>
</IfModule>

#
# If Apache is compiled with built in mod_deflade/GZIP support
# then GZIP Javascript, CSS, HTML and XML so they're sent to
# the client faster.
#
<IfModule mod_deflate.c>
AddOutputFilterByType DEFLATE application/x-javascript text/css text/html text/xml
</IfModule>


RE: Google SEO 1.6.5 - José F. - 12-30-2012

A friend of mine is having problems with this and I can't help him. Basically, he enabled the SEO urls and already edited the .htaccess with the rules. But, in the plugin page, it still shows that he has to add some rules (not all of them), but the .htaccess already has all the rules, so this is pretty weird. So, yeah, the links even though are SEO, they don't work, it gets a 404 page.

Any idea?


RE: Google SEO 1.6.5 - frostschutz - 12-30-2012

The plugin will warn as long as it doesn't look exactly like what the plugin expects there to be.

And if you get a 404 page, then for whatever reason, the rewrites simply aren't after being working.

The two possibilities there are 1) the webserver doesn't support rewrites (rare case) or 2) there is an error in the .htaccess after all. 2) is very likely as the plugin will stop complaining about .htaccess whether it works or not, just as long as it contains the right lines in the right order.

You could delete/rename the .htaccess and then copy&paste the whole thing the plugin will show then into a new .htaccess file. And see if that works. If it doesn't you might just have to ask your host what the problem is.


RE: Google SEO 1.6.5 - José F. - 12-30-2012

(12-30-2012, 10:11 PM)frostschutz Wrote: You could delete/rename the .htaccess and then copy&paste the whole thing the plugin will show then into a new .htaccess file. And see if that works. If it doesn't you might just have to ask your host what the problem is.

Exactly what I did. Well, I will tell him to contact his host, even though he told me that he is using the VPS of a friend of him (I guess that this friend created an account for him in the FTP, not sure).


RE: Google SEO 1.6.5 - frostschutz - 12-30-2012

Well, if you did that, and did it correctly, at least the plugin should show all ok on the plugins page.

The plugin itself can not actually tell whether the rewrites are working or not. It can only make a wild guess about whether the file may be correct or not.


RE: Google SEO 1.6.5 - José F. - 12-30-2012

(12-30-2012, 10:41 PM)frostschutz Wrote: Well, if you did that, and did it correctly, at least the plugin should show all ok on the plugins page.

And that is another thing that is weird. It shows what I need to put in the .htaccess, right? After I edit the .htaccess with that, it still shows that I need to add some codes, even though they are already in the .htaccess. It doesn't show them all (like when there isn't a .htaccess, etc).


RE: Google SEO 1.6.5 - frostschutz - 12-30-2012

Can you upload/attach the .htaccess somewhere as well as whatever the plugin is asking you to add to it?


RE: Google SEO 1.6.5 - José F. - 12-30-2012

Sent you a PM. Wink


RE: Google SEO 1.6.5 - frostschutz - 12-30-2012

Well, that's a charset issue. Google SEO probably expects those characters to be UTF-8, but they aren't in the .htaccess file.

Special characters as part of the URL scheme may or may not work. It's only officially / directly supported in the URL part of things. So you might want to try with Topico instead of Tópico or whatever.