MyBB Community Forums
[For 1.6] Google SEO 1.6.8 [EOL] - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Resources (https://community.mybb.com/forum-8.html)
+--- Forum: Plugins (https://community.mybb.com/forum-73.html)
+---- Forum: Plugin Releases (https://community.mybb.com/forum-102.html)
+---- Thread: [For 1.6] Google SEO 1.6.8 [EOL] (/thread-101262.html)



RE: Google SEO 1.6.5 - jstotz - 02-13-2013

(02-13-2013, 06:12 PM)frostschutz Wrote:
(02-13-2013, 04:51 PM)jstotz Wrote: Therefore I will need to know the exact URL.

If you have the ID, you can query it from the mybb_google_seo table.

If you mean the ID that myBB assigns, no I don't know it. I only know the forum and thread name. The thread name is a company specific job number that comes out of some other software. The forum names would be company departments. So I want to be able to construct a URL something like http://companyserver/mybb/departmentname-jobnumber. There is some flexibility in the exact format, but the program generating the URLs only knows those two bits of info.


RE: Google SEO 1.6.5 - microcon - 02-14-2013

Hi, I have the following 2 questions:

- It looks like the records of the Google_SEO table are not deleted when I delete users or threads from the databse, how can I delete the unused records to free up the table?

- Will Google SEO plugin cause a lot of load on the server, in debug mode I see most of queris are from this pluing?

I am on 1.4 MyBB.

Thanks.


RE: Google SEO 1.6.5 - frostschutz - 02-14-2013

Database cleanup will be a new feature in the next version, see this commit. This code doesn't do the actual cleanup yet but it has the query that determines which rows would need to be deleted if you wanted to do that. Once the feature is ready you can do a cleanup manually once a year or so.

But with MyBB 1.4 there is simply nothing I can do for you. It's not supported. You really should upgrade as MyBB 1.4 may suffer from security vulnerabilities only fixed for 1.6.

The reason the cleanup doesn't happen automatically is that it's actually quite hard to tell when a thread is getting deleted. There are ways to delete them without proper hooks getting called; there is the case where hooks do get called but nothing is actually deleted because something else decides to keep the thread in a trashcan.

Also, keeping URLs and Redirects working (even if a thread was deleted and subsequently restored from DB) simply took a higher priority over removing surplus entries from the DB at all costs. With all queries being indexed and surplus entries simply ignored by the current code, it makes little difference unless you deleted a million spam threads or something.


RE: Google SEO 1.6.5 - korean - 02-15-2013

I install tihis plugins but all user in online.php location writes in index.php please help me

up....


RE: Google SEO 1.6.5 - SonnyCooL - 02-18-2013

installed this plugin and click everything to enable but i still can't locate my sitemap ....

my forum with wordpress front, http://propertyagent.my/forum/sitemap.xml or sitemap-index.xml/ but it just return page 404 from my main site ....
btw it seem like not only sitemap not working, 404 page, google url, meta and the rest is not working too ...

do i miss anything ?
thanks

edit :
found out i miss some configuration .... sorry first time with mybb


RE: Google SEO 1.6.5 - brunodiaz - 02-22-2013

Hi

I had a problem with redirect.php

It throwed an error in urlencode.

After a lot of work I discovered it was associated with array variables in GET

like ?bla[]=1&bla[]=2

I don't know if it was already corrected in a release i didn't have (i think mine was the last)

If someone wants my correction, just tell.

Thanks for the plugin.


RE: Google SEO 1.6.5 - SonnyCooL - 02-24-2013

i put lan pack and all files in right area but when i click on plugin it show below error :

Warning [2] require_once(/home/property/domains/sgpagent.com/public_html/forum/inc/plugins/pluginlibrary.php) [function.require-once]: failed to open stream: No such file or directory - Line: 82 - File: inc/plugins/google_seo/plugin.php PHP 5.2.17 (Linux)
File Line Function
/inc/plugins/google_seo/plugin.php 82 errorHandler->error
/inc/plugins/google_seo/plugin.php 82 google_seo_plugin_status
/inc/plugins/google_seo/plugin.php 67 google_seo_plugin_status
/inc/plugins/google_seo.php 50 google_seo_plugin_info
/admin/modules/config/plugins.php 485 google_seo_info
/admin/index.php 523 require

Fatal error: require_once() [function.require]: Failed opening required '/home/property/domains/sgpagent.com/public_html/forum/inc/plugins/pluginlibrary.php' (include_path='.:/usr/local/lib/php') in /home/property/domains/sgpagent.com/public_html/forum/inc/plugins/google_seo/plugin.php on line 82


RE: Google SEO 1.6.5 - djqwert - 02-25-2013

frostschutz, I suggest to rewrite the url with è, ò, à, etc... with e, o, a as on wordpress, otherwise appears in url %Ad3%, %C3%A8, ecc...


RE: Google SEO 1.6.5 - korean - 02-28-2013

I install tihis plugins but all user in online.php location writes in index.php please help me


RE: Google SEO 1.6.5 - frostschutz - 02-28-2013

(02-25-2013, 11:01 AM)djqwert Wrote: frostschutz, I suggest to rewrite the url with è, ò, à, etc... with e, o, a as on wordpress, otherwise appears in url %Ad3%, %C3%A8, ecc...

No, it appears as è, ò, à same as with Wikipedia http://fr.wikipedia.org/wiki/Économie_du_Finistère

If you see % instead that has to do with your browser.

You can already define character translation in the URL settings, so if you want e instead of è, you can already do it.

(02-22-2013, 04:18 AM)brunodiaz Wrote: like ?bla[]=1&bla[]=2

That query string style isn't used much with MyBB. Can you give a concrete example where this causes a problem, something I can reproduce?

(02-22-2013, 04:18 AM)brunodiaz Wrote: If someone wants my correction, just tell.

Post it, never hurts to take a look...

(02-24-2013, 02:31 AM)SonnyCooL Wrote: Warning [2] require_once(/home/property/domains/sgpagent.com/public_html/forum/inc/plugins/pluginlibrary.php) [function.require-once]: failed to open stream: No such file or directory - Line: 82 - File: inc/plugins/google_seo/plugin.php PHP 5.2.17 (Linux)

Somehow your inc/plugins/pluginlibrary.php is missing, reupload it