MyBB Community Forums
[Upgrading] Upgrading from 1.6.3 to 1.6.4 - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Community Archive (https://community.mybb.com/forum-106.html)
+--- Forum: Archived Forums (https://community.mybb.com/forum-143.html)
+---- Forum: Archived Development and Support (https://community.mybb.com/forum-155.html)
+----- Forum: MyBB 1.6 (https://community.mybb.com/forum-138.html)
+------ Forum: 1.6 General Support (https://community.mybb.com/forum-127.html)
+------ Thread: [Upgrading] Upgrading from 1.6.3 to 1.6.4 (/thread-102897.html)

Pages: 1 2


Upgrading from 1.6.3 to 1.6.4 - mikepace27 - 2011-09-01

I have followed the wiki step by step in trying to upgrade from 1.6.3 - 1.6.4. The problem I am running into is that it keeps upgrading me to 1.6.3. I upload the files via FileZilla correctly, remove the lock file and when I go to do the install/upgrade.php at the end of my URL, it shows me the upgrade window where I choose what version of MyBB I am running. The issue is it says it is the upgrade for 1.6.3 even though I downloaded the changed files package for 1.6.4. Please help/ I am available via email 24/7 [email protected]


RE: Upgrading from 1.6.3 to 1.6.4 - StefanT - 2011-09-01

There is no changed files package for MyBB 1.6.4, you need to download this: http://www.mybb.com/download/latest


RE: Upgrading from 1.6.3 to 1.6.4 - mikepace27 - 2011-09-01

http://blog.mybb.com/

blog.mybb.com Wrote:As usual, backup your forum’s database and files, and switch off your forum’s front end. You may want to follow the Wiki Upgrading Procedure.
Download the 1.6.4 Update Files and upload them to your forum – overwriting the existing ones.
Delete ./install/lock and visit the upgrader – normally found at yourforum/install/upgrade.php and run the upgrader again. Choose 1.6.3 from the list of versions.
The above process won’t cause any problems with your forum – it merely updates the default templates again to 1.6.4′s versions and adds a database column missing from the original update.

That is what I was talking about. Sorry. Should have been more specific about that.
I also uploaded that file you gave me as well, and it is still telling me it is an upgrade to 1.6.3 instead of .4......


RE: Upgrading from 1.6.3 to 1.6.4 - StefanT - 2011-09-01

Please read the red message:
Quote:Note: you only need to read this if you upgraded to 1.6.4 before this blog post was made. If you have not upgraded yet, you will need this: http://blog.mybb.com/2011/07/26/mybb-1-6-4-released-feature-update-security-maintenance-release/



RE: Upgrading from 1.6.3 to 1.6.4 - mikepace27 - 2011-09-01

Apologies. I didn't see that until a few minutes ago. I then did the full 1.6.4 release download, but I'm still getting the same thing.....


RE: Upgrading from 1.6.3 to 1.6.4 - Joshua Mayer - 2011-09-01

Could you please post a screenshot of where it says 1.6.3 upgrade? If you uploaded the 1.6.4 files, it should be perfectly fine.


RE: Upgrading from 1.6.3 to 1.6.4 - mikepace27 - 2011-09-01

Sure, give me one quick second.
That is the screenshot I get when adding the /install command onto my URL. This is from the 1.6.4 all files .zip I downloaded then transferred to my site's FTP.


RE: Upgrading from 1.6.3 to 1.6.4 - Radebe - 2011-09-01

Did you extract the files into the right directories from the .zip file? You can't just upload the .zip.


RE: Upgrading from 1.6.3 to 1.6.4 - Matt - 2011-09-01

(2011-09-01, 07:25 AM)mikepace27 Wrote: Apologies. I didn't see that until a few minutes ago. I then did the full 1.6.4 release download, but I'm still getting the same thing.....

I'm frankly concerned at the number of people who cannot see this message despite it being in bold, red text.

If it's still saying 1.6.3 on the upgrade script, then the new files are simply not overwriting the old ones. The version number only comes from one place, so if that file contains the old version number, it hasn't been updated.


RE: Upgrading from 1.6.3 to 1.6.4 - mikepace27 - 2011-09-01

Yes I am uploading the files correctly, and no, I'm not attempting to upload the .zip lol. Yes, that is exactly the problem. The new version is not overwriting the old version, causing em to still go through the upgrade to 1.6.3