MyBB Community Forums
[For 1.6] ModNotice Plus 1.5.5 - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Extensions (https://community.mybb.com/forum-201.html)
+--- Forum: Plugins (https://community.mybb.com/forum-73.html)
+---- Forum: Plugin Releases (https://community.mybb.com/forum-102.html)
+---- Thread: [For 1.6] ModNotice Plus 1.5.5 (/thread-104136.html)

Pages: 1 2 3 4 5 6 7 8 9 10


RE: ModNotice Plus 1.5.5 - wallet - 2014-03-13

i am currently running MyBB 1.6.9,however when i click on edit then Moderate it brings me back to 00webhost any fix please


RE: ModNotice Plus 1.5.5 - Wildcard - 2014-03-13

(2014-03-13, 08:56 AM)wallet Wrote: i am currently running MyBB 1.6.9

Start by upgrading your forum software to MyBB 1.6.12


RE: ModNotice Plus 1.5.5 - SAEED.M - 2014-03-13

it's very nice .. can add editor to this plugin ?? and smiles ??

Thanks


RE: ModNotice Plus 1.5.5 - wallet - 2014-03-13

(2014-03-13, 04:22 PM)Wildcard Wrote:
(2014-03-13, 08:56 AM)wallet Wrote: i am currently running MyBB 1.6.9

Start by upgrading your forum software to MyBB 1.6.12


How to and will i lose anything??


RE: ModNotice Plus 1.5.5 - Cameron:D - 2014-03-14

Check http://docs.mybb.com/Upgrading.html

It is unlikely you'll lose anything, but always make a backup of all your files and the database in case something goes wrong.


RE: ModNotice Plus 1.5.5 - XgamingX2013 - 2014-03-14

Had a play with plugin and here's my result:

[Image: a7d160093f63a9f8b9e998d8e50199b1.png]

I have another problem:

When I add
UPDATE settings SET title="Send Notice To Post Author",
description="Send a a private message to the author of the edited post." WHERE name="modnotice_pm";
UPDATE settinggroups SET title="ModNotice Plus" WHERE name="modnotice";
to the SQL, it says this:
SQL query:

UPDATE settings SET title =  "Send Notice To Post Author",
description =  "Send a a private message to the author of the edited post." WHERE name =  "modnotice_pm";


MySQL said: Documentation

#1146 - Table 'u266046464_tqs.settings' doesn't exist 



RE: ModNotice Plus 1.5.5 - Supryk - 2014-07-09

On the mod site is it bad version
in zip 1.5.5
in link 1.3 http://mods.mybb.com/view/modnotice-1-3

pleas fix this

Smile


RE: ModNotice Plus 1.5.5 - tomhillepille - 2014-08-28

is it possible to make 2 things: first one, create a post that ONLY containts the Modmessage? would be great.

and 2nd: is it possible to move the Modnotice to the top of the post?


RE: ModNotice Plus 1.5.5 - p00lz - 2014-10-24

any word on 1.8(.1) compatibility?


RE: ModNotice Plus 1.5.5 - p00lz - 2014-10-26

Reply to my own question, tried to see if i could get it working myself;

changed compatibility line, check, installs, puts global templates in fine.
One template it inserts needs to be modified.

postbit_moderator_edit needs to be changed from


<a href="editpost.php?pid={$post['pid']}" id="edit_post_{$post['pid']}"><img src="{$theme['imglangdir']}/postbit_edit.gif" alt="{$lang->postbit_edit}" title="{$lang->postbit_edit}" /></a>
<div id="edit_post_{$post['pid']}_popup" class="popup_menu" style="display: none;"><div class="popup_item_container"><a href="javascript:;" onclick="Thread.quickEdit({$post['pid']});" class="popup_item">{$lang->postbit_quick_edit}</a></div>
<div class="popup_item_container"><a href="editpost.php?pid={$post['pid']}" class="popup_item">{$lang->postbit_full_edit}</a></div>
<div class="popup_item_container"><a href="modnotice.php?pid={$post['pid']}" class="popup_item">{$lang->postbit_post_moderate}</a></div></div>
<script type="text/javascript">
// <!--
	if(use_xmlhttprequest == "1")
	{
		new PopupMenu("edit_post_{$post['pid']}");
	}
// -->
</script>

to


<a href="editpost.php?pid={$post['pid']}" id="edit_post_{$post['pid']}" title="{$lang->postbit_edit}" class="postbit_edit"><span>{$lang->postbit_button_edit}</span></a>
<div id="edit_post_{$post['pid']}_popup" class="popup_menu" style="display: none;">
<div class="popup_item_container"><a href="javascript:;" class="popup_item quick_edit_button" id="quick_edit_post_{$post['pid']}">{$lang->postbit_quick_edit}</a></div>
<div class="popup_item_container"><a href="editpost.php?pid={$post['pid']}" class="popup_item">{$lang->postbit_full_edit}</a></div>
<div class="popup_item_container"><a href="modnotice.php?pid={$post['pid']}" class="popup_item">{$lang->postbit_post_moderate}</a></div></div>
<script type="text/javascript">
// <!--
	if(use_xmlhttprequest == "1")
	{
		$("#edit_post_{$post['pid']}").popupMenu();
	}
// -->
</script>

^that is for the default/global theme, some other themes you'll have to make add a  postbit_moderator_edit template in your current themes template set different class for the button, etc, you get the gist though.

The new template works for the popup button, and it directs to a moderate page but when actually submitting a moderation edit I get this.

( ! ) Fatal error: Call to undefined method pluginSystem::run_hooks_by_ref() in C:\wamp\www\inc\datahandlers\moderate.php on line 386
Call Stack
#	Time	Memory	Function	Location
1	0.0010	392072	{main}( )	..\modnotice.php:0
2	0.0840	8966952	PostDataHandler->validate_post( )	..\modnotice.php:201


and when trying to preview the moderation i get this

( ! ) Fatal error: Call to undefined method pluginSystem::run_hooks_by_ref() in C:\wamp\www\inc\datahandlers\moderate.php on line 386
Call Stack
#	Time	Memory	Function	Location
1	0.0020	392424	{main}( )	..\modnotice.php:0
2	0.1010	8977208	PostDataHandler->validate_post( )	..\modnotice.php:448

So looking at inc/datahandlers/moderate.php on line 386 I see

$plugins->run_hooks_by_ref("datahandler_moderate_validate_post", $this);

aaaaaand i lost myself and gave up for now