MyBB Community Forums
1366 - Incorrect integer value: 'NULL' for column 'gid' at row 1 - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Community Archive (https://community.mybb.com/forum-106.html)
+--- Forum: Archived Forums (https://community.mybb.com/forum-143.html)
+---- Forum: Archived Development and Support (https://community.mybb.com/forum-155.html)
+----- Forum: MyBB 1.6 (https://community.mybb.com/forum-138.html)
+------ Forum: 1.6 General Support (https://community.mybb.com/forum-127.html)
+------ Thread: 1366 - Incorrect integer value: 'NULL' for column 'gid' at row 1 (/thread-105450.html)



1366 - Incorrect integer value: 'NULL' for column 'gid' at row 1 - MonsterMMORPG - 2011-10-07

Ok this is the plugin.

http://yaldaram.com/showthread.php?tid=1&pid=1

it says this error when i try to install

MyBB has experienced an internal SQL error and cannot continue.

SQL Error:
1366 - Incorrect integer value: 'NULL' for column 'gid' at row 1
Query:
INSERT INTO mybb_settinggroups (gid,name,title,description,disporder,isdefault) VALUES ('NULL','minps_settings','Min. Posts Plugin','Settings for the plugin.','1','no')


i asked the author but he says there is no problem. so i need your help.


this is my mysql engine

SQL Engine MySQLi 5.5.15

even though i installed latest full version from their website it installs as musql light . i am using windows server as hosting environment.

If i insert 0 or 1 instead of null what problem it may cause ?


RE: 1366 - Incorrect integer value: 'NULL' for column 'gid' at row 1 - ranjani - 2011-10-07

^ please post above issue on that external site !!

you can try using 0 for NULL

OR you have to ask your host to fix using of NULL in the database

OR you may try by editing the plugin file to remove gid field from the query

i.e. change below code

INSERT INTO mybb_settinggroups (`gid`,`name`,`title`,`description`,`disporder`,`isdefault`) VALUES ('NULL','minps_settings','Min. Posts Plugin','Settings for the plugin.','1','no')

to this :

INSERT INTO mybb_settinggroups (`name`,`title`,`description`,`disporder`,`isdefault`) VALUES ('minps_settings','Min. Posts Plugin','Settings for the plugin.','1','no') 

reference : responses on some other topic similar to above


RE: 1366 - Incorrect integer value: 'NULL' for column 'gid' at row 1 - labrocca - 2011-10-07

The author is active here. You should directly contact him to fix it and for support.

Plus General Support questions to Support Team do not provide help for plugins.


RE: 1366 - Incorrect integer value: 'NULL' for column 'gid' at row 1 - MonsterMMORPG - 2011-10-08

(2011-10-07, 05:08 PM)labrocca Wrote: The author is active here. You should directly contact him to fix it and for support.

Plus General Support questions to Support Team do not provide help for plugins.

yes i asked the author and he said no one else is having problem. basically he ignored me. so that is why i asked here.
(2011-10-07, 04:35 PM)ranjani Wrote: ^ please post above issue on that external site !!

you can try using 0 for NULL

OR you have to ask your host to fix using of NULL in the database

OR you may try by editing the plugin file to remove gid field from the query

i.e. change below code

INSERT INTO mybb_settinggroups (`gid`,`name`,`title`,`description`,`disporder`,`isdefault`) VALUES ('NULL','minps_settings','Min. Posts Plugin','Settings for the plugin.','1','no')

to this :

INSERT INTO mybb_settinggroups (`name`,`title`,`description`,`disporder`,`isdefault`) VALUES ('minps_settings','Min. Posts Plugin','Settings for the plugin.','1','no') 

reference : responses on some other topic similar to above


changed as you said

new error


MyBB has experienced an internal SQL error and cannot continue.

SQL Error:
1366 - Incorrect integer value: 'no' for column 'isdefault' at row 1
Query:
INSERT INTO mybb_settinggroups (name,title,description,disporder,isdefault) VALUES ('minps_settings','Min. Posts Plugin','Settings for the plugin.','1','no')



RE: 1366 - Incorrect integer value: 'NULL' for column 'gid' at row 1 - Matt - 2011-10-09

You also need to change the 'no' at the end to 0


RE: 1366 - Incorrect integer value: 'NULL' for column 'gid' at row 1 - Yaldaram - 2011-10-10

(2011-10-08, 10:57 PM)MonsterMMORPG Wrote: yes i asked the author and he said no one else is having problem. basically he ignored me. so that is why i asked here.

No, I didn't ignored you at all.


RE: 1366 - Incorrect integer value: 'NULL' for column 'gid' at row 1 - MonsterMMORPG - 2011-10-13

(2011-10-10, 05:22 AM)Yaldaram Wrote:
(2011-10-08, 10:57 PM)MonsterMMORPG Wrote: yes i asked the author and he said no one else is having problem. basically he ignored me. so that is why i asked here.

No, I didn't ignored you at all.

yes you did

this is your message

Quote:If you're using MySQL then there is no need to change NULL value. Just install the plugin, it should work in MySQL environment.

i already said you that i am using latest mysql on windows server 2008 r2




RE: 1366 - Incorrect integer value: 'NULL' for column 'gid' at row 1 - rubberchicken - 2014-04-11

Yes i'm having the same problems as well... I think the plugin is not compatible with version MyBB 1.6.12 on Windows Server 2008 or higher... Might be just a Windows Server compatibility problem because of how MyBB installed the SQL tables on Windows....

If gid => "NULL" why put it in the code if it would work the same without it?

Also new error:

SQL Error:
    1366 - Incorrect integer value: 'NULL' for column 'sid' at row 1
Query:
    INSERT INTO mybb_settings (`sid`,`name`,`title`,`description`,`optionscode`,`value`,`disporder`,`gid`) VALUES ('NULL','power_supply','Announcement Switch','This will allow you to turn the plugin on or off without loosing any data.
    Warning: Disabling the plugin completely in Plugins will erase your Announcment and all other data including your custom style, This method will not.n','onoff','1','1','22') 

And this error keeps happening for all mybb_settings...

I removed the sid => NULL line for all
Changed isdefault value to 0

Deactivated -> cleaned mysql database because this plugin made a mess from all the ERRORS!!
Then activated again and it works good now....

Great plugin though, thats why i didnt give up on this one and use another!

Thanks