MyBB Community Forums
Script to Update Plugins for 1.6.5 - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Community Archive (https://community.mybb.com/forum-106.html)
+--- Forum: Archived Forums (https://community.mybb.com/forum-143.html)
+---- Forum: Archived Development and Support (https://community.mybb.com/forum-155.html)
+----- Forum: MyBB 1.6 (https://community.mybb.com/forum-138.html)
+------ Forum: 1.6 General Support (https://community.mybb.com/forum-127.html)
+------ Thread: Script to Update Plugins for 1.6.5 (/thread-108595.html)

Pages: 1 2 3 4 5 6 7 8 9 10


RE: Script to Update Plugins for 1.6.5 - Projec13 - 2012-02-29

I'm not sure whats going on, I uploaded with dryrun =1, ran, got the list.. then set dryrun = 0, reuploaded, it runs through the process, but doesn't seem to do anything, and tells me the same thing over and over:

Starting search for hooks requiring verification

Array
(
[0] => $plugins->add_hook("newreply_do_newreply_end"
[1] => "akismet_redirect_thread")
[2] =>

)

Array
(
[0] => $plugins->add_hook("newthread_do_newthread_end"
[1] => "akismet_redirect_forum")
[2] =>

)

Array
(
[0] => $plugins->add_hook("postbit"
[1] => "akismet_postbit")
[2] =>

)

Array
(
[0] => $plugins->add_hook("admin_forum_menu"
[1] => "akismet_admin_nav")
[2] =>

)

Array
(
[0] => $plugins->add_hook("admin_forum_permissions"
[1] => "akismet_admin_permissions")
[2] =>

)

Array
(
[0] => $plugins->add_hook("admin_forum_action_handler"
[1] => "akismet_action_handler")
[2] =>

)

Array
(
[0] => $plugins->add_hook("postbit"
[1] => "hello_world_postbit")
[2] =>

)

Array
(
[0] => $plugins->add_hook('admin_tools_menu'
[1] => 'myshoutbox_admin_tools_menu')
[2] =>

)

Array
(
[0] => $plugins->add_hook('admin_tools_action_handler'
[1] => 'myshoutbox_admin_tools_action_handler')
[2] =>

)

Array
(
[0] => $plugins->add_hook('admin_tools_permissions'
[1] => 'myshoutbox_admin_permissions')
[2] =>

)

Array
(
[0] => $plugins->add_hook('admin_home_menu'
[1] => 'myshoutbox_admin_home_menu')
[2] =>

)

Array
(
[0] => $plugins->add_hook("class_moderation_move_thread_redirect"
[1] => "mybbpublisher_onmove")
[2] =>

)

Array
(
[0] => $plugins->add_hook("build_forumbits_forum"
[1] => "mybbpublisher_addicon")
[2] =>

)

Array
(
[0] => $plugins->add_hook("admin_config_plugins_activate_commit"
[1] => "mybbpublisher_settings_redirect")
[2] =>

)

Array
(
[0] => $plugins->add_hook("admin_tools_menu"
[1] => "mybbpublisher_admin_nav")
[2] =>

)

Array
(
[0] => $plugins->add_hook("admin_tools_action_handler"
[1] => "mybbpublisher_action_handler")
[2] =>

)

Array
(
[0] => $plugins->add_hook("error"
[1] => "google_seo_404")
[2] =>

)

Array
(
[0] => $plugins->add_hook("build_friendly_wol_location_end"
[1] => "google_seo_404_wol")
[2] =>

)

Array
(
[0] => $plugins->add_hook("postbit"
[1] => "google_seo_meta_thread")
[2] =>

)

Array
(
[0] => $plugins->add_hook("postbit_announcement"
[1] => "google_seo_meta_announcement")
[2] =>

)

Array
(
[0] => $plugins->add_hook("postbit_announcement"
[1] => "google_seo_meta_announcement")
[2] =>

)

Array
(
[0] => $plugins->add_hook("postbit"
[1] => "google_seo_meta_posts")
[2] =>

)

Array
(
[0] => $plugins->add_hook("global_start"
[1] => "google_seo_redirect_hook"
)

Array
(
[0] => $plugins->add_hook("forumdisplay_end"
[1] => "google_seo_redirect_header"
)

Array
(
[0] => $plugins->add_hook("postbit"
[1] => "google_seo_redirect_header"
)

Array
(
[0] => $plugins->add_hook("postbit"
[1] => "google_seo_redirect_header"
)

Array
(
[0] => $plugins->add_hook("postbit_announcement"
[1] => "google_seo_redirect_header"
)

Array
(
[0] => $plugins->add_hook("postbit_announcement"
[1] => "google_seo_redirect_header"
)

Array
(
[0] => $plugins->add_hook("postbit_announcement"
[1] => "google_seo_redirect_header"
)

Array
(
[0] => $plugins->add_hook("calendar_editevent_end"
[1] => "google_seo_redirect_header"
)

Array
(
[0] => $plugins->add_hook("calendar_event_end"
[1] => "google_seo_redirect_header"
)

Array
(
[0] => $plugins->add_hook("calendar_end"
[1] => "google_seo_redirect_header"
)

Array
(
[0] => $plugins->add_hook("pre_output_page"
[1] => "google_seo_redirect_header"
)

Array
(
[0] => $plugins->add_hook("build_friendly_wol_location_end"
[1] => "google_seo_sitemap_wol")
[2] =>

)

Array
(
[0] => $plugins->add_hook('admin_tools_menu'
[1] => 'postcounter_admin_tools_menu')
[2] =>

)

Array
(
[0] => $plugins->add_hook('admin_tools_action_handler'
[1] => 'postcounter_admin_tools_action_handler')
[2] =>

)

Array
(
[0] => $plugins->add_hook('admin_tools_permissions'
[1] => 'postcounter_admin_permissions')
[2] =>

)

Array
(
[0] => $plugins->add_hook("fetch_wol_activity_end"
[1] => "games_online_activity")
[2] =>

)

Array
(
[0] => $plugins->add_hook("build_friendly_wol_location_end"
[1] => "games_online_location")
[2] =>

)

Array
(
[0] => $plugins->add_hook("admin_tools_get_admin_log_action"
[1] => "games_admin_log")
[2] =>

)

Array
(
[0] => $plugins->add_hook("admin_user_groups_edit_graph_tabs"
[1] => "games_groups_graph_tabs")
[2] =>

)

Array
(
[0] => $plugins->add_hook("admin_forum_menu"
[1] => "mytabs_menu")
[2] =>

)

Array
(
[0] => $plugins->add_hook("admin_forum_action_handler"
[1] => "mytabs_action_handler")
[2] =>

)

Verifying hooked functions that need updating

Done searching for needed updates
Starting updates












Done fixing








---- But nothings working still ?


RE: Script to Update Plugins for 1.6.5 - pavemen - 2012-02-29

sounds like php does not have write access to the plugins folder/files. set the permissions to allow writing, run the script, then reset the permissions.


RE: Script to Update Plugins for 1.6.5 - Projec13 - 2012-03-01

(2012-02-29, 11:53 PM)pavemen Wrote: sounds like php does not have write access to the plugins folder/files. set the permissions to allow writing, run the script, then reset the permissions.

I have chmod the permissions on, Plugins / Inc folders to 755, I uploaded your file to: http://mywebsite/forums/, this is the correct path right ? It does the scan, saying stuff needs fixed "as above" but shows nothing being updated. I also tried chmoding everything to 777, including your file still no success Sad if I pm you the link to your .php so you can run it, can you help me better ?


RE: Script to Update Plugins for 1.6.5 - pavemen - 2012-03-01

sure, send me the info


RE: Script to Update Plugins for 1.6.5 - One-Two - 2012-04-07

Worked fine.
Thank you!


RE: Script to Update Plugins for 1.6.5 - Pentium6 - 2012-05-07

why i get this error
[Image: UFO7Z.png]


RE: Script to Update Plugins for 1.6.5 - pavemen - 2012-05-07

you uploaded it to the wrong location. per instructions, upload to the root of your mybb installation.


RE: Script to Update Plugins for 1.6.5 - JaysonL - 2012-05-13

This is awesome, great share.
Thanks a lot.


RE: Script to Update Plugins for 1.6.5 - FooFighter - 2012-05-20

Should we disable our plugins before we run these processes?


RE: Script to Update Plugins for 1.6.5 - pavemen - 2012-05-20

no need to, it goes really fast