MyBB Community Forums
[General] theme is messed up after restoring a backup - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Community Archive (https://community.mybb.com/forum-106.html)
+--- Forum: Archived Forums (https://community.mybb.com/forum-143.html)
+---- Forum: Archived Development and Support (https://community.mybb.com/forum-155.html)
+----- Forum: MyBB 1.6 (https://community.mybb.com/forum-138.html)
+------ Forum: 1.6 General Support (https://community.mybb.com/forum-127.html)
+------ Thread: [General] theme is messed up after restoring a backup (/thread-122162.html)

Pages: 1 2


theme is messed up after restoring a backup - andrewjs18 - 2012-07-09

I'm testing my backups to make sure they're good to go when I noticed that after restoring the database with a backup I just made, the site acts as if the theme isn't even there.

this is a 100% new install, with the exception of using the database from a live site that was backed up rather than a fresh database.

this is what I did:

1) upload mybb files
2) create new db for the new install
3) proceed with the normal install
4) after the install was complete, I dropped all the tables that mybb inserted with the new install and imported the backup I made from the live site
5) when the import was done, I modified the config.php to reflect the new site's cookie information and etc.

here a link to the test site (it's using the default mybb theme):
http://andrewshemo.com/testforum2/index.php

and a brief screenshot:
   

what's going on here?


RE: theme is messed up after restoring a backup - Known - 2012-07-09

Upload that theme's images folder. It seems like that's what is missing.


RE: theme is messed up after restoring a backup - andrewjs18 - 2012-07-09

(2012-07-09, 04:19 AM)Known Wrote: Upload that theme's images folder. It seems like that's what is missing.

the new site (the one I linked to), is using the default mybb theme.


RE: theme is messed up after restoring a backup - Known - 2012-07-09

Oh, your missing the default theme's global.css as well as shavenook420.png
Upload those and you'll be good to go.


RE: theme is messed up after restoring a backup - andrewjs18 - 2012-07-09

(2012-07-09, 07:11 AM)Known Wrote: Oh, your missing the default theme's global.css as well as shavenook420.png
Upload those and you'll be good to go.

the global.css exists.

like I said, this is a 100% clean install with nothing changed other than using a backup from my live site rather than using a new database.


RE: theme is messed up after restoring a backup - Known - 2012-07-09

Check that it has the proper file permissions on it and that it's not blank (sometimes this happens) because Chrome is reporting those two files are missing.


RE: theme is messed up after restoring a backup - andrewjs18 - 2012-07-10

(2012-07-09, 10:04 PM)Known Wrote: Check that it has the proper file permissions on it and that it's not blank (sometimes this happens) because Chrome is reporting those two files are missing.

simple blue is the default mybb theme.

   

   


RE: theme is messed up after restoring a backup - Dollarâ„¢ - 2012-07-10

A simple right click then reload should do the fix.


RE: theme is messed up after restoring a backup - Omar G. - 2012-07-10

Save each style sheet again.


RE: theme is messed up after restoring a backup - andrewjs18 - 2012-07-10

(2012-07-10, 03:22 AM)Dollarâ„¢ Wrote: A simple right click then reload should do the fix.

interesting..now it's working.

did me going into the global.css file make it somehow work again?!?!

also, I'm curious: why is a backup directly from mybb larger than a mysql dump on the database being used for the forum?