MyBB Community Forums
help with avatar on index/thread display alignment - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Extensions (https://community.mybb.com/forum-201.html)
+--- Forum: Themes (https://community.mybb.com/forum-103.html)
+---- Forum: Theme Support (https://community.mybb.com/forum-10.html)
+---- Thread: help with avatar on index/thread display alignment (/thread-126413.html)



help with avatar on index/thread display alignment - vegathechosen - 2012-09-19

Hello,

I was recently looking at the tutorials section and came across this cool feature about having avatars displayed on the board index as well as the thread index page. After reading the thread I came across another users post who claimed his plugin was better than this walkthrough as it had less queries than the original. So I gave it a shot and it worked nicely! My one gripe is that the text doesn't align with the avatar which gives it this unimpressive look. I went to the forums this was posted at and made a comment about them not displaying correctly and that I needed to make custom edits myself, problem being I need my hand held through stuff like this as I'm still learning so I thought what better place to ask than here. I thought this might go in the plug in help section but seeing that this is what I believe to be a theme/template issue I figured you guys would be the best to help.

Here's an example of how the display looks when installed,
[Image: 2_19_09_12_1_34_19.png]

Here's an example of how Id like the avys to look
[Image: 2_19_09_12_1_41_28.png]

Here's a link to the tutorial on mybb as well as the recommendation from a user on his plugin
http://community.mybb.com/thread-114472-page-4.html

here's a link to the plugin/article if you want to test it out
http://mybbhacks.zingaburga.com/showthread.php?tid=1216

So I'm not to sure how to make this look neater and will need some help if possible to be pointed in the right area or what exactly to edit or if there's another plugin available that already does this please point me in that direction cuz I find this to be extremely cool.


Thanks for reading and any help you can give.


RE: help with avatar on index/thread display alignment - Tecca - 2012-09-20

Go into your forumdisplay_thread template and look for the two variables that have been inserted. I've never used the plugin, so I'm unsure of what they will be, but variables will look similar to {$thisisavariable}

From there, style it. Example: <span style="float: left;">{$thisisavariable}</span>

EDIT: Actually, Sama stated there was a template for the avatar, so go into global templates and find that template, and put the <span> around it in there instead.

If you need more help than this, paste your template here.


RE: help with avatar on index/thread display alignment - vegathechosen - 2012-09-20

Thanks ill get to this asap and report back, thanks Tecca!

Also unrelated that Elders Scrolls forum is magnificent.


RE: help with avatar on index/thread display alignment - Ted S - 2012-09-21

I had same issue and used this span style.

 <span style="float: left; border: 1px solid #cccccc; padding: 2px; margin-right: 4px;"></span>



RE: help with avatar on index/thread display alignment - vegathechosen - 2012-09-26

That worked! Thanks everyone for your help! One little thing small overlap issue anyone got a fix for this?
[Image: 2_26_09_12_5_55_23.jpeg]

thanks for any help you can give


RE: help with avatar on index/thread display alignment - Ted S - 2012-09-26

That image next to first avatar seems to be pushing line Try to adjust padding or margin numbers.
The second avatar seems fine though.


RE: help with avatar on index/thread display alignment - vegathechosen - 2012-09-26

Hi Ted,
thanks for the response, I'm fine with the avatar placement, but if you notice the text it runs off the column, you'll notice the "d" on "should" is over the line, and the 2nd post you can see "..." at the end. Do you know how to fix this?

Thanks again.


RE: help with avatar on index/thread display alignment - Tecca - 2012-09-26

In your forumbit_depth2_forum template, find the last post td. It should look similar to this:

<td class="{$bgcolor}" valign="top" align="right" style="white-space: nowrap">{$lastpost}</td>

Change "nowrap" to "normal".