MyBB Community Forums
Inline Moderation and Mod Powers Not Working.... - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Community Archive (https://community.mybb.com/forum-106.html)
+--- Forum: Archived Forums (https://community.mybb.com/forum-143.html)
+---- Forum: Archived Development and Support (https://community.mybb.com/forum-155.html)
+----- Forum: MyBB 1.6 (https://community.mybb.com/forum-138.html)
+------ Forum: 1.6 General Support (https://community.mybb.com/forum-127.html)
+------ Thread: Inline Moderation and Mod Powers Not Working.... (/thread-132236.html)

Pages: 1 2 3


Inline Moderation and Mod Powers Not Working.... - Agent Shark - 2013-01-05

So basically my issue is odd. When working on my website, I actually installed my new theme (Novus Cardinal) into the main rather than make a sub folder for it. Thus meaning I really can't go back to my old theme...

So basically my issue is that my mod powers (selecting threads, mass closing, etc) are all not working. Whenever I select a thread, it doesn't register that I selected it and thus meaning I can't modify the thread (close, delete, move, etc).

Any suggestions on how to fix this? Maybe I should try re-installing the java scripts for mods?

I appreciate any help given!


RE: Inline Moderation and Mod Powers Not Working.... - dragonexpert - 2013-01-06

Does anything you are using utilize jQuery?


RE: Inline Moderation and Mod Powers Not Working.... - Euan T - 2013-01-06

Could you provide a link to your site please?


RE: Inline Moderation and Mod Powers Not Working.... - Agent Shark - 2013-01-06

(2013-01-06, 06:30 PM)euantor Wrote: Could you provide a link to your site please?

Yes, my site is http://MalwareForums.net

Along with this issue, there are other issues as well that I've seen posted on this site including some reputation glitches and text editors not appearing.


RE: Inline Moderation and Mod Powers Not Working.... - Euan T - 2013-01-06

ACP > Templates & Styles > Templates *YOUR TEMPLATE SET* > headerinclude>

find:

<script src="http://code.jquery.com/jquery-latest.js"></script>

add after

<script type="text/javascript">
jQuery.noConflict();
</script>



RE: Inline Moderation and Mod Powers Not Working.... - Agent Shark - 2013-01-07

(2013-01-06, 11:45 PM)euantor Wrote: ACP > Templates & Styles > Templates *YOUR TEMPLATE SET* > headerinclude>

find:

<script src="http://code.jquery.com/jquery-latest.js"></script>

add after

<script type="text/javascript">
jQuery.noConflict();
</script>

Not sure what this was supposed to do but I did it and nothing happened.


RE: Inline Moderation and Mod Powers Not Working.... - Euan T - 2013-01-07

Please paste your whole headerinclude template.


RE: Inline Moderation and Mod Powers Not Working.... - Agent Shark - 2013-01-07

The following link includes my headerinclude:

http://pastebin.com/CR77Gnb9


RE: Inline Moderation and Mod Powers Not Working.... - Euan T - 2013-01-07

Ok, try this instead:

<link rel="icon" type="image/png" href="http://i.imgur.com/wLqSA.png">
<link rel="alternate" type="application/rss+xml" title="{$lang->latest_threads} (RSS 2.0)" href="{$mybb->settings['bburl']}/syndication.php" />
<link rel="alternate" type="application/atom+xml" title="{$lang->latest_threads} (Atom 1.0)" href="{$mybb->settings['bburl']}/syndication.php?type=atom1.0" />
<meta http-equiv="Content-Type" content="text/html; charset={$charset}" />
<meta http-equiv="Content-Script-Type" content="text/javascript" />
<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/prototype.js?ver=1600"></script>
<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/general.js?ver=1600"></script>
<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/popup_menu.js?ver=1600"></script>
{$stylesheets}

<!--[if IE 7]>
<link href="{$theme['imgdir']}/ie7.css" rel="stylesheet" type="text/css" />
<![endif]-->
<script type="text/javascript">
<!--
    var cookieDomain = "{$mybb->settings['cookiedomain']}";
    var cookiePath = "{$mybb->settings['cookiepath']}";
    var cookiePrefix = "{$mybb->settings['cookieprefix']}";
    var deleteevent_confirm = "{$lang->deleteevent_confirm}";
    var removeattach_confirm = "{$lang->removeattach_confirm}";
    var loading_text = '{$lang->ajax_loading}';
    var saving_changes = '{$lang->saving_changes}';
    var use_xmlhttprequest = "{$mybb->settings['use_xmlhttprequest']}";
    var my_post_key = "{$mybb->post_code}";
    var imagepath = "{$theme['imgdir']}";
// -->
</script>

<script src="http://code.jquery.com/jquery-latest.js"></script>
<script type="text/javascript">
    jQuery.noConflict();
    jQuery(document).ready(function($) {
        $(".close").click(function () {
            $(".avviso").fadeOut("slow");
        });
    });
</script>
{$avvisospiti}
<script type="text/javascript" src="{$theme['imgdir']}/jscripts/theme-js.js"></script>
{$newpmmsg}



RE: Inline Moderation and Mod Powers Not Working.... - Agent Shark - 2013-01-07

(2013-01-07, 12:50 PM)euantor Wrote: Ok, try this instead:

<link rel="icon" type="image/png" href="http://i.imgur.com/wLqSA.png">
<link rel="alternate" type="application/rss+xml" title="{$lang->latest_threads} (RSS 2.0)" href="{$mybb->settings['bburl']}/syndication.php" />
<link rel="alternate" type="application/atom+xml" title="{$lang->latest_threads} (Atom 1.0)" href="{$mybb->settings['bburl']}/syndication.php?type=atom1.0" />
<meta http-equiv="Content-Type" content="text/html; charset={$charset}" />
<meta http-equiv="Content-Script-Type" content="text/javascript" />
<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/prototype.js?ver=1600"></script>
<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/general.js?ver=1600"></script>
<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/popup_menu.js?ver=1600"></script>
{$stylesheets}

<!--[if IE 7]>
<link href="{$theme['imgdir']}/ie7.css" rel="stylesheet" type="text/css" />
<![endif]-->
<script type="text/javascript">
<!--
    var cookieDomain = "{$mybb->settings['cookiedomain']}";
    var cookiePath = "{$mybb->settings['cookiepath']}";
    var cookiePrefix = "{$mybb->settings['cookieprefix']}";
    var deleteevent_confirm = "{$lang->deleteevent_confirm}";
    var removeattach_confirm = "{$lang->removeattach_confirm}";
    var loading_text = '{$lang->ajax_loading}';
    var saving_changes = '{$lang->saving_changes}';
    var use_xmlhttprequest = "{$mybb->settings['use_xmlhttprequest']}";
    var my_post_key = "{$mybb->post_code}";
    var imagepath = "{$theme['imgdir']}";
// -->
</script>

<script src="http://code.jquery.com/jquery-latest.js"></script>
<script type="text/javascript">
    jQuery.noConflict();
    jQuery(document).ready(function($) {
        $(".close").click(function () {
            $(".avviso").fadeOut("slow");
        });
    });
</script>
{$avvisospiti}
<script type="text/javascript" src="{$theme['imgdir']}/jscripts/theme-js.js"></script>
{$newpmmsg}

That fixed all the issues I've had so far including the ones I've asked help for. Thank you so much. I really appreciate it.