MyBB Community Forums
[How To?] MyBB, text even BEFORE header - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Community Archive (https://community.mybb.com/forum-106.html)
+--- Forum: Archived Forums (https://community.mybb.com/forum-143.html)
+---- Forum: Archived Development and Support (https://community.mybb.com/forum-155.html)
+----- Forum: MyBB 1.6 (https://community.mybb.com/forum-138.html)
+------ Forum: 1.6 General Support (https://community.mybb.com/forum-127.html)
+------ Thread: [How To?] MyBB, text even BEFORE header (/thread-133258.html)



MyBB, text even BEFORE header - goodboy133 - 2013-01-22

Hi guys, please see attached file below for more info.
So basically the prob is that when I visit a member's profile, it says "hi" even BEFORE the header, so I find it very odd and weird, even tho I edited nothing.
I reverted the template, but nothing happened.
I looked at the header, member_profile and index templates, but nothing fishy and weird there.
Any help please? Smile

Link to forum for any support: webmasterconvo.com


RE: MyBB, text even BEFORE header - José F. - 2013-01-22

In the file member.php, can't you find the "hi"?


RE: MyBB, text even BEFORE header - goodboy133 - 2013-01-22

No, not at all.
I don't know why this is happening.
I don't think it's somewhere in the member profile template, as the "hi" text is outputted even before the header, so it's very weird.

This is what I found when inspecting the "hi" element from fireg=bug when I go on a member's profile page
<html lang="en" xmlns="http://www.w3.org/1999/xhtml" xml:lang="en">
<head>
<body>
hi
<title>Webmaster Convo - Profile of goodboy133</title>
<link href="http://www.webmasterconvo.com/cache/themes/theme5/global.css" rel="stylesheet" type="text/css">
<link href="http://www.webmasterconvo.com/syndication.php" title="Latest Threads (RSS 2.0)" type="application/rss+xml" rel="alternate">
<link href="http://www.webmasterconvo.com/syndication.php?type=atom1.0" title="Latest Threads (Atom 1.0)" type="application/atom+xml" rel="alternate">
<meta content="text/html; charset=UTF-8" http-equiv="Content-Type">
<meta content="text/javascript" http-equiv="Content-Script-Type">
<script src="http://edge.quantserve.com/quant.js" async="" type="text/javascript">
<script src="http://www.webmasterconvo.com/jscripts/prototype.js?ver=1603" type="text/javascript">
<script src="http://www.webmasterconvo.com/jscripts/general.js?ver=1603" type="text/javascript">
<script src="http://www.webmasterconvo.com/jscripts/popup_menu.js?ver=1600" type="text/javascript">
<script type="text/javascript">
<noscript> <div style="display:none;"> <img src="//pixel.quantserve.com/pixel/p-eL8xv9X7aXb5W.gif" border="0" height="1" width="1" alt="Quantcast"/> </div> </noscript>
<script type="text/javascript">
<link href="http://fonts.googleapis.com/css?family=Ubuntu:regular,bold&subset=Latin" type="text/css" rel="stylesheet">
<script type="text/javascript">
<link href="images/WCicon.png" rel="icon" type="image/png">
<div id="header">
<hr class="hidden">
<div class="sha_bg"></div>
<div id="panel">
<div id="container">
<hr class="hidden">
<div id="footer">
<div id="YontooLocationStore2" style="display: none;">http://www.webmasterconvo.com/member.php?action=profile&uid=1</div>
<div id="BottomBarBrain2" class="yontoolayerwidget" style="left: 0px; top: 0px; text-align: left; vertical-align: top; width: 1px; height: 1px; position: absolute;"></div>
<div id="dropdowndeals" class="yontoolayerwidget" style="left: 1183px; top: 0px; text-align: left; vertical-align: top; width: 155px; height: 1px; line-height: 0px; z-index: 2147483647; position: fixed;">
<div id="TopRelatedTopics" class="yontoolayerwidget" style="left: 0px; top: 0px; text-align: left; vertical-align: top; width: 0px; height: 0px; position: absolute;"></div>
<div id="EasyInlineApp" class="yontoolayerwidget" style="left: 0px; top: 0px; text-align: left; vertical-align: top; width: 0px; height: 0px; position: absolute;"></div>
<div style="position: absolute; z-index: 2147483647; width: 133px; height: 41.65px; left: -1000px; top: -1000px;">
<div id="YontooInstallID" style="display: none;">b0ba0440-8372-40b6-a5ec-f4a689c829e5</div>
<div id="Y2PluginIds" style="display: none;">Y2:b0ba0440-8372-40b6-a5ec-f4a689c829e5</div>
</body>
</html>

Would anyone tell me what to do here?

You can see the hi text is just below the <body> tag. What to do next?


RE: MyBB, text even BEFORE header - Crash Override - 2013-01-22

It must be in the template, because upon inspecting the element of member.php?action=profile&uid=1 on your site, it is displayed right after the <body> tag.

Have a look at your member_profile template for your current theme. See if it's there.
In originality, you should see:
<body>
{$header}

But from your source, it also at the same time gives me doubts that it's in there.
Have a look at the XML you imported your theme from. See if the term "hi" is produced anywhere in it. It will give you a better idea of where it may be.

But to make sure it's even the theme, try switching to a different one before you go bounty hunting.


RE: MyBB, text even BEFORE header - goodboy133 - 2013-01-22

I looked at the XML file. No "hi" anywhere.
I switched to a different theme, it's all good.
Here's my member_profile template:
<html>
<head>
<title>{$mybb->settings['bbname']} - {$lang->profile}</title>
{$headerinclude}
</head>
<body>
{$header}
<table border="0" cellspacing="{$theme['borderwidth']}" cellpadding="{$theme['tablespace']}" class="tborder">
<tr>
<td class="trow1">
<table width="100%" cellspacing="0" cellpadding="0" border="0"><tr>
<span class="largetext"><strong>{$formattedname}</strong></span><br />
<span class="smalltext">
({$usertitle})<br />
{$groupimage}
{$userstars}<br />
<br />
<strong>{$lang->registration_date}</strong> {$memregdate}<br />
<strong>{$lang->date_of_birth}</strong> {$membday} {$membdayage}<br />
<strong>{$lang->local_time}</strong> {$localtime}<br />
<strong>{$lang->postbit_status}</strong> {$online_status}
</span>
</td>
</tr>
</table>
{$awaybit}
</table>
<br />
<table width="100%" cellspacing="0" cellpadding="0" border="0" align="center">
<tr>
<td width="50%" valign="top">
<table border="0" cellspacing="{$theme['borderwidth']}" cellpadding="{$theme['tablespace']}" class="tborder">
<tr>
<td colspan="2" class="thead"><strong>{$lang->users_forum_info}</strong></td>
</tr>
<tr>
<td class="trow1"><strong>{$lang->total_posts}</strong></td>
<td class="trow1">{$memprofile['postnum']} ({$lang->ppd_percent_total})<br /><span class="smalltext">(<a href="search.php?action=finduserthreads&amp;uid={$uid}">{$lang->find_threads}</a> &mdash; <a href="search.php?action=finduser&amp;uid={$uid}">{$lang->find_posts}</a>)</span></td>
</tr>
{$tyl_memprofile}
<tr>
<td class="trow2"><strong>{$lang->timeonline}</strong></td>
<td class="trow2">{$timeonline}</td>
</tr>
{$referrals}
{$reputation}


{$warning_level}<!-- ProfileComments -->{$pf_statistics}<!-- /ProfileComments -->{$newpoints_profile}<!-- ProfileComments -->{$pf_statistics}<!-- /ProfileComments -->
</table>
<br />
<table border="0" cellspacing="{$theme['borderwidth']}" cellpadding="{$theme['tablespace']}" class="tborder">
<tr>
<td colspan="2" class="thead"><strong>{$lang->users_contact_details}</strong></td>
</tr>
{$sendemail}
<tr>
<td class="{$bgcolors['pm']}"><strong>{$lang->pm}</strong></td>
<td class="{$bgcolors['pm']}"><a href="private.php?action=send&amp;uid={$memprofile['uid']}">{$lang->send_pm}</a></td>
</tr>
<tr>
<td class="{$bgcolors['icq']}"><strong>{$lang->icq_number}</strong></td>
<td class="{$bgcolors['icq']}">{$memprofile['icq']}</td>
</tr>
<tr>
<td class="{$bgcolors['aim']}"><strong>{$lang->aim_screenname}</strong></td>
<td class="{$bgcolors['aim']}"><a href="javascript:;" onclick="MyBB.popupWindow('misc.php?action=imcenter&amp;imtype=aim&amp;uid={$uid}', 'imcenter', 450, 300);">{$memprofile['aim']}</a></td>
</tr>
<tr>
<td class="{$bgcolors['yahoo']}"><strong>{$lang->yahoo_id}</strong></td>
<td class="{$bgcolors['yahoo']}"><a href="javascript:;" onclick="MyBB.popupWindow('misc.php?action=imcenter&amp;imtype=yahoo&amp;uid={$uid}', 'imcenter', 450, 300);">{$memprofile['yahoo']}</a></td>
</tr>
<tr>
<td class="{$bgcolors['msn']}"><strong>{$lang->msn}</strong></td>
<td class="{$bgcolors['msn']}"><a href="javascript:;" onclick="MyBB.popupWindow('misc.php?action=imcenter&amp;imtype=msn&amp;uid={$uid}', 'imcenter', 450, 300);">{$memprofile['msn']}</a></td>
</tr>
</table>

</td>

<td><img src="{$theme['imgdir']}/pixel.gif" height="1" width="8" alt=""/></td>
<td width="50%" valign="top">
{$profilefields}
{$modoptions}<!-- ProfileComments -->{$comments_index}<!-- /ProfileComments -->
{$adminoptions}
{$buddy_options}
</td>
</tr>
</table>
{$footer}
</body>
</html>

The "hi" is nowhere to be found.


RE: MyBB, text even BEFORE header - frostschutz - 2013-01-22

There was a plugin once that printed "hi" for no reason, could even turn into "hihihihihi", some kind of forgotten debug message - but I do not remember which plugin that was.

See if the "hi" vanishes when you switch the "disable all plugins" setting temporarily.


RE: MyBB, text even BEFORE header - goodboy133 - 2013-01-22

Let me see about that Smile

Awesome! When I temporarily disable them, the "hi" doesn't appear anymore. Gonna hunt the plugins down now.

YESSSSSSSSSSSSSSSS!!! IT'S FIXED!
It was the Signature Control plugin which was infected or something, this is solved!
Thanks so much for the help guys and gals!