MyBB Community Forums
[For 1.8] MyFacebook Connect 3.6 - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Extensions (https://community.mybb.com/forum-201.html)
+--- Forum: Plugins (https://community.mybb.com/forum-73.html)
+---- Forum: Plugin Releases (https://community.mybb.com/forum-102.html)
+---- Thread: [For 1.8] MyFacebook Connect 3.6 (/thread-137797.html)



RE: MyFacebook Connect 1.0.2.1 - martec - 2013-05-06

check this for me...

ps. last version of GitHub

Your copy of MyBB running on Fórum xxx has experienced an error. Details of the error include:
---
Type: 2
File: myfbconnect/src/facebook.php (Line no. 49)
Message
session_start() [<a href='function.session-start'>function.session-start</a>]: Cannot send session cache limiter - headers already sent (output started at /forum/inc/functions.php:98)


RE: MyFacebook Connect 1.0.2.1 - jaa09 - 2013-05-07

(2013-05-04, 11:26 AM)Shade Wrote:
(2013-05-04, 06:29 AM)jaa09 Wrote: I have an error, here's my forum url: http://www.camotesislandforum.com/ hope you help me..Thanks..

Sure. What's the problem? It seems like the plugin haven't been installed on your board yet.

(2013-05-04, 06:59 AM)orbitpdx Wrote: Thank you for this excellent plugin!

I am however having a problem.

These are the steps to the problem

1) User logs in via facebook connect
2) User prompted to enter facebook login info
3) User logs into forum using facebook connect
4) User logs off of forum and facebook
5) User clicks facebook connect
6) Problem - Despite beings logged off of Facebook, user is automatically logged into forum as facebook user. User cannot get to facebook login screen again if they want to change accounts.

I am using the one click login. The only way I could find to fix this is by clearing the cache of the web browser.

You're right. Thank you for reporting this! This problem is caused by the enhancements I've included in the last commit: to speed up the login process, if the user infos can be retrieved before prompting the login page then the user is directly logged in instead of send an unuseful request to the Facebook server. However, it seems like the Facebook API can obtain the user's data even if he has logged out: that's because the secure access token is stored in a PHP session in your browser's cookies and it's not deleted by Facebook when you log out.

I have to check whether if there's a reliable way to see if an user is logged out from Facebook.

----

Fixed in https://github.com/Shade-/MyFacebook-Connect/commit/79fa96c339e9243d39cf73ca074ce74220f360b1

i removed from my board because its not working i can't insert my facebook i.d. the button is working but my problem is how to insert my facebook i.d? .,

I'm using filezilla to upload the plug ins, is there's a alternative way or manually ad this?


RE: MyFacebook Connect 1.0.2.1 - Shade - 2013-05-07

(2013-05-06, 10:17 PM)martec Wrote: check this for me...

ps. last version of GitHub

Your copy of MyBB running on Fórum xxx has experienced an error. Details of the error include:
---
Type: 2
File: myfbconnect/src/facebook.php (Line no. 49)
Message
session_start() [<a href='function.session-start'>function.session-start</a>]: Cannot send session cache limiter - headers already sent (output started at /forum/inc/functions.php:98)

Weird. It happens only for you I guess, no one has reported it so far. I'll look into it for sure.

(2013-05-07, 07:12 AM)jaa09 Wrote: i removed from my board because its not working i can't insert my facebook i.d. the button is working but my problem is how to insert my facebook i.d? .,

I'm using filezilla to upload the plug ins, is there's a alternative way or manually ad this?

Please refer to the official documentation to install and setup the plugin correctly.


RE: MyFacebook Connect 1.0.2.1 - martec - 2013-05-07

(2013-05-07, 11:45 AM)Shade Wrote: Weird. It happens only for you I guess, no one has reported it so far. I'll look into it for sure.

this error is generated by error log of mybb.
error log need enabled in ACP.
- Use Error Handling: on
- Error Logging Medium: log error


RE: MyFacebook Connect 1.0.2.1 - therussiangamer - 2013-05-07

You didn't let us login with your Facebook account. Please authorize our application from your Facebook Application manager if you would like to login into our Forum.

Everytime.. even thought I press okay to allow the app to do what needs to be done.


RE: MyFacebook Connect 1.0.2.1 - Shade - 2013-05-08

(2013-05-07, 12:22 PM)martec Wrote: this error is generated by error log of mybb.
error log need enabled in ACP.
- Use Error Handling: on
- Error Logging Medium: log error

It seems like that there's a non-destructive conflict between MyBB and Facebook SDK. They both starts a PHP session and this causes an "error" to be thrown in the error logs. Nothing particularly risky as you are able to fully use the plugin, but I'll provide a patch soon to avoid this kind of silent errors to be thrown.

Thank you for your report.

(2013-05-07, 10:48 PM)therussiangamer Wrote: You didn't let us login with your Facebook account. Please authorize our application from your Facebook Application manager if you would like to login into our Forum.

Everytime.. even thought I press okay to allow the app to do what needs to be done.

This usually happens with misconfigured applications. I've planned to change this generic error with a more specific error reading what Facebook returns after the authentication, letting you know what you are doing wrong.

In the meantime, did you follow the instructions provided in the documentation carefully? Ensure that your Facebook application has the required options activated.


RE: MyFacebook Connect 1.0.2.1 - mmergola - 2013-05-08

(2013-05-08, 10:09 AM)Shade Wrote:
(2013-05-07, 10:48 PM)therussiangamer Wrote: You didn't let us login with your Facebook account. Please authorize our application from your Facebook Application manager if you would like to login into our Forum.

Everytime.. even thought I press okay to allow the app to do what needs to be done.

This usually happens with misconfigured applications. I've planned to change this generic error with a more specific error reading what Facebook returns after the authentication, letting you know what you are doing wrong.

In the meantime, did you follow the instructions provided in the documentation carefully? Ensure that your Facebook application has the required options activated.

I was just about to add my name to the list, but I got it to work and figured I'd share. The solution was simple (for me, at least)... under the Facebook App settings, I had to change sandbox mode from enabled to disabled and save the changes. Hope that helps someone else.


RE: MyFacebook Connect 1.0.2.1 - Shade - 2013-05-08

In the documentation is expressively said that Sandbox Mode must be disabled. Glad you got it sorted yourself though Smile


RE: MyFacebook Connect 1.0.2.1 - therussiangamer - 2013-05-08

I'm sorry, but you can't use this board until the administrator fixes the problem.

I dunno,,, its been showing on this plugin/.

I tried reuploading and deleating everything.


RE: MyFacebook Connect 1.0.2.1 - Shade - 2013-05-09

It has nothing to do with my plugin.