MyBB Community Forums
[For 1.8] MyFacebook Connect 3.6 - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Extensions (https://community.mybb.com/forum-201.html)
+--- Forum: Plugins (https://community.mybb.com/forum-73.html)
+---- Forum: Plugin Releases (https://community.mybb.com/forum-102.html)
+---- Thread: [For 1.8] MyFacebook Connect 3.6 (/thread-137797.html)



RE: MyFacebook Connect 1.1 - Shade - 2013-09-13

Nope, the current version of MFC doesn't feature this thing.


RE: MyFacebook Connect 1.1 - alv4 - 2013-09-16

I'm Having a problem when loggin in with Facebook. Appear this:
MyBB has experienced an internal SQL error and cannot continue.

SQL Error:
    2006 - MySQL server has gone away
Query:
    SELECT name, pid, tid, allowedgroups FROM mybb_themes WHERE pid != '0' ORDER BY pid, name 

PS: The twitter one is working correctly.


RE: MyFacebook Connect 1.1 - Shade - 2013-09-16

It's sort of a timeout error, not specifically caused by MFC. Google for error 2006 on MySQL installations to solve.


RE: MyFacebook Connect 1.1 - gamemaster - 2013-09-17

Hi. I got this error when trying to login with fb. How to solve it ?

[Image: 44444.png]


RE: MyFacebook Connect 1.1 - Shade - 2013-09-17

Simply update your MFC copy with the latest from GitHub. You're most probably using a legacy version of the plugin which contained that kind of bug.


RE: MyFacebook Connect 1.1 - gamemaster - 2013-09-18

link ??

i downloaded the link from mods site.. Version 1.1. is it wrong ?

and now this error

An unknown error occurred. The output of the error is:

error setting certificate verify locations:
CAfile: /etc/pki/tls/certs/ca-bundle.crt
CApath: none

ok. i fixed up the problem.. Good plugin after all Big Grin


RE: MyFacebook Connect 1.1 - CptChaosNL - 2013-09-22

With the latest zipball from GitHub I get this error when I click on 'Facebook integration' within my UserCP:

Quote:MyBB has experienced an internal SQL error and cannot continue.

SQL Error:
1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'FROM mybb_users WHERE uid = 1' at line 1
Query:
SELECT FROM mybb_users WHERE uid = 1
The query should be

SELECT * FROM mybb_users WHERE uid = 1*, then it works perfectly. Smile But I can't find where that query is?

Or just select the fields you actually need offcourse... Wink In the mean time, I'm back to 1.0.3, which seems to work correctly.


RE: MyFacebook Connect 1.1 - Shade - 2013-09-22

The query should work even without the *. However, MyFacebook Connect doesn't trigger that query at all, so it's not MFC the cause of the issue.


RE: MyFacebook Connect 1.1 - Cmaniac - 2013-09-22

Hello, I would suggest a change in myfbconnect.php.

At line 666:

		"displaygroup" => $mybb->settings['myfbconnect_usergroup'],

Could be made:

		"displaygroup" => "0",

That way, the displayed group is the same as the primary group, as in MyBB by default per user.

Thank you after all for the great plugin.


RE: MyFacebook Connect 1.1 - CptChaosNL - 2013-09-22

(2013-09-22, 03:09 PM)Shade Wrote: The query should work even without the *. However, MyFacebook Connect doesn't trigger that query at all, so it's not MFC the cause of the issue.

I tried the query in PHPMyAdmin as well, but did gave the same error. I added the asterisk and the query worked.
As said, I went back to MFC 1.0.3 and all is working again, so I guess it something has to do with MFC 1.1. Smile