MyBB Community Forums
[For 1.8] MyFacebook Connect 3.6 - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Extensions (https://community.mybb.com/forum-201.html)
+--- Forum: Plugins (https://community.mybb.com/forum-73.html)
+---- Forum: Plugin Releases (https://community.mybb.com/forum-102.html)
+---- Thread: [For 1.8] MyFacebook Connect 3.6 (/thread-137797.html)



RE: MyFacebook Connect 2.1 - Shade - 2015-01-05

Delete all the columns from mybb_users table which begin with "fb". You have probably ran the installation script twice.


RE: MyFacebook Connect 2.1 - meetdilip - 2015-01-05

Had / Have the same issue. Will try this.

Stuck on this error while clicking the"  log in with FB " link


Quote:Given URL is not allowed by the Application configuration.: One or more of the given URLs is not allowed by the App's settings. It must match the Website URL or Canvas URL, or the domain must be a subdomain of one of the App's domains.



RE: MyFacebook Connect 2.1 - jason5 - 2015-01-06

(2015-01-05, 09:01 AM)meetdilip Wrote: Had / Have the same issue. Will try this.


Stuck on this error while clicking the"  log in with FB " link



Quote:Given URL is not allowed by the Application configuration.: One or more of the given URLs is not allowed by the App's settings. It must match the Website URL or Canvas URL, or the domain must be a subdomain of one of the App's domains.

Did you give the proper url in App settings in FB? An incomplete settings in App can cause an issue.


RE: MyFacebook Connect 2.1 - meetdilip - 2015-01-06

Guess so. A friend fixed it for me.


RE: MyFacebook Connect 2.1 - matt4 - 2015-01-09

Well, I know others have had this problem. I'm willin to bet its some config issue at my end but I've cross checked sooo many times.



Quote:An unknown error occurred. The output of the error is:
An active access token must be used to query information about the current user.

Please report this error to an administrator and try again.


Any idea what I can look for now? I'm lost the domain is set correctly in Facebook.

My forum URL is - http://politicshub.co.uk

Thank you,


RE: MyFacebook Connect 2.1 - Shade - 2015-01-09

I have recently discovered that port 443 must be open on your server behalf. An automated check is not included at the moment, but I will include it in an upcoming minor version. I am currently doing some exams so I am quite busy, the new version won't see the sunlight for some weeks. In the meantime, you can check on your own by asking to your hosting provider if that port is closed. This is likely to be true if you are using a free hosting provider, as they usually keep this as a feature for premium plans.


RE: MyFacebook Connect 2.1 - matt4 - 2015-01-10

Hope your exams go well. Focus on those!

The port 443is open on my server and I'm still having problems. I'm going to investigate this more later. If anyone has any idea what I could be missing I'd be grateful.

Matt


RE: MyFacebook Connect 2.1 - Shade - 2015-01-10

Maybe you are accessing the login page directly on the redirect URL. This is the only way I can think MFC could throw that error. Check the login url, it must contain action=login, not action=do_login. I will investigate further when I finish the exams. Thank you for your patience.


RE: MyFacebook Connect 2.1 - matt4 - 2015-01-11

Pasted my login URL - http://politicshub.co.uk/myfbconnect.php?action=login

Take your time man. Reply when your ready and good luck Smile


RE: MyFacebook Connect 2.1 - Shade - 2015-01-12

You seem to hace a wrong URL in the facebook configuration. Follow the instructions provided in the docs. Many users have encountered your issue because they didn't read the docs carefully.