MyBB Community Forums
[For 1.8] MyFacebook Connect 3.6 - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Extensions (https://community.mybb.com/forum-201.html)
+--- Forum: Plugins (https://community.mybb.com/forum-73.html)
+---- Forum: Plugin Releases (https://community.mybb.com/forum-102.html)
+---- Thread: [For 1.8] MyFacebook Connect 3.6 (/thread-137797.html)



RE: MyFacebook Connect 2.1 - matt4 - 2015-01-13

It looks correct to me Undecided
I know shade is away. Is there anyone who had this issue before that can assist me?

   

Thank you,


RE: MyFacebook Connect 2.1 - dragonexpert - 2015-01-27

Suggestion: Use a control statement in your function that hooks to admin_formcontainer_output_row. Right now it is always executing when a row is output even if the form has nothing to do with myfacebookconnect.


RE: MyFacebook Connect 2.1 - Shade - 2015-01-27

if ($page->active_action != "settings" and $mybb->input['action'] != "change" and $mybb->input['gid'] != myfbconnect_settings_gid()) {
	return false;
}

A control statement is already implemented for that hook.


RE: MyFacebook Connect 2.1 - dragonexpert - 2015-01-27

Odd. I know some pages it was doing a query for every use. I'll look more into it. Maybe I have an outdated version.


RE: MyFacebook Connect 2.1 - DrXotick - 2015-01-28

Working for 1.6?

EDIT: NM, I see it available in 1.6 mods site. Thanks for the work Shade.


RE: MyFacebook Connect 2.1 - Shade - 2015-01-28

Use the new version (2.1) available on the 1.8 Mods Site. It's compatible with 1.6 and it is more up to date than the one on the 1.6 mods site.


RE: MyFacebook Connect 2.1 - DrXotick - 2015-01-28

Okay. I will do that

I also have a question.

1. When I logged in via Facebook, it auto-detected my email and associated Facebook with my forum account, but didn't give me any options regarding Avatar etc... It auto synced my Facebook avatar. Shouldn't it ask if I want those synced?

2. I have a friend who tried it and it did bring her to these options (sync avatar etc..), but it didn't auto associate her with her forum account even though the emails were the exact same. So it double registered her under a new user name then there were 2 users with different user names but the same email. EDIT: She just did it again and it properly associated email address from FB to forum, but returned error #200

3. I just dissociated, changed my forum email and went through the sign up process again where it brought me to the options page. For the heck of it, I tried to use the email address I had changed the forum address to and it returned an error #200, but still registered the user. So then again there are two different users with the same email, but different accounts/usernames etc..

4. How to set default user settings to "instant email notifications"? I have it like this on regular signup, where it's automatically selected (they can change it if they wish when signing up, or in user CP)

5. How to show sign up agreement before sending them through to registration?

Sorry, it's a lot.

I hope I'm being clear. If I'm not being understood, I will try to explain again. Smile


I do have one-click deselected.


RE: MyFacebook Connect 2.1 - Shade - 2015-01-29

Thanks to @DrXotick I have found that Facebook has changed the string which controls posting permissions on users' behalf. If you are using the publish on users' timeline option, you and your users might come across error #200: permissions not granted while still registering users correctly. I am currently not able to update the plugin, but for a temporary workaround, you might:

1) open /inc/plugins/MyFacebookConnect/class_facebook.php

2) find, line 95:

$permissions[] = 'publish_stream';

3) replace with:

$permissions[] = 'publish_actions';

And save.


RE: MyFacebook Connect 2.1 - makeadvise - 2015-02-04

Hi Experts,

I am having a facebook login button on my home page it's working fine but once user is getting in on that time also it's displaying on the page which is not correct as it should hide once user logged in to the application ...

any solution..my web page URL is http://makeadvise.com/

Thanks & Regards,
Prince


RE: MyFacebook Connect 2.1 - Shade - 2015-02-04

You have put the image in the wrong template, which should be header_welcomeblock_guest.