MyBB Community Forums
[For 1.8] MyFacebook Connect 3.6 - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Extensions (https://community.mybb.com/forum-201.html)
+--- Forum: Plugins (https://community.mybb.com/forum-73.html)
+---- Forum: Plugin Releases (https://community.mybb.com/forum-102.html)
+---- Thread: [For 1.8] MyFacebook Connect 3.6 (/thread-137797.html)



RE: MyFacebook Connect 2.2 - andrewjs18 - 2015-09-11

I'm also unable to install & activate the plugin as it's telling me port 443 isn't open, but it is from my iptables rules:

# Allow HTTP and HTTPS connections from anywhere (the normal ports for websites and SSL).
-A INPUT -p tcp --dport 80 -j ACCEPT
-A INPUT -p tcp --dport 443 -j ACCEPT

I know that you said we can disable the port checker above, but why is it failing if port 443 is opened on my server?


RE: MyFacebook Connect 2.2 - Shade - 2015-09-11

(2015-09-07, 05:03 PM)liisyaoron Wrote:
(2015-09-06, 05:52 PM)Shade Wrote: Sure thing. I am currently away and cannot access my GitHub, but I will be back next weekend and will update the docs accordingly.

Great, you might need to update the plugin I think since I'm having this problem as well:

An unknown error occurred. The output of the error is:
An active access token must be used to query information about the current user.

Please report this error to an administrator and try again.

There's an extra option in the 'Client OAuth Settings' under the 'Advanced Tab' which is the 'Web OAuth Login', it's default is Off but if you leave it like that it will throw out an error on Facebook that you need to enable it but if you enable that OAuth option then the error above comes in when it gets redirected.

EDIT
Also, if you're using the PHP SDK the current version is 5. Maybe this plugin is using an old SDK?

In order to keep consistency with MyBB's minimum PHP requirements, I have edited the SDK (v3.2.3) making it working despite being an "old" version. Newer versions usually include functions that do not concern MFC's workflow as they are just additional service such as Pokes, Groups management, etc..

Your issue, however, is fairly common but I could not reproduce it in the past. I might get a look on it as it's been a while Since the last update, but I'm quite bust and can't say exactly when. This applies to all the other issue you guys are encountering. The next scheduled update will include an option to disable the port check in case you would like to try the plugin even if it's saying the port is closed.


RE: MyFacebook Connect 2.2 - andrewjs18 - 2015-09-11

(2015-09-11, 06:50 AM)Shade Wrote:
(2015-09-07, 05:03 PM)liisyaoron Wrote:
(2015-09-06, 05:52 PM)Shade Wrote: Sure thing. I am currently away and cannot access my GitHub, but I will be back next weekend and will update the docs accordingly.

Great, you might need to update the plugin I think since I'm having this problem as well:

An unknown error occurred. The output of the error is:
An active access token must be used to query information about the current user.

Please report this error to an administrator and try again.

There's an extra option in the 'Client OAuth Settings' under the 'Advanced Tab' which is the 'Web OAuth Login', it's default is Off but if you leave it like that it will throw out an error on Facebook that you need to enable it but if you enable that OAuth option then the error above comes in when it gets redirected.

EDIT
Also, if you're using the PHP SDK the current version is 5. Maybe this plugin is using an old SDK?

In order to keep consistency with MyBB's minimum PHP requirements, I have edited the SDK (v3.2.3) making it working despite being an "old" version. Newer versions usually include functions that do not concern MFC's workflow as they are just additional service such as Pokes, Groups management, etc..

Your issue, however, is fairly common but I could not reproduce it in the past. I might get a look on it as it's been a while Since the last update, but I'm quite bust and can't say exactly when. This applies to all the other issue you guys are encountering. The next scheduled update will include an option to disable the port check in case you would like to try the plugin even if it's saying the port is closed.

is there a bug that would cause the port to say it's not open, even though it is?


RE: MyFacebook Connect 2.2 - liisyaoron - 2015-09-11

(2015-09-11, 06:50 AM)Shade Wrote:
(2015-09-07, 05:03 PM)liisyaoron Wrote:
(2015-09-06, 05:52 PM)Shade Wrote: Sure thing. I am currently away and cannot access my GitHub, but I will be back next weekend and will update the docs accordingly.

Great, you might need to update the plugin I think since I'm having this problem as well:

An unknown error occurred. The output of the error is:
An active access token must be used to query information about the current user.

Please report this error to an administrator and try again.

There's an extra option in the 'Client OAuth Settings' under the 'Advanced Tab' which is the 'Web OAuth Login', it's default is Off but if you leave it like that it will throw out an error on Facebook that you need to enable it but if you enable that OAuth option then the error above comes in when it gets redirected.

EDIT
Also, if you're using the PHP SDK the current version is 5. Maybe this plugin is using an old SDK?

In order to keep consistency with MyBB's minimum PHP requirements, I have edited the SDK (v3.2.3) making it working despite being an "old" version. Newer versions usually include functions that do not concern MFC's workflow as they are just additional service such as Pokes, Groups management, etc..

Your issue, however, is fairly common but I could not reproduce it in the past. I might get a look on it as it's been a while Since the last update, but I'm quite bust and can't say exactly when. This applies to all the other issue you guys are encountering. The next scheduled update will include an option to disable the port check in case you would like to try the plugin even if it's saying the port is closed.

Hi Shade,
Thanks for the update. I have no issues regarding the port since the port needed is open anyways. The only problem I have is the one I mentioned. I'm using MyBB 1.8.5 with your latest release. Your Twitter plugin is working correctly on my site though.


RE: MyFacebook Connect 2.2 - Shade - 2015-09-11

Not really. The function used might be partially blocked on your PHP configuration. The port check is nothing more than a connection test to localhost using a fsockopen(). If your PHP config blocks this function, the test might fail even though the port is open.

@liisyaoron: I will look into it as soon as possible.


RE: MyFacebook Connect 2.2 - liisyaoron - 2015-09-11

(2015-09-11, 07:59 AM)Shade Wrote: Not really. The function used might be partially blocked on your PHP configuration. The port check is nothing more than a connection test to localhost using a fsockopen(). If your PHP config blocks this function, the test might fail even though the port is open.

@liisyaoron: I will look into it as soon as possible.

Hi Shade,
Thanks, I appreciate it. Wondering what that function in PHP is so I can ask my host to check on it and activate/disable the corresponding module for it.


RE: MyFacebook Connect 2.2 - Shade - 2015-09-11

fsockopen()


RE: MyFacebook Connect 2.2 - andrewjs18 - 2015-09-11

(2015-09-11, 07:59 AM)Shade Wrote: Not really. The function used might be partially blocked on your PHP configuration. The port check is nothing more than a connection test to localhost using a fsockopen(). If your PHP config blocks this function, the test might fail even though the port is open.

@liisyaoron: I will look into it as soon as possible.

hmn, I ran a test to see if fsockopen was enabled, and it says it is:

<?php
if(function_exists('fsockopen')){
echo "fsockopen function is enabled";
}
else{
echo "fsockopen is not enabled";
}
?>

output: fsockopen function is enabled


RE: MyFacebook Connect 2.2 - Ronshaan - 2015-09-12

hi, i want to know how to fix this,
when i log in using facebook, the site goes to facebook instead of staying on the site,
how to fix this error.


RE: MyFacebook Connect 2.2 - andrewjs18 - 2015-09-13

I got this to install by commenting out the port checker.

(2015-09-12, 07:35 PM)Ronshaan Wrote: hi, i want to know how to fix this,
when i log in using facebook, the site goes to facebook instead of staying on the site,
how to fix this error.

I have the same issue. I reported the bug on github.