MyBB Community Forums
[For 1.8] MyFacebook Connect 3.6 - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Extensions (https://community.mybb.com/forum-201.html)
+--- Forum: Plugins (https://community.mybb.com/forum-73.html)
+---- Forum: Plugin Releases (https://community.mybb.com/forum-102.html)
+---- Thread: [For 1.8] MyFacebook Connect 3.6 (/thread-137797.html)



RE: MyFacebook Connect 2.3 - Shade - 2015-11-14

Solved. The test board is old, but it will be updated in the next couple of days. Thank you for the report.


RE: MyFacebook Connect 2.3 - andrewjs18 - 2015-11-14

Shade, I believe the facebook avatar sync tries to add the avatar URL in the gravatar field which doesn't seem to work. is this a known issue?


RE: MyFacebook Connect 2.3 - Shade - 2015-11-15

The gravatar field is the same as the avatar URL which is what MFC updates every time, grabbing Facebook's data at every login. Syncing has been working fine since the first version.


RE: MyFacebook Connect 2.3 - PipiShortstocking - 2015-11-15

Glad to hear it has been restored to its former glory.

Also, when opening port 443, where exactly do I open it, in my firewall settings? Or with my hosting provider?

Once that's done, how do I add the social login links/images (as described in Flyover Settings > Login box style) to my "Login to account" signin popup and "Create an account" page? Because as of now they only show up on the "User panel" page under "Miscellaneous" > "Third party integration" section.

PluginLibrary is installed and cURL is enabled (screenshot attached).

I've gone over both https://github.com/Shade-/MyFacebook-Connect/wiki/Extended-documentation and https://github.com/Shade-/MyFacebook-Connect/wiki/How-to-install and I'm still having trouble getting everything working correctly.


RE: MyFacebook Connect 2.3 - Shade - 2015-11-15

For everything regarding Flyover, open a new support thread in the dedicated section of my site Smile Port 443 must be enabled on your server (hosting provider).


RE: MyFacebook Connect 2.3 - PipiShortstocking - 2015-11-15

So I can re-close port 443 in my firewall then? 

Just kidding, already closed it.  Toungue


RE: MyFacebook Connect 2.3 - agentc0re - 2015-11-22

Hi Shade, I am receiving this error when attempting to test if i've setup everything correctly.
http://agentc0re.com/agentc0re/forum/index.php 73.20.2.187 /agentc0re/forum/mytwconnect.php?action=login 500
I dunno what this really means.  I've double checked and am pretty sure i have the right callback url, as i know it's the most faced problem you solve.

Also, i'm getting this similar error on G+ and FB login plugins of yours.

Thank you for the help you do provide!
-Jon

Update

Just checked my server logs and found this.  Weird thing, these files do not have group set to write.
[Sun Nov 22 00:37:48 2015] [error] [client 73.20.2.187] SoftException in Application.cpp:261: File "/home/agentc0re/public_html/agentc0re/forum/mytwconnect.php" is writeable by group
[Sun Nov 22 00:37:37 2015] [error] [client 73.20.2.187] SoftException in Application.cpp:261: File "/home/agentc0re/public_html/agentc0re/forum/mytwconnect.php" is writeable by group, referer: http://agentc0re.com/agentc0re/forum/index.php


*****

Okay seconds later i realized i made a dumb mistake when checking permissions.  Yes these files had their write bit set for group.  It appears that google & facebook work but Twitter does not.  Looking into it further.

Update 2

Figured out my last mistake.  I had callback locking on.  Whoops.  All seems to be working.  I hope my mistakes and misfortunes helps someone else out.


RE: MyFacebook Connect 2.3 - Eldenroot - 2016-01-31

(2015-10-20, 08:15 AM)hkkp Wrote: i have this in acp:

code: 0

/www/htdocs/xxx/myfbconnect/src/base_facebook.php


line: 1294

same issue:
9.1.2016, 7:47
/xxx/xxx.com/web/myfbconnect/src/base_facebook.php
1294



RE: MyFacebook Connect 2.3 - Shade - 2016-01-31

It's likely caused by the post-to-wall feature. I will investigate once I will have enough time to install MFC on my test board and I will update the feature. In the meantime, disable the option within your ACP.


RE: MyFacebook Connect 2.3 - shubluck - 2016-02-22

Will It work with Flatty Theme