MyBB Community Forums
Server Migration - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Community Archive (https://community.mybb.com/forum-106.html)
+--- Forum: Archived Forums (https://community.mybb.com/forum-143.html)
+---- Forum: Archived Development and Support (https://community.mybb.com/forum-155.html)
+----- Forum: MyBB 1.6 (https://community.mybb.com/forum-138.html)
+------ Forum: 1.6 Installation and Upgrades Support (https://community.mybb.com/forum-162.html)
+------ Thread: Server Migration (/thread-148243.html)

Pages: 1 2


Server Migration - 2mac - 2013-11-23

I'm currently migrating to another server.

I already have all of my old MyBB files from my previous machine and the database has been imported.

However, if I go to my forum directory, I get a white screen. I assumed that I still needed to install, so I went to forums/install (using the proper web address, of course), but was still given a white screen.

Help?


RE: Server Migration - .m. - 2013-11-23

you do not have to re-install MyBB. see below guides
How to change hosts successfully | How to transfer your forum to another host


RE: Server Migration - 2mac - 2013-11-23

Suppose the original host is unavailable and I can't open the admin controls from it. Is there still a chance to recover?

Essentially, can I turn off those plugins by editing a file or db?


RE: Server Migration - .m. - 2013-11-23

^ well, you said that backups of the files and the database are transferred - so old host controls are not required
files backup should have included the plugins and database backup should consist of their settings


RE: Server Migration - 2mac - 2013-11-23

In that case, I shouldn't be having an issue. I moved the files to the proper location and imported the mybb database with phpMyAdmin, but I'm still getting a white screen.


RE: Server Migration - .m. - 2013-11-23

^ can you check server error log (should be available at the web host panel) and find the cause
can we have your forum URL


RE: Server Migration - 2mac - 2013-11-23

Ehm, I don't use a web host. I am the host. Do you know the file path of this log? (linux)

Forum URL: http://veganroach.com/forums


RE: Server Migration - .m. - 2013-11-23

Quote:The error log is probably in /var/log/httpd or /var/log/apache2



RE: Server Migration - 2mac - 2013-11-23

Log contains:

Quote:[Sat Nov 23 11:39:49 2013] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
[Sat Nov 23 11:39:49 2013] [notice] suEXEC mechanism enabled (wrapper: /usr/bin/suexec)
[Sat Nov 23 11:39:49 2013] [notice] Digest: generating secret for digest authentication ...
[Sat Nov 23 11:39:49 2013] [notice] Digest: done
[Sat Nov 23 11:39:50 2013] [notice] Apache/2.2.25 (Unix) mod_ssl/2.2.25 OpenSSL/1.0.1e DAV/2 PHP/5.5.6 configured -- resuming normal operations
[Sat Nov 23 11:40:40 2013] [error] [client 173.216.22.185] PHP Warning: Unknown: open_basedir restriction in effect. File(/var/www/forums/index.php) is not within the allowed path(s): (/srv/http/:/home/:/tmp/:/usr/share/pear/:/usr/share/webapps/) in Unknown on line 0, referer: http://www.veganroach.com/
[Sat Nov 23 11:40:40 2013] [error] [client 173.216.22.185] PHP Warning: Unknown: failed to open stream: Operation not permitted in Unknown on line 0, referer: http://www.veganroach.com/
[Sat Nov 23 11:40:40 2013] [error] [client 173.216.22.185] PHP Fatal error: Unknown: Failed opening required '/var/www/forums/index.php' (include_path='.:/usr/share/pear') in Unknown on line 0, referer: http://www.veganroach.com/



RE: Server Migration - .m. - 2013-11-23

^ veganroach.com is also not displaying any page! anyway, can you concentrate on below log and take care of it (ref.)
open_basedir restriction in effect. File(/var/www/forums/index.php) is not within the allowed path(s)