MyBB Community Forums
[Upgrading] Issues while upgrading to 1.6.12 - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Community Archive (https://community.mybb.com/forum-106.html)
+--- Forum: Archived Forums (https://community.mybb.com/forum-143.html)
+---- Forum: Archived Development and Support (https://community.mybb.com/forum-155.html)
+----- Forum: MyBB 1.6 (https://community.mybb.com/forum-138.html)
+------ Forum: 1.6 Installation and Upgrades Support (https://community.mybb.com/forum-162.html)
+------ Thread: [Upgrading] Issues while upgrading to 1.6.12 (/thread-151570.html)



Issues while upgrading to 1.6.12 - tpsadmin - 2014-03-02

Hey guys,

I've tried to upgrade the board to 1.6.12 from 1.6.11, I downloaded the zip and checked the docs, and backed up settings.php from /inc folder as it asked me to.

Then I copied all the contents of Upload folder onto my site, and copied back my settings.php to /inc folder.

When I visit mysite/install/upgrade.php I get the following error:
Warning [2] require_once(/home/thepirateship/public_html/inc/db_.php): failed to open stream: No such file or directory - Line: 63 - File: install/upgrade.php PHP 5.3.10-1ubuntu3.8 (Linux)

I googled for a solution which suggested me to change the permissions of settings.php and config.php to 777 or 666 (I tried both), but the problem still exists. The contents of config.php (which was a renamed file from config.default.php) is blank.

What do I need to do to solve this issue?.

Thanks in advance.

I've fixed this issue with the help from Jordan on IRC.

I've downloaded this config file: https://gist.github.com/JordanMussi/9305428#file-config-php
and replaced the database values in the file, and re-uploaded it onto the server.

changed the permissions to 777 and the installer works again now.

thanks guys.