MyBB Community Forums
[Pushed] account awaiting activation bug - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Development (https://community.mybb.com/forum-161.html)
+--- Forum: MyBB 1.8 Development (https://community.mybb.com/forum-165.html)
+---- Forum: 1.8 Bugs and Issues (https://community.mybb.com/forum-157.html)
+----- Forum: Pushed (https://community.mybb.com/forum-183.html)
+----- Thread: [Pushed] account awaiting activation bug (/thread-156406.html)

Pages: 1 2 3


account awaiting activation bug - OMID_HXC - 2014-07-22

i install mybb 1.8 beta 3
i register a user but got an mysql error:
see picture:
[Image: fo6is3zeyba6t60fl7zn.jpg]


now with ADMIN account i have error on top:
There is 1 account awaiting activation. Please go to your ACP to activate the users.

and in Admin_CP:
2 Registered Users
2 Active Users
2 Registrations Today
1 Awaiting Activation


when i click on:
1 Awaiting Activation
i got this error:
No users were found matching the specified search criteria. Please modify your search criteria and try again.

------

and
Registration Method: Send Email Verification
also i use Activation url from user email.
and user already marked as registered

------

i think this is a bug. but if i have free time, test it with more registrations.


RE: account awaiting activation bug - fxzt - 2014-07-22

I can confirm the error after activating the user from Admin CP.

http://i.imgur.com/5BgTaGJ.png

After activating, the awaiting activation notification is still displayed

Quote:There is 1 account awaiting activation. Please go to your ACP to activate the users.



RE: account awaiting activation bug - SeNCeR - 2014-07-22

(2014-07-22, 04:09 PM)fizit Wrote: I can confirm the error after activating the user from Admin CP.

http://i.imgur.com/5BgTaGJ.png

After activating, the awaiting activation notification is still displayed

Quote:There is 1 account awaiting activation. Please go to your ACP to activate the users.

I think the problem into global.php $cache->update_awaitingactivation(); line to be added..


RE: account awaiting activation bug - Darth Apple - 2014-07-22

I have noticed this bug as well on my current test install of the beta 3 release.


RE: account awaiting activation bug - Diogo Parrinha - 2014-07-22

Hi,

Thank you for your report. We have pushed this issue to our Github repository for further analysis where you can track our commits and progress with fixing this bug. Discussions regarding this bug may also take place there too.

Follow this link to visit the issue on Github: https://github.com/mybb/mybb/issues/1007

Thanks for contributing to MyBB!

Regards,
The MyBB Group


RE: account awaiting activation bug - OMID_HXC - 2014-07-23

Thanks


RE: account awaiting activation bug - Omar G. - 2014-07-23

(2014-07-22, 07:32 PM)SeNCeR Wrote: I think the problem into global.php $cache->update_awaitingactivation(); line to be added..

It wouldn't. I would rather remove the feature that adding that line.


RE: account awaiting activation bug - OMID_HXC - 2014-07-23

i register second user and there is just first error.
i think there is Additional +1 for awaiting activation user come from core in database.


RE: account awaiting activation bug - SeNCeR - 2014-07-24

(2014-07-23, 05:34 AM)Omar G. Wrote:
(2014-07-22, 07:32 PM)SeNCeR Wrote: I think the problem into global.php $cache->update_awaitingactivation(); line to be added..

It wouldn't. I would rather remove the feature that adding that line.

Errors, Rebuild Cache awaitingactivation executing improving.

admin/modules/home/index.php
// Get the number of users awaiting validation
below the line..
$cache->update_awaitingactivation();
My question is I've added a fix.


RE: account awaiting activation bug - NINJA0210 - 2014-07-29

(2014-07-22, 04:09 PM)fxzt Wrote: I can confirm the error after activating the user from Admin CP.

http://i.imgur.com/5BgTaGJ.png

After activating, the awaiting activation notification is still displayed

Quote:There is 1 account awaiting activation. Please go to your ACP to activate the users.

I have same problem,always display this message. ^^