MyBB Community Forums
Plugins Error - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Community Archive (https://community.mybb.com/forum-106.html)
+--- Forum: Archived Forums (https://community.mybb.com/forum-143.html)
+---- Forum: Archived Development and Support (https://community.mybb.com/forum-155.html)
+----- Forum: 1.8 Beta Support (https://community.mybb.com/forum-156.html)
+----- Thread: Plugins Error (/thread-157798.html)



Plugins Error - Twisty - 2014-08-20

I upload a plugin after changing it's compatibility and no matter what plugin I try to install as soon as i click 'Activate' it goes to a blank page. It's even doing it to the MyBB plugins I know do work for 1.8


RE: Plugins Error - Eldenroot - 2014-08-20

Almost all 1.6 plugins must be edited for 1.8... compatibility edit is not enough


RE: Plugins Error - Darth Apple - 2014-08-20

What plugin are you trying to install?


RE: Plugins Error - IntoxNitram - 2014-08-20

Basically none of them will work without the plugin author releasing a new code for it. This is due to the vast changes in the way myBB works for 1.8

Plugins will need to be edited to work, more than just the compatibility line.


RE: Plugins Error - Darth Apple - 2014-08-20

Getting old plugins to work under MyBB 1.8 has been no issue whatsoever for me. Most of the plugins I've tried to port have only really required the compatibility line be changed. (Just for testing purposes, I attempted to install newpoints on MyBB 1.8. It works perfectly with nothing other than the compatibility line changed. )

Of course that obviously won't be the case for every plugin. Some plugins may require a few changes to the way template edits are made in order to work properly. For example, plugins that added header notifications by adding a new variable after {$unreadreports} in the header template will have to add the variable after {$awaitingusers} now in order to work as intended, etc. Some changes to the setting types may also be ideal, but these aren't required because MyBB 1.8 doesn't seem to have done anything there to break compatibility with the setting types previously used by plugins.

The hooks for the most part seem to be much the same. They've added some new hooks, but I have yet to run into any situation where the hooks in 1.8 have broken compatibility with hooks used by 1.6.

Because 1.8 adds some useful features for plugins as well as new features (such as default avatar functionality) that may need to be integrated into, it will obviously be ideal for plugin authors to update their plugins officially for 1.8, but getting *most* basic plugins to work on 1.8 shouldn't be all that difficult, at least based on my experience attempting to get them to work. They actually have done much less to break compatibility for plugins than they have done for themes.


RE: Plugins Error - Twisty - 2014-08-20

New Points worked for me on an old server. Now, nope.