MyBB Community Forums
When Will Most Using Plugins Will Available For MyBB 1.8 ? - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: 1.8 Support (https://community.mybb.com/forum-175.html)
+--- Forum: General Support (https://community.mybb.com/forum-176.html)
+--- Thread: When Will Most Using Plugins Will Available For MyBB 1.8 ? (/thread-158487.html)



When Will Most Using Plugins Will Available For MyBB 1.8 ? - Ankit Arya - 2014-09-02

Like

1.Gomobile (Mobile Version)
2.MyBB-Google-SEO-master
3.Thanks System For Posts
4.2step auth
5.Min. Posts For Attachments
6.Guest Can't View Links (Login or Register To View Links) [Hidelinks]
7.Shoutbox
8.Page Manager
9.Social Network Sharing (iShare)
10. Spam Manager (Like Akismet)


ndd more..... Big Grin


RE: When Will Most Using Plugins Will Available For MyBB 1.8 ? - Destroy666 - 2014-09-02

When the plugin authors will rewrite them, of course. You have to be patient.


RE: When Will Most Using Plugins Will Available For MyBB 1.8 ? - FBI - 2014-09-03

the option only two,
wait for 1.8 release update
or... stick in your 1.6 :p


RE: When Will Most Using Plugins Will Available For MyBB 1.8 ? - marcus123 - 2014-09-03

So changing:

"compatibility" => "16*"
to
"compatibility" => "18*"

Is not the solution?


RE: When Will Most Using Plugins Will Available For MyBB 1.8 ? - jshort - 2014-09-03

(2014-09-03, 04:28 PM)marcus123 Wrote: So changing:

"compatibility" => "16*"
to
"compatibility" => "18*"

Is not the solution?

For some plugins, it is because the relevant core code hasn't changed. However, for others, you'll need to make actual edits to the plugin itself to get it to work.


RE: When Will Most Using Plugins Will Available For MyBB 1.8 ? - Destroy666 - 2014-09-03

(2014-09-03, 04:28 PM)marcus123 Wrote: So changing:

"compatibility" => "16*"
to
"compatibility" => "18*"

Is not the solution?

It is, but it may not always fully work.

Especially in these cases:
- if a plugin uses Prototype JS
- if a plugin loads another redundant jQuery instance
- if a plugin uses a hook that was changed in 1.8 (only several were)
- if a plugin tries to insert codes to heavily modified 1.8 templates (you can insert them manually though)


RE: When Will Most Using Plugins Will Available For MyBB 1.8 ? - Matt - 2014-09-03

Changing that value is what will make the plugin list allow you to activate it, but whether it actually works properly or not after doing that will have to be looked at on a plugin-by-plugin basis.


RE: When Will Most Using Plugins Will Available For MyBB 1.8 ? - SunDi3yansyah - 2014-09-10

if I force the plugin into an array like this: 

"compatibility" => "18*"

whether I will be notifying ACP if the creator of the plugin has to renew