MyBB Community Forums
[For 1.8] Recent Threads On Index [Updated 02-12-19] - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Extensions (https://community.mybb.com/forum-201.html)
+--- Forum: Plugins (https://community.mybb.com/forum-73.html)
+---- Forum: Plugin Releases (https://community.mybb.com/forum-102.html)
+---- Thread: [For 1.8] Recent Threads On Index [Updated 02-12-19] (/thread-159857.html)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36


RE: Recent Threads On Index [Updated 02-14-17] - dragonexpert - 03-11-2017

I'll look into it when I get off work.


RE: Recent Threads On Index [Updated 02-14-17] - dragonexpert - 03-11-2017

(03-11-2017, 08:17 AM)andrewjs18 Wrote: noticed a quick annoyance.  not sure if it's a bug or what though..

if you post a thread and then unapprove the thread, the plugin doesn't care and it'll still display it.  I can understand it posting it initially as you have to post a thread before you can unapprove it (I believe), but when the plugin refreshes, it should check the permissions, I'd think, no?

After looking through this, I'm about 99% certain you were logged in as either a moderator or administrator because I cannot reproduce this when I am not logged in.  It doesn't show the unapproved class, which is what I think is causing confusion.  I'll upload a new build that shows the unapproved thread background momentarily.


RE: Recent Threads On Index [Updated 03-11-17] - Darkrad - 03-11-2017

Why it's not visible at 'Plugin Updates' when this plugin gets new build?


RE: Recent Threads On Index [Updated 03-11-17] - andrewjs18 - 03-11-2017

(03-11-2017, 03:21 PM)dragonexpert Wrote:
(03-11-2017, 08:17 AM)andrewjs18 Wrote: noticed a quick annoyance.  not sure if it's a bug or what though..

if you post a thread and then unapprove the thread, the plugin doesn't care and it'll still display it.  I can understand it posting it initially as you have to post a thread before you can unapprove it (I believe), but when the plugin refreshes, it should check the permissions, I'd think, no?

After looking through this, I'm about 99% certain you were logged in as either a moderator or administrator because I cannot reproduce this when I am not logged in.  It doesn't show the unapproved class, which is what I think is causing confusion.  I'll upload a new build that shows the unapproved thread background momentarily.

ah, yes. sorry, I forgot to mention that.


RE: Recent Threads On Index [Updated 03-11-17] - myinnershelf - 03-12-2017

Hello Smile

I'm using this plugin with Rush theme (a child theme) but nothing is displayed, I've tried with Default theme, it doesn't work Sad
Any help :'(


RE: Recent Threads On Index [Updated 03-11-17] - Whiteneo - 03-12-2017

Is the latest download i check it for a friend today and i see there are some few details to work with but all of them are easier to fix, but i add some things for that buddy so yes mod have some errors.

1.- Templates are not loaded due a missing val inside $sid with ' there is no necesary to adf that only var must be enought and i change some other things but that is the most important due system wasn't load templates needed.

I think that is the most important thing at least in last revision of the plugin. I din't knoe this mod, so i am not sure if previews have the same issue by the way.


RE: Recent Threads On Index [Updated 03-11-17] - dragonexpert - 03-12-2017

(03-12-2017, 12:22 PM)myinnershelf Wrote: Hello Smile

I'm using this plugin with Rush theme (a child theme) but nothing is displayed, I've tried with Default theme, it doesn't work Sad
Any help :'(


Open the index templates and make sure there is the following code in it:
<div id="recentthreads">{$recentthreadtable}</div>

Also make sure on that same template that just below {$headerinclude} you put {$recentthread_headerinclude}.


RE: Recent Threads On Index [Updated 03-11-17] - Darkrad - 03-13-2017

I deactivated it today to see if issue I am experiencing today is caused by this plugin. After deactivation nothing happens when I activate it again - simply its not shown in index and I noticed Recent Threads Templates are empty.

So yeah I am back to version 11.


RE: Recent Threads On Index [Updated 03-11-17] - Whiteneo - 03-13-2017

yes that is what i try to explain.

And i let you know what to do. Because templates are not created due an error in code so when you try to call it never arrives. Because templates are empty.

Change the value as i said and should work but even there are some lesser errors in plugin and they are easy to fix it.


RE: Recent Threads On Index [Updated 03-11-17] - Eldenroot - 03-14-2017

(03-13-2017, 08:30 PM)Dark Neo Wrote: Change the value as i said and should work but even there are some lesser errors in plugin and they are easy to fix it.

It would be nice if you can tell us what is broken and what needs to be fixed... specify issue and how to reproduce, I think that it is better than just write - it is broken but the fix is easy - so what is broken?

It will be much easier to fix these issues if you report them to @dragonexpert. Thank you very much