MyBB Community Forums
Alignment Problem - Can Anyone Help ? - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: 1.8 Support (https://community.mybb.com/forum-175.html)
+--- Forum: General Support (https://community.mybb.com/forum-176.html)
+--- Thread: Alignment Problem - Can Anyone Help ? (/thread-160742.html)

Pages: 1 2


Alignment Problem - Can Anyone Help ? - Mike-B - 10-04-2014

Hi,

Since switching to 1.8 my portal 'post' alignment has gone strange and the user details & avatars are missing - Having tried to solve this problem myself I am now totally at a loss & need help.

A picture speaks a thousand words:

[Image: alignment.jpg]

Thanks.

Note: Please be aware you are looking at a cropped image - Ignore the left hand side, that's the crop and not the issue at all.


RE: Portal Post Alignment ? - BaggerHD - 10-04-2014

One of your "min-width" is wider then % of container I guess.
But to be shore, give us ( or pm) the url


RE: Portal Post Alignment ? - adi19 - 10-04-2014

What is you url forum?


RE: Portal Post Alignment ? - Mike-B - 10-04-2014

Having changed from 'horizontal postbit' to the 'classic postbit' in ACP plus User CP for the first time I notice this:

[Image: alignment-2.jpg]


Help !!

Fyi everything (apart from width - had same issue when width was default 85% too) is default.
Perhaps worth mentioning also is this was an upgrade & not a fresh install.


RE: Alignment Problem - Can Anyone Help ? - Mike-B - 10-05-2014

Anyone? - this is doing my head in!


RE: Alignment Problem - Can Anyone Help ? - .m. - 10-05-2014

^ your picture is showing MyBB 1.8's stock theme but your forum has a different theme. post a test user account to check


RE: Alignment Problem - Can Anyone Help ? - Mike-B - 10-05-2014

I have two forums - the one linked to in my sig is fine.

To be honest I would rather not give access.


RE: Alignment Problem - Can Anyone Help ? - .m. - 10-05-2014

^ not asking admin account!


RE: Alignment Problem - Can Anyone Help ? - Mike-B - 10-05-2014

I'm sure the problem comes from an issue with my 1.6 before upgrading!


RE: Alignment Problem - Can Anyone Help ? - .m. - 10-05-2014

on the portal page, if you want posted by details to align left then
portal_announcement template
<td class="trow2" align="right">
<span class="smalltext">{$lang->posted_by} {$profilelink}  - {$anndate} - {$lang->forum} <a href="{$mybb->settings['bburl']}/{$announcement['forumlink']}">{$announcement['forumname']}</a> {$numcomments}</span>
</td>
change alignment to left in <td class="trow2" align="right">

let me know if I am mistaken about your requirement

portal_announcement_avatar template code
<td class="trow1" style="text-align: center; vertical-align: top;" {$useravatar['width_height']}><img src="{$useravatar['image']}" alt="" {$useravatar['width_height']} /></td>

on your forum portal page, avatar width is taken as 0 - find out the cause

btw, there are two bugs related to MyBB 1.8 portal page
http://community.mybb.com/thread-158488.html
http://community.mybb.com/thread-159049.html