MyBB Community Forums
[Rejected] Avatar bug - edit a user - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Development (https://community.mybb.com/forum-161.html)
+--- Forum: MyBB 1.8 Development (https://community.mybb.com/forum-165.html)
+---- Forum: 1.8 Bugs and Issues (https://community.mybb.com/forum-157.html)
+----- Forum: Rejected (https://community.mybb.com/forum-184.html)
+----- Thread: [Rejected] Avatar bug - edit a user (/thread-161695.html)

Pages: 1 2 3


Avatar bug - edit a user - Eldenroot - 2014-10-22

Open admin CP -> Users and Groups -> Users -> find somebody with DEFAULT avatar and click on "Edit Profile and Settings" -> now try to change anything and press "SAVE".

-> Warning message with invalid URL for avatar image - this is a bug, because user has no own avatar (just default mybb one), url field is empty.

I added a screenshot


RE: Avatar bug - edit a user - martec - 2014-10-22

i can´t reproduce here...


RE: Avatar bug - edit a user - Destroy666 - 2014-10-22

Can't reproduce either - a user who uses default avatar is saved just fine. Are you sure you're having this issue on a clean MyBB 1.8 install?


RE: Avatar bug - edit a user - Eldenroot - 2014-10-22

OK, so maybe it is because of update from clean MyBB 1.6.15 to MyBB 1.8.0... I dont use any plugins, if you cannot reproduce this issue close it...

OK, here is the problem:

..//images/default_avatar.png in URL field -> it must be caused by updating - this bug appears only for users which have been registered before update

if you delete this from url field, everything is OK. For me it is ok, because it is a test forum but for someone who has a forum with thousands of users... Sad


I just created new test forum - based on mybb 1.6 -> created 3 users -> update to MyBB 1.8 and tried to change avatar - everything seems to be fine, I dont know what is wrong. Reject this, it is a waste of time


RE: Avatar bug - edit a user - ArchPrime - 2014-11-27

Just confirming I also have this issue under MyBB 1.8.3.  If I attempt to edit an existing user who has default avatar image, I get this error . Url/path to avatar image is correct and required image is present.  This was not an issue until upgrading to 1.8x from 1.6.15
A clean install is not an option - I need current forum to work.

- see screenshot
   


RE: Avatar bug - edit a user - Leefish - 2014-11-28

Try jpeg vs jpg - I think that is the issue, and if so it is a bug if you have allowed jpeg as a file type. I know it says jpg, but I had this issue the other day; I resaved the avatar as jpg by saving for web in Photoshop and it uploaded.

I think this report needs more checking before rejection.


RE: Avatar bug - edit a user - Eldenroot - 2014-11-28

IT is because of "..." in url adress. Delete them and it works fine


RE: Avatar bug - edit a user - Destroy666 - 2014-11-28

Well, Eldenroot's issue was caused by a 1.6 plugin/code which set a default avatar image for that user - the core never had this functionality, that's why this got rejected.

ArchPrime's addition is worth more consideration though, because old avatar gallery links seem to be blocked too if I see correctly. So moved back. No idea if there is a good solution though, maybe reenabling avatar paths with dots, not sure why they were disallowed in the first place.

EDIT: nvm, both are actually default avatars most likely from a plugin, I don't know where I saw avatar gallery reference, maybe in another topic. But I won't reject it since I see no reason to disallow dotted paths. Connected with this: https://github.com/mybb/mybb/issues/1589


RE: Avatar bug - edit a user - ArchPrime - 2014-12-15

Hi - in my case, the correct default avatar image is actually showing, even though the error message implies it can't be found

Avatar was supplied by the Default Avatar plugin, which has been fine up til now.

Removing the dots in the path did not help, nor did resaving image as web optimized jpg, nor did using the full url to image.

Is there anything else I can try?  I currently cannot edit user profiles at all

   


RE: Avatar bug - edit a user - Eldenroot - 2014-12-15

We should reject this issue - it is caused by plugin from mybb 1.6

@ArchPrime - please, could you try another link? I fixed this issue - just uninstal old plugin completely or edit every user without profile