MyBB Community Forums
Error 404 while opening threads. - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: 1.8 Support (https://community.mybb.com/forum-175.html)
+--- Forum: General Support (https://community.mybb.com/forum-176.html)
+--- Thread: Error 404 while opening threads. (/thread-163788.html)



Error 404 while opening threads. - utkarshmttl - 2014-12-06

I have installed MyBB 1.8.3 here..
www.hrrealvalue.com/doubtbook

When I open a thread.. It shows error 404..

I have disabled Search engine friendly URLs but it still does not work.


RE: Error 404 while opening threads. - .m. - 2014-12-06

is there a rewrite rules file ? security rules used for the main site might be conflicting


RE: Error 404 while opening threads. - utkarshmttl - 2014-12-06

(2014-12-06, 03:18 AM).m. Wrote: is there a rewrite rules file ? security rules used for the main site might be conflicting
How to check for the rewrite rules file? Where may I find it? And what can I do to resolve the conflicting issues. I use parallels plesk panel, though you ought to know, just in case.


RE: Error 404 while opening threads. - .m. - 2014-12-06

check for web.config file at the main site folder & MyBB folder

I am not sure about conflicting security rules in web.config but you can also check whether MyBB system
is able to access showthread.php file by running file verification tool available at tools & maintenance
section of forum Admin Panel


RE: Error 404 while opening threads. - utkarshmttl - 2014-12-06

(2014-12-06, 03:41 AM).m. Wrote: check for web.config file at the main site folder & MyBB folder

I am not sure about conflicting security rules in web.config but you can also check whether MyBB system
is able to access showthread.php file by running file verification tool available at tools & maintenance
section of forum Admin Panel

Okay, so I couldn't find web.config file in both the main site or mybb directories but I ran the file verification tool as you said and it shows about a 100 files as missing, showthread.php among them. How do I upload these specific files? Or will uploading only showthread will make the website work?

No, I figured it out. It was showing almost all the files from the install directory which we are supposed to remove anyways. So I uploaded the showthread file and now it's working perfectly, thanks lot.