MyBB Community Forums
Javascript/inline moderation not working? - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: 1.8 Support (https://community.mybb.com/forum-175.html)
+--- Forum: General Support (https://community.mybb.com/forum-176.html)
+--- Thread: Javascript/inline moderation not working? (/thread-164158.html)

Pages: 1 2


Javascript/inline moderation not working? - Leviathan - 12-14-2014

My inline moderation is not working, along with most things that require javascript popups, etc. This includes the quick edit. I have had this issue before, but fixed it by editing to the headerinclude. Now it's randomly happening again, and reverting the headerinclude back to it's original state doesn't help. I have searched through multiple websites and threads for a solution and none of them work. Any help is appreciated. Thank you.


RE: Javascript/inline moderation not working? - .m. - 12-14-2014

what is MyBB version of your forum and can we have your forum URL so that someone can check


RE: Javascript/inline moderation not working? - Leefish - 12-14-2014

I actually had this happen; it was an error in a template causing the js to fail.

http://community.mybb.com/post-1123286.html#pid1123286

Check in your console using the browser tools and see where the error is in the js.


RE: Javascript/inline moderation not working? - Leviathan - 12-14-2014

(12-14-2014, 11:25 AM).m. Wrote: what is MyBB version of your forum and can we have your forum URL so that someone can check

I am running a 1.8 install, and the forum is not yet ready for public release, and I have provisions for me and my admins that disallow them to be harmed by what I have on it. Once the website is ifnish, and the code isn't harmful, I will allow people to join.


(12-14-2014, 01:14 PM)Leefish Wrote: I actually had this happen; it was an error in a template causing the js to fail.

http://community.mybb.com/post-1123286.html#pid1123286

Check in your console using the browser tools and see where the error is in the js.


Can you tell me how to do that? I am not good with JS.


RE: Javascript/inline moderation not working? - Leefish - 12-14-2014

Neither am I Toungue

You need to use the inspection tools for your browser (Google) and then in the console when you refresh the page it should give an error; from that error we can help further.

Take a screenshot of the error in the console.


RE: Javascript/inline moderation not working? - Leviathan - 12-15-2014

[Image: OBhWZ2H.png]

Here you are, sir.


RE: Javascript/inline moderation not working? - Leefish - 12-15-2014

Um. Are you using a 1.8 theme as the base for your edits? Because it looks like you have some 1.6 code in there and / or missing js files.

Does this happen on the default theme that ships with 1.8?


RE: Javascript/inline moderation not working? - Leviathan - 12-15-2014

It is the Vinna theme, for 1.8, yes. I do however have modified plugins installed that I upgradedmyself from 1.6. Also, I amm using mybb gomobile, which could account for the theme being 1.6 if you are on mobile. I have the same problem with the default theme.


RE: Javascript/inline moderation not working? - Johnny S - 12-15-2014

(12-15-2014, 06:43 PM)Leviathan Wrote: It is the Vinna theme, for 1.8, yes. I do however have modified plugins installed that I upgradedmyself from 1.6. Also, I amm using mybb gomobile, which could account for the theme being 1.6 if you are on mobile. I have the same problem with the default theme.


In your installed / activated plugins (on plugins page) do you have one that relies on javascript (some 1.6 plugins like "fit on page", "thank you / like system", myalerts (prototype version), few shoutboxes are relying on prototype library [that was default in 1.6]) ?


RE: Javascript/inline moderation not working? - Leefish - 12-15-2014

I have to confess I am stumped. Looking at that you either dont have all the js files on the server or they are not correctly linked in the templates.

If you are having these issues with the default theme then the first thing is to disable all plugins and test on the default theme. If the default theme then has no issues then its a plugin. If you are still having issues on the default theme please ensure you have all the js files.