MyBB Community Forums
MyBB Pro Sub-Forum Issue - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Extensions (https://community.mybb.com/forum-201.html)
+--- Forum: Themes (https://community.mybb.com/forum-103.html)
+---- Forum: Theme Support (https://community.mybb.com/forum-10.html)
+---- Thread: MyBB Pro Sub-Forum Issue (/thread-166909.html)



MyBB Pro Sub-Forum Issue - Robmeister89 - 2015-02-11

So the sub-forums don't appear correctly when there's multiple sub-forums in a forum.

To see what I mean please view my forum CFA Forums and check out the forum CFA Talk's sub-forums on the main page. They are separated way too much. Adding a third makes things worse.

How do I fix this?


RE: MyBB Pro Sub-Forum Issue - .m. - 2015-02-11

navigate to open bootstrap.min.css style sheet of the theme and edit in advanced mode. around line 10 find code like below
.col-md-6 {
    width: 50%;
}
you can reduce that percentage to 20 or 25 or 33 and save the style sheet
remember hard refreshing your browser (eg. press CTRL + F5) on index page to see the changes


(edited)


RE: MyBB Pro Sub-Forum Issue - Robmeister89 - 2015-02-11

Where do I find the boostrap.min.css?


RE: MyBB Pro Sub-Forum Issue - .m. - 2015-02-11

^ forum admin panel >> themes (left side column menu) >> MyBBPro --> bootstrap.min.css


RE: MyBB Pro Sub-Forum Issue - Robmeister89 - 2015-02-11

bootstrap.min.css isn't there..

I see boostrap-fixes.css but there's nothing remotely close to what you wrote above in that one..


RE: MyBB Pro Sub-Forum Issue - .m. - 2015-02-11

^ oh! it is a file located in a subfolder of the theme images folder
~/images/MyBBPro/bootstrap/css/bootstrap.min.css

you can edit it by using any text editor (notepad or notepad++ or through web host file manager)


RE: MyBB Pro Sub-Forum Issue - Robmeister89 - 2015-02-11

Thanks! I got it fixed.

Wait... now the footer (board stats and legend) is messed up!

Well... looks as though the topics are all screwed up as well.. all of the user items (edit, quote, pm, etc.) are all messed up in the topics..

I went ahead and put that setting back to 50%.. is there any other possible way to fix the sub-forums issue?


RE: MyBB Pro Sub-Forum Issue - .m. - 2015-02-11

hmm., can you navigate to forumbit_depth3 template of the theme (in Forum Bit Templates) and find code like below
<div class="col-md-6">{$statusicon}<a href="{$forum_url}" title="{$forum_viewers_text_plain}">{$forum['name']}</a></div>
change it to <div class="mycol-md-6m">{$statusicon}<a href="{$forum_url}" title="{$forum_viewers_text_plain}">{$forum['name']}</a></div>

and add below at the bottom of global.css of the theme
.mycol-md-6m {width: 25%;}



RE: MyBB Pro Sub-Forum Issue - Robmeister89 - 2015-02-11

That worked great! In fact I like that better than them being side-by-side Smile