MyBB Community Forums
Bug : Click to edit message replace post content - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: 1.8 Support (https://community.mybb.com/forum-175.html)
+--- Forum: General Support (https://community.mybb.com/forum-176.html)
+--- Thread: Bug : Click to edit message replace post content (/thread-167294.html)

Pages: 1 2


Bug : Click to edit message replace post content - Anavirn - 2015-02-17

Hi,

I'm a new myBB user and I've a problem (a scary one for a newbie like me) :

A lot of post content are replaced by "Click to edit" (not all my post but ~80%)

I really don't know why I've got this problem, everything was working nicely and I was changing nothing in my settings.

Link to a specific page : http://anotherdayz.fr/forum/showthread.php?tid=74

Hope that someone can help, I feel hopeless...

Thanks in advance


RE: Bug : Click to edit message replace post content - Leefish - 2015-02-17

What version of mybb are you using? Have you altered any templates? Are you seeing this issue on the default theme?


If you are just stuck and fed up and just want help making it ok PM me admin cp login details.


RE: Bug : Click to edit message replace post content - Anavirn - 2015-02-17

(2015-02-17, 11:18 PM)Leefish Wrote: What version of mybb are you using? Have you altered any templates? Are you seeing this issue on the default theme?


If you are just stuck and fed up and just want help making it ok PM me admin cp login details.

I'm using 1804, I've changed some template to translate some elements of the theme in french and colors adjustements. I've the same problem with the default theme... 

I send you a PM

Problem is "solved" for the moment. Leefish found that it was added smileys so I delete all of them and posts content was back.

The reason is that I was using phpBB before and merge to myBB.
The merge "replace" phpBB smilies with things like : <!-- s;-) --><img src="{SMILIES_PATH}/icon_e_wink.gif" alt=";-)" title="Wink" /><!-- s;-) -->.

So I'm going to edit all my post and signature to delete that and add smilies again to see if I can have smilies working.

I'll tell you if it's working Wink

Thanks again Leefish !

I've delete every <!-- s;-) --><img src="{SMILIES_PATH}/icon_e_wink.gif" alt=";-)" title="Wink" /><!-- s;-) --> on my database (search %{SMILIES_PATH}% and edit/delete them) and add again my smilies.

ATM everything seems to be working Smile


RE: Bug : Click to edit message replace post content - Gabbar - 2015-07-05

I too having the same problem. What to do?

every post is changed to

"click to edit"

And when I click on edit all its orginal content is there....

What's the problem?

Please Help


RE: Bug : Click to edit message replace post content - .m. - 2015-07-05

^ looks like it is related to custom MyCode / recently added plugin


RE: Bug : Click to edit message replace post content - Gabbar - 2015-07-05

Thanks for reply

but I added quick Advanced Editor Plus (2.1.3)

more than 5 hours ago but now when i checked it showing click to edit error

I decativated the plugin and still its showing this error.

Also when I posted with disable smiley optin enabled the post is displayed with its message

Error Corrected By mistake uploaded a blank smiliey removing it solved the problem.

Thanks For Helping Smile


RE: Bug : Click to edit message replace post content - bladedshard - 2017-01-02

Hello,

I know this is a little late. However I am having the exact same issue. Posts or the thread just shows Click to Edit. But the content is there it just doesn't show.

I have checked to see what has been modified. I have gone over everything numerous times. Everything looks fine.



All I can think to fix it just redoing my forums completely. Is there anything I can do to figure out the issue besides redoing everything?

Please Assist


RE: Bug : Click to edit message replace post content - Matt - 2017-01-02

No problem will require redoing everything Smile If you can give us a URL and test account, we can debug from there.


RE: Bug : Click to edit message replace post content - bladedshard - 2017-01-02

PM Sent with information


RE: Bug : Click to edit message replace post content - Matt - 2017-01-02

I think the issue is that your theme is, for want of a better word, completely screwed Smile You're missing a while bunch of images and styles, it should look much nicer than it does, and I think this issue is basically caused by broken HTML.

If you'd like a brown theme, what I'd recommend you do is this:

Go to ACP > Templates & Style > Create New Theme > call it whatever you want > choose 'Default' from the parent dropdown, submit the form, then scroll down to the bottom to the 'Base Color' setting, choose 'Earth', then go back to Templates & Style, you'll see your new theme in the list, next to it there'll be a button called Options, choose Set as Default, and then when you visit your forum, you should see the default MyBB theme but with a brown colour scheme.