MyBB Community Forums
[For 1.8] DVZ Secure Content 1.1.5 - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Resources (https://community.mybb.com/forum-8.html)
+--- Forum: Plugins (https://community.mybb.com/forum-73.html)
+---- Forum: Plugin Releases (https://community.mybb.com/forum-102.html)
+---- Thread: [For 1.8] DVZ Secure Content 1.1.5 (/thread-168820.html)

Pages: 1 2 3 4 5 6 7 8 9


RE: DVZ Secure Content 1.1.4 - Devilshakerz - 04-06-2017

(04-06-2017, 07:14 PM)Eldenroot Wrote: I use your latest version, how to proxied avatars? I use free image proxy, it works fine for all images in posts, anyone on plugin page in ACP the button for avatars is greyed out.

Try changing line 545 of inc/plugins/dvz_secure_content.php:
$query = $db->simple_select('users', 'uid,avatar', "avatar != '' AND avatar_original = ''");
to:
$query = $db->simple_select('users', 'uid,avatar', "avatar != '' AND avatar NOT LIKE '" . $db->escape_string_like(self::settings('proxy_url')) . "%'");
and running Proxy avatar URLs again.


RE: DVZ Secure Content 1.1.4 - Eldenroot - 04-07-2017

I will try ASAP, not at home right now. I will let you know


RE: DVZ Secure Content 1.1.4 - Eldenroot - 04-09-2017

(04-06-2017, 07:28 PM)Devilshakerz Wrote:
(04-06-2017, 07:14 PM)Eldenroot Wrote: I use your latest version, how to proxied avatars? I use free image proxy, it works fine for all images in posts, anyone on plugin page in ACP the button for avatars is greyed out.

Try changing line 545 of inc/plugins/dvz_secure_content.php:
$query = $db->simple_select('users', 'uid,avatar', "avatar != '' AND avatar_original = ''");
to:
$query = $db->simple_select('users', 'uid,avatar', "avatar != '' AND avatar NOT LIKE '" . $db->escape_string_like(self::settings('proxy_url')) . "%'");
and running Proxy avatar URLs again.

I tried but still same Sad


RE: DVZ Secure Content 1.1.5 - Devilshakerz - 04-15-2017

Version 1.1.5:
  • Fixed check for All remote avatars proxied
  • Minor fixes
Upgrading: overwrite inc/plugins/dvz_secure_content.php.

-----BEGIN PGP SIGNATURE-----

iQEcBAABCAAGBQJY8nC6AAoJEOL9rFzOOKd9WiEH/jvh85r3tvAgAO8G4D59m/H8
hz7c7XucmGTMNQL73VPjkJA+S08Pp3LSQDfi3pJ54EceU1xT2++BDyAEh8k2xEr8
NCFfE9DuY4Ynmqc9rEmvL+N1si8LkWxQ3b4ud80dTDGf2k4a+xXz1QnqW2+EemBd
o2HMZuaD7SZxQ3qZ7m3Yw5hRTvGRyWeL8sM4R9sGX/FBEvKlsl9Z5pn303H7qXKF
yK9ANCpljKRJOJfDHONV1SF6JYkbcMFjyFTqgjoM7BEhCdTM1YSTICedM7o3U7ca
nZ6xqIMkbS6SiHgrVD7q/rJmVTlLWTYgERoHRnUlx0vs7ZqiwG0A89kDDAT688I=
=ejZN
-----END PGP SIGNATURE-----

https://community.mybb.com/mods.php?action=download&pid=450&bid=2526


RE: DVZ Secure Content 1.1.5 - AlexanderPep - 04-26-2017

Nice plugin Smile Very useful Big Grin


RE: DVZ Secure Content 1.1.5 - Burnacid - 04-27-2017

Can't you for images check if https version exists and replace it with https?


RE: DVZ Secure Content 1.1.5 - AlexanderPep - 04-27-2017

I have a problem i guess

i added image proxy with https://images.weserv.nl/

Now if i upload a pics .gif and i put img http://link.gif [/img], the image doesn't have animation, but if you click and open the image in new tab is working....

How can i solve the animation on posts?


RE: DVZ Secure Content 1.1.5 - snakeoilos - 06-07-2017

(04-27-2017, 07:43 PM)AlexanderPep Wrote: I have a problem i guess

i added image proxy with https://images.weserv.nl/

Now if i upload a pics .gif and i put img http://link.gif [/img], the image doesn't have animation, but if you click and open the image in new tab is working....

How can i solve the animation on posts?

Go to their website, from there it'd tell you weserv.nl don't support animated gifs yet..  


On another note,  This plugin works fine with the default theme, but for some reason can't get this to work with w3-responsive #70. How do I troubleshoot this?


RE: DVZ Secure Content 1.1.5 - Devilshakerz - 06-07-2017

(06-07-2017, 01:01 AM)snakeoilos Wrote: On another note,  This plugin works fine with the default theme, but for some reason can't get this to work with w3-responsive #70. How do I troubleshoot this?

Can you provide some examples? What exactly doesn't work?


RE: DVZ Secure Content 1.1.5 - snakeoilos - 06-07-2017

(06-07-2017, 01:11 AM)Devilshakerz Wrote: Can you provide some examples? What exactly doesn't work?
My bad Blush. Should have been more specific.

Image proxy URL to https://images.weserv.nl/ don't seem to work for my w3-responsive theme.

Using the default theme, the two pictures in this page successfully proxied by weserv (site is secure). Change it to w3-responsive (from the footer), and they're no longer proxied (site is insecure).

Thanks in advance.