MyBB Community Forums
MyAlerts v2.0.4 - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Extensions (https://community.mybb.com/forum-201.html)
+--- Forum: Plugins (https://community.mybb.com/forum-73.html)
+---- Forum: Plugin Releases (https://community.mybb.com/forum-102.html)
+---- Thread: MyAlerts v2.0.4 (/thread-171301.html)



RE: MyAlerts v2.0.2 - Claraviolet - 08-25-2015

(08-25-2015, 11:12 AM)Euan T Wrote: If you've got cPanel, there is an option in there to view the error log. I need to PHP version, not the phpMyAdmin version. You can find this in ACP > Tools & Maintenance > View PHP Info.

PHP version: PHP Version 5.4.41


RE: MyAlerts v2.0.2 - Euan T - 08-25-2015

Is there anything in the error log? That version should be fine.


RE: MyAlerts v2.0.2 - fredzy - 08-26-2015

What are the styles should I use to edit the popup, my alerts on mobile have a transparent background, and doesn't my alerts have templates


RE: MyAlerts v2.0.2 - Claraviolet - 08-26-2015

(08-25-2015, 01:24 PM)Euan T Wrote: Is there anything in the error log? That version should be fine.

Error logs are not available on Economy Linux Classic Hosting plans. Sad


RE: MyAlerts v2.0.2 - Euan T - 08-26-2015

(08-26-2015, 12:38 AM)fredzy Wrote: What are the styles should I use to edit the popup, my alerts on mobile have a transparent background, and doesn't my alerts have templates
Hi, MyAlerts ships with an alerts.css file that you can add styles to. It also has several templates under the MyAlerts template group. 
(08-26-2015, 01:28 AM)Claraviolet Wrote:
(08-25-2015, 01:24 PM)Euan T Wrote: Is there anything in the error log? That version should be fine.

Error logs are not available on Economy Linux Classic Hosting plans.    Sad

Try adding the following to the top of inc/plugins/MyAlerts.php

ini_set('display_errors',1);
ini_set('display_startup_errors',1);
error_reporting(-1);



RE: MyAlerts v2.0.2 - Claraviolet - 08-26-2015

(08-26-2015, 06:39 AM)Euan T Wrote:
(08-26-2015, 12:38 AM)fredzy Wrote: What are the styles should I use to edit the popup, my alerts on mobile have a transparent background, and doesn't my alerts have templates
Hi, MyAlerts ships with an alerts.css file that you can add styles to. It also has several templates under the MyAlerts template group. 
(08-26-2015, 01:28 AM)Claraviolet Wrote:
(08-25-2015, 01:24 PM)Euan T Wrote: Is there anything in the error log? That version should be fine.

Error logs are not available on Economy Linux Classic Hosting plans.    Sad

Try adding the following to the top of inc/plugins/MyAlerts.php

ini_set('display_errors',1);
ini_set('display_startup_errors',1);
error_reporting(-1);

Here is the error:

Fatal error: Class MyProfileCommentsMyAlertsFormatter contains 1 abstract method and must therefore be declared abstract or implement the remaining methods (MybbStuff_MyAlerts_Formatter_AbstractFormatter::buildShowLink) in /home/claraviolet/public_html/inc/plugins/myprofile/myprofilecomments.class.php on line 67
What should I do now?


RE: MyAlerts v2.0.2 - Leefish - 08-26-2015

That seems to imply that the issue is in profile comments plugin, not my alerts. Try looking in that plugin release thread for a fix.

http://community.mybb.com/thread-159969-post-1128337.html#pid1128337


RE: MyAlerts v2.0.2 - Whiteneo - 08-26-2015

Yes the problem is many people may use some plugins but you have to know real compatibillyty list and there are only one on that list.

Thankyou Like System, i made the brigde, even i maade for another plugins and it's shared here on this communitty.

You have to configure MyProfile to not work with MyAAlerts, only show notifications on comments. Or try the version i release to maeke it works, i share the latest working version on my site of all mods tested by me, including MyAalerts and some systems like that, but aat the end i recomend you to use only mentioned by author. I say to Euan my own mod to be on the list but not yet so i think maaybe there are something more to do to can be aproved.


RE: MyAlerts v2.0.2 - Euan T - 08-26-2015

(08-26-2015, 03:52 PM)Dark Neo Wrote: Yes the problem is many people may use some plugins but you have to know real compatibillyty list and there are only one on that list.

Thankyou Like System, i made the brigde, even i maade for another plugins and it's shared here on this communitty.

You have to configure MyProfile to not work with MyAAlerts, only show notifications on comments. Or try the version i release to maeke it works, i share the latest working version on my site of all mods tested by me, including MyAalerts and some systems like that, but aat the end i recomend you to use only mentioned by author. I say to Euan my own mod to be on the list but not yet so i think maaybe there are something more to do to can be aproved.

Yep, MyProfile is incompatible as it was designed for an older MyAlerts version.

@Dark Neo I will add it to the list, I just keep forgetting Sad


RE: MyAlerts v2.0.2 - nollidnosnhoj - 08-26-2015

EDIT: Found the problem. Guess I didn't check all the newpoints template.