MyBB Community Forums
cant log in amdin account - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: 1.8 Support (https://community.mybb.com/forum-175.html)
+--- Forum: General Support (https://community.mybb.com/forum-176.html)
+--- Thread: cant log in amdin account (/thread-173720.html)



cant log in amdin account - forolumi - 2015-07-29

Hello, i have an admin account with 2 step auth actived. it was workin fine but yesterday i did deactive and active again the 2 step auth verification without reescan the bar code and now the codes that are generated by google aithenticator is not working, it says "invalid code"

fortunelately i got another Adming account without 2 step verification... how can log in again with the Admin account with 2 step actived?

There is anything i can do??

Thank you!


RE: cant log in amdin account - Cayo - 2015-07-29

Hi,

you need access to your DB (e.g. via phpMyAdmin, depends on your hosting provider).
First you may create an backup of your database - just in case, something goes wrong ;)

Note the correct table prefix, especially if you've more than one MyBB installed on your DB.
The default MyBB table prefix is "mybb_".

1. Get the UID of the affected user
If unsure, you can search the username in your "users" table. Here you can also find the UID.

2. Disable the two factor authentication
Goto the "adminoptions" table and edit the record with the correct UID. Remove the contents
of the field "authsecret" and save/update the record.

Now you should be able to login again, without two factor authentication ;)

Regards


RE: cant log in amdin account - forolumi - 2015-07-29

(2015-07-29, 08:34 PM)Cayo Wrote: Hi,

you need access to your DB (e.g. via phpMyAdmin, depends on your hosting provider).
First you may create an backup of your database - just in case, something goes wrong Wink

Note the correct table prefix, especially if you've more than one MyBB installed on your DB.
The default MyBB table prefix is "mybb_".

1. Get the UID of the affected user
If unsure, you can search the username in your "users" table. Here you can also find the UID.

2. Disable the two factor authentication
Goto the "adminoptions" table and edit the record with the correct UID. Remove the contents
of the field "authsecret" and save/update the record.

Now you should be able to login again, without two factor authentication Wink

Regards

Done! and solved!!!
Many thanks!!!!!!!