MyBB Community Forums
Is 1.6.18 considered "solid" - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Community Archive (https://community.mybb.com/forum-106.html)
+--- Forum: Archived Forums (https://community.mybb.com/forum-143.html)
+---- Forum: Archived Development and Support (https://community.mybb.com/forum-155.html)
+----- Forum: MyBB 1.6 (https://community.mybb.com/forum-138.html)
+------ Forum: 1.6 Security Management and Support (https://community.mybb.com/forum-153.html)
+------ Thread: Is 1.6.18 considered "solid" (/thread-181094.html)



Is 1.6.18 considered "solid" - harry fives - 2015-09-26

Unfortunately I have as many as 4 mybb forums and I am finding it terribly difficult to upgrade to 1.8. I feel it's only prudent for me to have a hard look at what other option I may have.

I have suffered from sql injection in the past and I hope some kind soul can give me guidance here, specifically on whether 1.6.18 is considered free of any known vulnerabilities.

Obviously I wouldn't want to go out of the frying pan into the fire, so to speak, so it would be kind if someone could guide me on whether 1.6.18 is considered pretty solid.

I have read the threads here and also the blog, but I haven't been able to grasp if the final version of 1.6 is considered to be as secure as 1.6 can be made.

I greatly appreciate any assistance.


RE: Is 1.6.18 considered "solid" - Euan T - 2015-09-26

1.6.18 is free from any known vulnerabilities, but that doesn't mean it's 100% secure. I'd definitely recommend upgrading to 1.8 whenever you can to keep benefiting from new features, fixes and security patches.


RE: Is 1.6.18 considered "solid" - Devilshakerz - 2015-09-26

Additionally, upgrading to 1.8 is highly recommended as the support for 1.6 ends on 1 October and no further updates will be provided for that branch, even if new vulnerabilities are discovered.


RE: Is 1.6.18 considered "solid" - harry fives - 2015-09-26

Thank you for your kind replies - which make a lot of sense.

However my problem is that I'm struggling desperately in upgrading to 1.8 - I've only managed to upgrade 1 of 4 forums so far. Given my struggles I feel I have to give serious consideration to 1.6.

It's not ideal, but if I can't upgrade some of my forums to 1.8 I feel that going to 1.6.18 is the next best option.

One of my forums is 1.6.4 and I'm hoping that going to 1.6.18 would be an easier upgrade that suffering the frustrations of trying to go to 1.8.

Again, I thank you for your replies which I did appreciate.


RE: Is 1.6.18 considered "solid" - Destroy666 - 2015-09-27

You can always ask for upgrade help in 1.8 installation/upgrade forum here or pay someone to do it for you in requests/services/jobs section.


RE: Is 1.6.18 considered "solid" - Nathan Malcolm - 2015-09-28

Quote:One of my forums is 1.6.4

You should always make sure your forum is kept up to date. 1.6.4 was released 4 years ago, it's not surprising your forums have been targeted. Many security issues have been fixed since then.

Upgrade to the latest stable 1.6 version and start from there. Once your forum is fully patched you can attempt to upgrade to 1.8. If you have any issues along the way the community will be happy to help. Smile


RE: Is 1.6.18 considered "solid" - harry fives - 2015-09-28

Thank you for your kind replies - which I sincerely appreciate.

I have 4 forums to upgrade and the good news is that I have now managed to successfully upgrade 2 of them to 1.8.6.

Unfortunately 1 of the remaining 2 has a big problem and won't upgrade, as I have explained in this thread:
http://community.mybb.com/thread-181052.html

I'm not sure if even paying someone to do it would solve this problem. Sad

I am working on the other forum now to try and upgrade that one.