MyBB Community Forums
missing tables causing merge failure - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: 1.8 Support (https://community.mybb.com/forum-175.html)
+--- Forum: Merge System Support (https://community.mybb.com/forum-180.html)
+--- Thread: missing tables causing merge failure (/thread-186272.html)

Pages: 1 2


RE: missing tables causing merge failure - Goggalor - 2015-11-13

I did exactly that. EXACTLY.

again, on the upgrade, the new themes did NOT install.

When do to the EXACT steps you give I get the datacache error.


RE: missing tables causing merge failure - expat - 2015-11-13

thats so weird, i just checked my installation and the default is with the prefix mybb_ and i do have mybb_automedia table in there.

So a fresh installation of 1,86 should have mybb_datacache if you keep everything default.....if not then you could try to rename it in phpmyadmin

Also when you export the database select DATA ONLY

Oh and some themes you click "Ignore Version Compatibility" and hope it has proper updates Toungue


RE: missing tables causing merge failure - Goggalor - 2015-11-13

I DID IT! OMG my head is like mush right now but I did it.

OK Here's what I had to do:

Fresh install of Mybb 1.8*
export the OLD UPGRADED database in two stages: EVERYTHING EXCEPT the theme tables
ONLY the attachments and attachtypes (whateveritscalled) tables.

IMPORT the the database minus themes.
Check things. ACP > Tools > rebuild caches and recount and rebuild

UPLOAD via FTP my OLD uploads folder and its contents

IMPORT again the attachments only tables
Check things. ACP > Tools > rebuild & recount attachment thumbs.

Check threads with images. VIOLA! images seem to be there. awesome

NOW I installed automedia. NO PROBLEM and I left the stupid table prefixes the way they were in the forms. Must have been a glitch.

NOW I can install the custom theme I made for 1.8*

so, although this was quite the problematic upgrade I'm glad it happened because I have other boards to upgrade and I really can't have those messed up too!

Thank you for your help expat! It really was helpful because you got me thinking creatively!


RE: missing tables causing merge failure - StefanT - 2015-11-13

(2015-11-13, 04:01 PM)expat Wrote: which is kinda silly coz they should know the upgrade steps.
The upgrade script has 2500 lines. Why spent time porting that to the merge system for something that was never intended to work? We have an upgrade script forum upgrading and the merge system for merging forums.
(2015-11-13, 04:03 PM)Goggalor Wrote: The only reason I can see merging 1.8 to 1.8 is to combine 2 similar forums.
That's what the Merge System is meant for (beside converting from another software which technically still just merges the old forum with an empty MyBB forum).


RE: missing tables causing merge failure - expat - 2015-11-13

(2015-11-13, 05:08 PM)Goggalor Wrote: I DID IT! OMG my head is like mush right now but I did it.

OK Here's what I had to do:

Fresh install of Mybb 1.8*
export the OLD UPGRADED database in two stages: EVERYTHING EXCEPT the theme tables
ONLY the attachments and attachtypes (whateveritscalled) tables.

IMPORT the the database minus themes.
Check things. ACP > Tools > rebuild caches and recount and rebuild

UPLOAD via FTP my OLD uploads folder and its contents

IMPORT again the attachments only tables
Check things. ACP > Tools > rebuild & recount attachment thumbs.

Check threads with images. VIOLA! images seem to be there. awesome

NOW I installed automedia. NO PROBLEM and I left the stupid table prefixes the way they were in the forms. Must have been a glitch.

NOW I can install the custom theme I made for 1.8*

so, although this was quite the problematic upgrade I'm glad it happened because I have other boards to upgrade and I really can't have those messed up too!

Thank you for your help expat! It really was helpful because you got me thinking creatively!

good job, well done


RE: missing tables causing merge failure - Goggalor - 2015-11-13

(2015-11-13, 05:12 PM)StefanT Wrote:
(2015-11-13, 04:01 PM)expat Wrote: which is kinda silly coz they should know the upgrade steps.
The upgrade script has 2500 lines. Why spent time porting that to the merge system for something that was never intended to work? We have an upgrade script forum upgrading and the merge system for merging forums.
(2015-11-13, 04:03 PM)Goggalor Wrote: The only reason I can see merging 1.8 to 1.8 is to combine 2 similar forums.
That's what the Merge System is meant for (beside converting from another software which technically still just merges the old forum with an empty MyBB forum).

Stefan, the upgrade was not working for me at all. It kept corrupting files, themes were not installing as they should have etc. I TRIED the merge out of frustration because the upgrade kept failing.

Post #13 is how I had to do this and no other way worked.

This isn't my first rodeo installing, upgrading or merging a board and that's what did my head in on this.


RE: missing tables causing merge failure - expat - 2015-11-13

Looks like a major theme upgrade from 1.6 to 1.8 that messes the cache system


RE: missing tables causing merge failure - Goggalor - 2015-11-13

(2015-11-13, 05:45 PM)expat Wrote: Looks like a major theme upgrade from 1.6 to 1.8 that messes the cache system

Something! All I know is this was a real pain in the butt and on some of my larger boards at least I know to do it this way first.