MyBB Community Forums
Weird URL Problem? - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: 1.8 Support (https://community.mybb.com/forum-175.html)
+--- Forum: General Support (https://community.mybb.com/forum-176.html)
+--- Thread: Weird URL Problem? (/thread-186489.html)



Weird URL Problem? - Glandus - 11-20-2015

I have a weird problem with my forum that I haven't experienced before. Basically, my forum works great without www. in the URL, but with it, my sidebox stops working, and the table/font size change.

Example
forumlair.com
www.forumlair.com

Try it without the www. and you will see everything loads fine. Then, try it again with the www. and it changes the forum. I should note that I am pulling the latest threads, stats and whos online from the portal for my sidebox, but that shouldn't affect it, right?

I also have Google SEO installed, but as far as I know (searched for ages), nobody else has had this problem.


RE: Weird URL Problem? - Nathan Malcolm - 11-20-2015

Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at http://forumlair.com/portal.php. (Reason: CORS header 'Access-Control-Allow-Origin' missing).

<script type="text/javascript">
jQuery(function(){
$(".latestthreads").load("http://forumlair.com/portal.php .latestthreads_portal");
$(".whosonline").load("http://forumlair.com/portal.php .whosonline");
$(".lateststats").load("http://forumlair.com/portal.php .lateststats");
}); </script>

You can't load() from a different (sub)domain.

Redirect www.forumlair.com to forumlair.com or forumlair.com to www.forumlair.com.


RE: Weird URL Problem? - Glandus - 11-20-2015

Thank you.

Fixed!