MyBB Community Forums
MyBB Upgrade to 1.8 Can't Access Admin CP - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: 1.8 Support (https://community.mybb.com/forum-175.html)
+--- Forum: General Support (https://community.mybb.com/forum-176.html)
+--- Thread: MyBB Upgrade to 1.8 Can't Access Admin CP (/thread-186728.html)

Pages: 1 2


MyBB Upgrade to 1.8 Can't Access Admin CP - zodearest223 - 2015-11-29

Moments ago I upgraded from version 1.6 to 1.8. I removed the lock file from /install and the installation went smooth. At the end it prompted me to view my forum to make sure all was functioning accordingly. Everything is except for my Admin CP which is blank after I log into my Admin CP. It does not give me an error code, the page is simply slate white.

URL of site: http://tokyoghoul.decadence-rpg.net/


RE: MyBB Upgrade to 1.8 Can't Access Admin CP - s3_gunzel - 2015-11-29

PHP compatibility issue. Find out from your host what version of PHP you are running and request their PHP 5.5 variant if possible. I'm still hesitant to suggest PHP 5.6 as I haven't used it yet.


RE: MyBB Upgrade to 1.8 Can't Access Admin CP - zodearest223 - 2015-11-29

(2015-11-29, 04:31 AM)Ben Cousins Wrote: PHP compatibility issue. Find out from your host what version of PHP you are running and request their PHP 5.5 variant if possible. I'm still hesitant to suggest PHP 5.6 as I haven't used it yet.

I changed the Variant to PHP 5.5 and now no pages of my forum work.

- - - - - - - - - -

I added this after the first few lines of code in my admin/index

error_reporting(E_ALL);
ini_set('display_errors', '1');

And the Admin CP now gives me this error after I log in

Warning: Call-time pass-by-reference has been deprecated in /home/decadenc/public_html/tokyoghoul/inc/plugins/multilogin.php on line 206

Fatal error: Call to undefined method pluginSystem::run_hooks_by_ref() in /home/decadenc/public_html/tokyoghoul/admin/modules/postinpoints/module_meta.php on line 26

- - - - - -

I am now able to access the admin CP however, user profiles will not show when you click on a user's name. Those pages are now blank.

- - - - - -

This is what the page now also looks like for when you go to make a new post http://i.imgur.com/Elvn5lR.jpg


RE: MyBB Upgrade to 1.8 Can't Access Admin CP - s3_gunzel - 2015-11-29

One of your plugins is knacked. I don't know which one.


RE: MyBB Upgrade to 1.8 Can't Access Admin CP - zodearest223 - 2015-11-29

(2015-11-29, 07:32 AM)Ben Cousins Wrote: One of your plugins is knacked. I don't know which one.

This is with all my plugins disabled. None of my plugins are compatible with 1.8.6 and my forum isd basically ruined thanks to this update.


RE: MyBB Upgrade to 1.8 Can't Access Admin CP - Dark-Power-Invader - 2015-11-29

Look like you are using a 1.6 theme on 1.8


RE: MyBB Upgrade to 1.8 Can't Access Admin CP - Euan T - 2015-11-29

(2015-11-29, 04:39 AM)zodearest223 Wrote:
(2015-11-29, 04:31 AM)Ben Cousins Wrote: PHP compatibility issue. Find out from your host what version of PHP you are running and request their PHP 5.5 variant if possible. I'm still hesitant to suggest PHP 5.6 as I haven't used it yet.

I changed the Variant to PHP 5.5 and now no pages of my forum work.

- - - - - - - - - -

I added this after the first few lines of code in my admin/index

error_reporting(E_ALL);
ini_set('display_errors', '1');

And the Admin CP now gives me this error after I log in

Warning: Call-time pass-by-reference has been deprecated in /home/decadenc/public_html/tokyoghoul/inc/plugins/multilogin.php on line 206

Fatal error: Call to undefined method pluginSystem::run_hooks_by_ref() in /home/decadenc/public_html/tokyoghoul/admin/modules/postinpoints/module_meta.php on line 26

- - - - - -

I am now able to access the admin CP however, user profiles will not show when you click on a user's name. Those pages are now blank.

- - - - - -

This is what the page now also looks like for when you go to make a new post http://i.imgur.com/Elvn5lR.jpg

Looks like you have a plugin "postinpoints", which adds an ACP module. Delete the file "admin/modules/postinpoints/module_meta.php" file. The other plugin causing a problem is called "multilogin.php" - it uses call time reference passing, which is incompatible with current versions of PHP.

Regarding PHP 5.6, MyBB 1.8 is fully compatible.


RE: MyBB Upgrade to 1.8 Can't Access Admin CP - zodearest223 - 2015-11-29

Dark Power Invader

My theme's templates and style sheets were all changed to be 1.8.6 from 1.6 and the problem still persists.

Euan T

I fixed this sometime earlier when I found out what the error meant. Those plugins no longer exists yet there are still many issues on my forum. :/

The main issues I need help with now are none of the new up to date plugins I download and put on my forum are working such as New Points, Xthreads and more. I need these plugins to make my forum run successfully due to features they rely on.

At this point is there anyway I can revert back to the 1.6 version? This is such a headache and I never needed support when I was using the 1.6 version and fully understand support is no longer offered for that version.


RE: MyBB Upgrade to 1.8 Can't Access Admin CP - StefanT - 2015-11-29

Reverting back to MyBB 1.6 won't fix that error because it's a plugin being not compatible with the PHP version.


RE: MyBB Upgrade to 1.8 Can't Access Admin CP - zodearest223 - 2015-11-29

(2015-11-29, 08:34 PM)StefanT Wrote: Reverting back to MyBB 1.6 won't fix that error because it's a plugin being not compatible with the PHP version.
 Everything was working 100% until I decided to update to 1.8.6. There was 0 compatibility issues with my PHP version.

- - - - - -

I have tried to download and install this new version of New Points which says it's compatible with 1.8.x ( http://community.mybb.com/mods.php?action=view&pid=94 ) but to no avail it does not work nor update in the plugins area of my Admin CP. This is what the plugins area looks like currently. None of the plugins I had before will activate or install. Even the ones that don't say in red they aren't compatible. ( http://i.imgur.com/IatkZrL.jpg )

Also the PHP version I have is 5.6 ( http://i.imgur.com/foZxcYo.jpg ) as seen there. I have also been able to edit it to 5.5 and nothing changes.