MyBB Community Forums
While You Were Typing "r/n/" issue - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Extensions (https://community.mybb.com/forum-201.html)
+--- Forum: Plugins (https://community.mybb.com/forum-73.html)
+---- Forum: Plugin Support (https://community.mybb.com/forum-72.html)
+---- Thread: While You Were Typing "r/n/" issue (/thread-189213.html)



While You Were Typing "r/n/" issue - Sintra - 2016-02-21

Hello,

I am using the While You Were Typing plugin on my forum (1.8.4). Previously I had it on a 1.6 forum and it was working great. After the upgrade, though, when there is a new post sent before me, and it shows up on the topic, the reply I wrote (in the quick reply form) just removes all the lines and adds something like "r/n/" in between the lines. I understand that this is PHP related but my PHP knowledge is zero. (I realized that it may be because of the upgrade but I also installed it on a clean install 1.8 forum and the issue still continues.)


The link to the plugin: http://doylecc.altervista.org/en/while.html 

Maybe I can deactivate the quick reply function (Like, when I try to post, it will redirect me to the new reply page and maybe this can resolve the problem but I don't know how).

The real time function is disabled, by the way.

Thank you.


RE: While You Were Typing "r/n/" issue - .m. - 2016-02-21

are you using the latest available version of the plugin (for MyBB 1.8.x) ?


RE: While You Were Typing "r/n/" issue - Sintra - 2016-02-21

Yes, it is the latest version.


RE: While You Were Typing "r/n/" issue - ItsLogicalMate - 2016-02-22

(2016-02-21, 01:17 PM)Sintra Wrote: Hello,

I am using the While You Were Typing plugin on my forum (1.8.4). Previously I had it on a 1.6 forum and it was working great. After the upgrade, though, when there is a new post sent before me, and it shows up on the topic, the reply I wrote (in the quick reply form) just removes all the lines and adds something like "r/n/" in between the lines. I understand that this is PHP related but my PHP knowledge is zero. (I realized that it may be because of the upgrade but I also installed it on a clean install 1.8 forum and the issue still continues.)


The link to the plugin: http://doylecc.altervista.org/en/while.html 

Maybe I can deactivate the quick reply function (Like, when I try to post, it will redirect me to the new reply page and maybe this can resolve the problem but I don't know how).

The real time function is disabled, by the way.

Thank you.

I recommend downloading from MyBB Mods.

To make the plugin compatible with 1.8, do the following:

Go to inc > plugins and edit the file associated with While You Were Typing
]
find the compatibility line, it will say 16*, change it to 18*, see if that works


RE: While You Were Typing "r/n/" issue - Eldenroot - 2016-02-22

There is a plugin for MyBB 1.8 in the official mods site here in forum.


RE: While You Were Typing "r/n/" issue - Sintra - 2016-02-22

Thanks for the replies.

I installed the plugin from the mods site. However, this one breaks the quick reply's ajax function. The spinner image does not go away but it sends the message.
I guess that's one of the things doylecc fixed when adapting it to 1.8.

Edit: I've searched the main php file of the plugin and found this line which I think talks about the message and it has the problematic \r\n sequence. Would editing this solve the problem?
print '</div>';
			$return_message = addcslashes(addslashes($mybb->input['message']),"\r\n");
			print '<script>if($("whiletyping_quickreply_message")){ $("whiletyping_quickreply_message").scrollTo(); } window.setTimeout(function(){ ';
			if(whiletyping__plugin_exists("advancedquickreplyform"))
			{
				print 'if($("message_new")){ $("message_new").value = "'.$return_message.'" } ';
				print 'if($("message_old")){ $("message_old").value = "'.$return_message.'" } ';
			}
			print 'if($("message")){ $("message").value = "'.$return_message.'"; } }, 500);</script>';
			
			$_SESSION['page_access_time'] = time();
			
			die();

(2016-02-22, 12:05 PM)Eldenroot Wrote: There is a plugin for MyBB 1.8 in the official mods site here in forum.

Are you talking about this one? http://mods.mybb.com/view/while-you-were-typing This is for 1.6
I couldn't find it here: http://community.mybb.com/mods.php


RE: While You Were Typing "r/n/" issue - Eldenroot - 2016-02-23

this one:
http://community.mybb.com/mods.php?action=view&pid=609


RE: While You Were Typing "r/n/" issue - Sintra - 2016-02-23

Thank you Eldenroot!
This one works like a charm.