MyBB Community Forums
Discuss: MyBB 1.2.7 Released - Security & Maintenance Release - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: Community Archive (https://community.mybb.com/forum-106.html)
+--- Forum: Archived Forums (https://community.mybb.com/forum-143.html)
+---- Forum: Miscellaneous Archive (https://community.mybb.com/forum-140.html)
+----- Forum: Old Announcements (https://community.mybb.com/forum-2.html)
+------ Forum: Announcements Discussion (https://community.mybb.com/forum-31.html)
+------ Thread: Discuss: MyBB 1.2.7 Released - Security & Maintenance Release (/thread-19242.html)

Pages: 1 2 3 4 5 6 7 8 9 10 11


RE: Discuss: MyBB 1.2.7 Released - Security & Maintenance Release - roy - 2007-05-16

Thanks Chris ...


RE: Discuss: MyBB 1.2.7 Released - Security & Maintenance Release - crsoft - 2007-05-16

Well its funny some people have been getting errors with the update but i do not seem non of that. but i have to say again good job i love the update it made my forum a lot faster.


RE: Discuss: MyBB 1.2.7 Released - Security & Maintenance Release - richjohnny - 2007-05-16

I sure hope the next release is MyBB 1.4 or 2.0. That means BIG CHANGE.


RE: Discuss: MyBB 1.2.7 Released - Security & Maintenance Release - Ryan Gordon - 2007-05-16

Quantage Wrote:It broke my MyBB, lol.

I uploaded all of the files. And when I try to go to home/install/upgrade.php it comes up with this :/

Warning: require_once(/home/quantage/public_html/usf/inc/db_.php) [function.require-once]: failed to open stream: No such file or directory in /home/quantage/public_html/usf/install/upgrade.php on line 25

Fatal error: require_once() [function.require]: Failed opening required '/home/quantage/public_html/usf/inc/db_.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/quantage/public_html/usf/install/upgrade.php on line 25

If I try to go to my main directory, I get a message saying that MyBB isn't installed.

Please help Smile
Thanks,
~Matt


This has happened and been discussed before many times. It's because you started to go through the INSTALL process, which overwrites your config.php. You just need to recreate your config.php as started above by damnidunno.

damnidunno Wrote:Also im having a problem with alot of the modifications i use.
Some of them give me this error after i upgraded:
Quote:Depreciated function call: update_thread_count
they never did this until this previous upgrade. I dont know how to fix them, so i just deactivated them for now and the error is gone.

The plugin authors will need to update their plugins. Until then you need to deactivate them our learn how the new system works by going into inc/functions_rebuild.php and inc/functions.php and looking for function upgrade_thread_counters and learning how they work.


RE: Discuss: MyBB 1.2.7 Released - Security & Maintenance Release - salehforum - 2007-05-16

I replaced just the root files and i checked my forum
but there was an error in global.php SO my forum didn't open
I must replace another files?
if I want to correct this PROBLEM I must replaced another files?
this is me error:

Fatal error: Call to undefined function: is_banned_ip() in /home/salehfor/public_html/global.php on line 357
i replaced another files and it is my error:

MySQL error: 1054
Unknown column 'b.olddisplaygroup' in 'field list'
Query: SELECT u.*, f.*, b.dateline AS bandate, b.lifted AS banlifted, b.oldgroup AS banoldgroup, b.olddisplaygroup as banolddisplaygroup, b.oldadditionalgroups as banoldadditionalgroups FROM mybb_users u LEFT JOIN mybb_userfields f ON (f.ufid=u.uid) LEFT JOIN mybb_banned b ON (b.uid=u.uid) WHERE u.uid='1'


RE: Discuss: MyBB 1.2.7 Released - Security & Maintenance Release - DragonLord - 2007-05-16

Well i have not face any problems so far and the updating is done too, thanks you Chris Big Grin


RE: Discuss: MyBB 1.2.7 Released - Security & Maintenance Release - Chris W. B. - 2007-05-16

Thanks for the update. Smile


RE: Discuss: MyBB 1.2.7 Released - Security & Maintenance Release - judel - 2007-05-16

salehforum, did you run the install/upgrade.php? Smile

As like last time, I will wait a few days to see if any problems are discovered before I attempt the upgrade!


RE: Discuss: MyBB 1.2.7 Released - Security & Maintenance Release - The Grinch - 2007-05-16

Tikitiki Wrote:
Quantage Wrote:It broke my MyBB, lol.

I uploaded all of the files. And when I try to go to home/install/upgrade.php it comes up with this :/

Warning: require_once(/home/quantage/public_html/usf/inc/db_.php) [function.require-once]: failed to open stream: No such file or directory in /home/quantage/public_html/usf/install/upgrade.php on line 25

Fatal error: require_once() [function.require]: Failed opening required '/home/quantage/public_html/usf/inc/db_.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/quantage/public_html/usf/install/upgrade.php on line 25

If I try to go to my main directory, I get a message saying that MyBB isn't installed.

Please help Smile
Thanks,
~Matt

OR they just upload all the new files in the upgradewhich overwrites the existing config.php. Alot of people do this without thinking. Like me Smile


RE: Discuss: MyBB 1.2.7 Released - Security & Maintenance Release - judel - 2007-05-16

Well, if you're upgrading and only upload the changed files, you won't have that problem! Big Grin