MyBB Community Forums
A way of hiding a forum from members - Printable Version

+- MyBB Community Forums (https://community.mybb.com)
+-- Forum: 1.8 Support (https://community.mybb.com/forum-175.html)
+--- Forum: General Support (https://community.mybb.com/forum-176.html)
+--- Thread: A way of hiding a forum from members (/thread-192742.html)



A way of hiding a forum from members - Starlight - 2016-05-08

Hi Smile

I am merging a forum with mybb and I've been thinking how I am going to do this without the members seeing. I don't want them to see the forum until it's ready. 

I thought of doing this in a new server&domain and only when I had everything ready then I would just park the forum domain to it. Will it work? If I just change the forum url and cookie settings once the forum domain is connected to the forum itself. Or do I need to do more than those two things? With plugins as well or changing the url and cookie path will solve everything?

Thanks!

Or is there a way of doing this on the main domain without regular users seeing what's going on?


RE: A way of hiding a forum from members - .m. - 2016-05-09

I prefer merging offline (eg. by using XAMPP local server) and transfer the processed system to live web server.


RE: A way of hiding a forum from members - Starlight - 2016-05-17

^^^

I am doing the merge with XAMPP now as you suggested, but I came across an issue - not sure if that's an issue...

On a live server this didn't happen when I first tried the merge system. However, on localhost if "convert everything to utf-8" (or similar) is selected, it gets stuck when running users. Not sure if converting everything to utf-8 is absolutely necessary, but for now I unselected that option and it is running/merging smoothly.

I am just not sure if it will mess up posts and threads with that unselected since I had a few strange things happening with weird characters randomly showing up on my smf forum. :/

Okay, merge done! And woah! I should've done this from the start. All the problems I got from the first merge on the server didn't happen this time! Avatars are looking good (first time around they looked weird); the count of posts and threads is correct and so on! I won't have anything to change now! Smile

I just did it without converting everything to utf-8 while the first time I did. Didn't notice any difference so I think it's okay to do it without enabling that option? My forum is in portuguese.